#1732 closed defect (invalid)

mpc5566evb does not build

Reported by: Ralf Corsepius Owned by: Sebastian Huber
Priority: normal Milestone: 4.10
Component: bsps Version: 4.10
Severity: major Keywords:
Cc: sebastian.huber@… Blocked By:
Blocking:

Description

powerpc-rtems4.10-gcc --pipe -B../../../../../.././lib/ -B../../../../../.././mpc5566evb/lib/ -specs bsp_specs -qrtems -DHAVE_CONFIG_H -isystem ../../../../../.././mpc5566evb/lib/include -mcpu=8540 -meabi -msdata -fno-common -msoft-float -Dppc_generic -mstrict-align -O2 -g -fno-keep-inline-functions -Wall -Wimplicit-function-declaration -Wstrict-prototypes -Wnested-externs -MT bspstart.o -MD -MP -MF .deps/bspstart.Tpo -c -o bspstart.o test -f 'startup/bspstart.c' || echo '../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/'startup/bspstart.c
../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/startup/bspstart.c:147: error: 'MPC55XX_FMPLL_PREDIV' undeclared here (not in a function)
../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/startup/bspstart.c:148: error: 'MPC55XX_FMPLL_MFD' undeclared here (not in a function)
../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/startup/bspstart.c: In function 'bsp_start':
../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/startup/bspstart.c:396: warning: assignment makes integer from pointer without a cast
../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/startup/bspstart.c:449: error: 'MPC55XX_EMIOS_PRESCALER' undeclared (first use in this function)
../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/startup/bspstart.c:449: error: (Each undeclared identifier is reported only once
../../../../../../../../c/src/lib/libbsp/powerpc/mpc55xxevb/startup/bspstart.c:449: error: for each function it appears in.)
gmake[4]: * [bspstart.o] Error 1

At this point in time, such kind of breakdowns are inacceptable.

=> Either this breakdown will be fixed very soon or this BSP will have to be removed.

Change History (2)

comment:1 Changed on Jan 27, 2011 at 11:34:40 AM by Sebastian Huber

Cc: Sebastian Huber added
Milestone: 4.114.10
Owner: changed from Joel Sherrill to Sebastian Huber

comment:2 Changed on Feb 2, 2011 at 5:00:33 AM by Ralf Corsepius

Resolution: invalid
Status: newclosed

No idea about the cause - Probably a local screw up.

Closing as invalid

Note: See TracTickets for help on using tickets.