#1687 closed defect (fixed)

powerpc-rtems4.[10|11]/motorola_powerpc: Linking sample's *.exe segfaults

Reported by: Ralf Corsepius Owned by: Joel Sherrill
Priority: normal Milestone: 4.10
Component: bsps Version: 4.10
Severity: blocker Keywords:
Cc: Blocked By:
Blocking:

Description

I am facing segfaults from ld for several powerpc BSPs:

powerpc-rtems4.11/c/mcp750/log:/bin/sh: line 1: 18480 Segmentation fault (core dumped) powerpc-rtems4.11-ld -o ticker.ralf ../../../../../mcp750/lib/bootloader.o --just-symbols=ticker.exe -b binary rtems.gz -T ../../../../../mcp750/lib/ppcboot.lds -Map ticker.map

powerpc-rtems4.11/c/mtx603e/log:/bin/sh: line 1: 12956 Segmentation fault (core dumped) powerpc-rtems4.11-ld -o ticker.ralf ../../../../../mtx603e/lib/bootloader.o --just-symbols=ticker.exe -b binary rtems.gz -T ../../../../../mtx603e/lib/ppcboot.lds -Map ticker.map

powerpc-rtems4.11/c/mvme2100/log:/bin/sh: line 1: 13630 Segmentation fault (core dumped) powerpc-rtems4.11-ld -o ticker.ralf ../../../../../mvme2100/lib/bootloader.o --just-symbols=ticker.exe -b binary rtems.gz -T ../../../../../mvme2100/lib/ppcboot.lds -Map ticker.map

powerpc-rtems4.11/c/mvme2307/log:/bin/sh: line 1: 14305 Segmentation fault (core dumped) powerpc-rtems4.11-ld -o ticker.ralf ../../../../../mvme2307/lib/bootloader.o --just-symbols=ticker.exe -b binary rtems.gz -T ../../../../../mvme2307/lib/ppcboot.lds -Map ticker.map

# powerpc-rtems4.11-gcc --version
powerpc-rtems4.11-gcc (GCC) 4.5.1 20100731 (RTEMS gcc-4.5.1-5.fc13/newlib-1.18.0-20.fc13)

Change History (5)

comment:1 Changed on Aug 20, 2010 at 2:39:16 PM by Ralf Corsepius

Severity: normalcritical

comment:2 Changed on Aug 20, 2010 at 2:55:16 PM by Ralf Corsepius

Version: HEAD4.10

comment:3 Changed on Aug 21, 2010 at 2:04:38 AM by Ralf Corsepius

Severity: criticalblocker
Summary: powerpc-rtems4.11: Linking ticker.exe segfaultspowerpc-rtems4.[10|11]/motorola_powerpc: Linking sample's *.exe segfaults

comment:4 Changed on Aug 22, 2010 at 5:23:25 AM by Ralf Corsepius

Milestone: 4.114.10

comment:5 Changed on Aug 26, 2010 at 1:59:17 AM by Ralf Corsepius

Resolution: fixed
Status: newclosed

H.J.Lu seems to have found the cause and has provided a "cludge":
http://sourceware.org/bugzilla/show_bug.cgi?id=11939#c4

As this patch works sufficiently for me, I will adopt his patch at least to the rtems-4.10 and rtems-4.11 binutils packages.

Note: See TracTickets for help on using tickets.