#1637 closed defect (fixed)

Broken CVS Ids

Reported by: Ralf Corsepius Owned by: Joel Sherrill
Priority: normal Milestone: 4.11
Component: unspecified Version: 4.11
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

# grep -R '\$Id\$' testsuites
testsuites/sptests/sp69/sp69.doc:# $Id$
testsuites/sptests/spfifo02/spfifo02.doc:# $Id$
testsuites/sptests/sp27a/sp27a.doc:# $Id$
testsuites/sptests/sp60/sp60.doc:# $Id$
testsuites/sptests/spintrcritical12/spintrcritical12.doc:# $Id$
testsuites/sptests/sp53/sp53.doc:# $Id$
testsuites/sptests/sp41/sp41.doc:# $Id$
testsuites/sptests/spcoverage/spcoverage.doc:# $Id$
testsuites/sptests/spwkspace/spwkspace.doc:# $Id$
testsuites/sptests/spintrcritical01/spintrcritical01.doc:# $Id$
testsuites/sptests/sp47/sp47.doc:# $Id$
testsuites/sptests/sp40/sp40.doc:# $Id$
testsuites/sptests/spfatal05/spfatal05.doc:# $Id$
testsuites/sptests/spintrcritical07/spintrcritical07.doc:# $Id$
testsuites/sptests/sp57/sp57.doc:# $Id$
testsuites/sptests/sp37/sp37.doc:# $Id$
testsuites/sptests/spfatal06/spfatal06.doc:# $Id$
testsuites/sptests/spfatal16/spfatal16.doc:# $Id$
testsuites/sptests/spfatal14/spfatal14.doc:# $Id$
testsuites/sptests/sp55/sp55.doc:# $Id$
testsuites/sptests/spintrcritical17/spintrcritical17.doc:# $Id$
testsuites/sptests/sp49/sp49.doc:# $Id$
testsuites/sptests/sp18/sp18.doc:# $Id$
testsuites/sptests/spintrcritical04/spintrcritical04.doc:# $Id$
testsuites/sptests/sp43/sp43.doc:# $Id$
testsuites/sptests/spfatal22/spfatal22.doc:# $Id$
testsuites/sptests/sp58/sp58.doc:# $Id$
testsuites/sptests/spintrcritical05/spintrcritical05.doc:# $Id$
testsuites/sptests/sp66/sp66.doc:# $Id$
testsuites/sptests/spclockget/spclockget.doc:# $Id$
testsuites/sptests/sp51/sp51.doc:# $Id$
testsuites/sptests/spintrcritical16/spintrcritical16.doc:# $Id$
testsuites/sptests/sp71/sp71.doc:# $Id$
testsuites/sptests/spintrcritical11/spintrcritical11.doc:# $Id$
testsuites/sptests/sp54/sp54.doc:# $Id$
testsuites/sptests/spintrcritical15/spintrcritical15.doc:# $Id$
testsuites/sptests/sp72/sp72.doc:# $Id$
testsuites/sptests/spfatal13/spfatal13.doc:# $Id$
testsuites/sptests/sp42/sp42.doc:# $Id$
testsuites/sptests/spfatal18/spfatal18.doc:# $Id$
testsuites/sptests/spfatal09/spfatal09.doc:# $Id$
testsuites/sptests/sp70/sp70.doc:# $Id$
testsuites/sptests/spobjgetnext/spobjgetnext.doc:# $Id$
testsuites/sptests/spsize/spsize.doc:# $Id$
testsuites/sptests/spfatal08/spfatal08.doc:# $Id$
testsuites/sptests/spintrcritical09/spintrcritical09.doc:# $Id$
testsuites/sptests/sp52/sp52.doc:# $Id$
testsuites/sptests/sp61/sp61.doc:# $Id$
testsuites/sptests/spfatal04/spfatal04.doc:# $Id$
testsuites/sptests/sp64/sp64.doc:# $Id$
testsuites/sptests/spwatchdog/spwatchdog.doc:# $Id$
testsuites/sptests/spnotepad01/spnotepad01.doc:# $Id$
testsuites/sptests/sp65/sp65.doc:# $Id$
testsuites/sptests/sp38/sp38.doc:# $Id$
testsuites/sptests/sp67/sp67.doc:# $Id$
testsuites/sptests/sp48/sp48.doc:# $Id$
testsuites/sptests/spintrcritical02/spintrcritical02.doc:# $Id$
testsuites/sptests/spfatal15/spfatal15.doc:# $Id$
testsuites/sptests/spfatal10/spfatal10.doc:# $Id$
testsuites/sptests/spprintk/spprintk.doc:# $Id$
testsuites/sptests/spintrcritical10/spintrcritical10.doc:# $Id$
testsuites/sptests/spchain/spchain.doc:# $Id$
testsuites/sptests/sp68/sp68.doc:# $Id$
testsuites/sptests/spfatal07/spfatal07.doc:# $Id$
testsuites/sptests/sp39/sp39.doc:# $Id$
testsuites/sptests/sp33/sp33.doc:# $Id$
testsuites/sptests/spintrcritical13/spintrcritical13.doc:# $Id$
testsuites/sptests/spfatal19/spfatal19.doc:# $Id$
testsuites/sptests/spfatal02/spfatal02.doc:# $Id$
testsuites/sptests/sp32/sp32.doc:# $Id$
testsuites/sptests/spfatal01/spfatal01.doc:# $Id$
testsuites/sptests/spfatal11/spfatal11.doc:# $Id$
testsuites/sptests/spthreadq01/spthreadq01.doc:# $Id$
testsuites/sptests/sp59/sp59.doc:# $Id$
testsuites/sptests/spintrcritical06/spintrcritical06.doc:# $Id$
testsuites/sptests/spfatal21/spfatal21.doc:# $Id$
testsuites/sptests/spintrcritical08/spintrcritical08.doc:# $Id$
testsuites/sptests/spfatal03/spfatal03.doc:# $Id$
testsuites/sptests/spintrcritical14/spintrcritical14.doc:# $Id$
testsuites/sptests/spfatal20/spfatal20.doc:# $Id$
testsuites/sptests/sp63/sp63.doc:# $Id$
testsuites/sptests/spmkdir/spmkdir.doc:## $Id$
testsuites/sptests/spstkalloc/spstkalloc.doc:# $Id$
testsuites/sptests/sp56/sp56.doc:# $Id$
testsuites/sptests/spfatal17/spfatal17.doc:# $Id$
testsuites/sptests/sp44/sp44.doc:# $Id$
testsuites/sptests/sp62/sp62.doc:# $Id$
testsuites/sptests/spfatal12/spfatal12.doc:# $Id$
testsuites/sptests/sp50/sp50.doc:# $Id$
testsuites/sptests/sp10/sp10.doc:# $Id$
testsuites/sptests/spintrcritical03/spintrcritical03.doc:# $Id$
testsuites/libtests/termios02/termios02.doc:# $Id$
testsuites/libtests/devfs03/devfs03.doc:# $Id$
testsuites/libtests/malloc05/malloc05.doc:# $Id$
testsuites/libtests/termios04/termios04.doc:# $Id$
testsuites/libtests/tztest/tztest.doc:# $Id$
testsuites/libtests/termios01/termios01.doc:# $Id$
testsuites/libtests/devfs02/devfs02.doc:# $Id$
testsuites/libtests/termios05/termios05.doc:# $Id$
testsuites/libtests/devfs04/devfs04.doc:# $Id$
testsuites/libtests/termios06/termios06.doc:# $Id$
testsuites/libtests/tar03/tar03.doc:# $Id$
testsuites/libtests/stringto01/stringto01.doc:# $Id$
testsuites/libtests/devfs01/devfs01.doc:# $Id$
testsuites/libtests/termios03/termios03.doc:# $Id$
testsuites/libtests/malloc02/malloc02.doc:# $Id$
testsuites/libtests/termios07/termios07.doc:# $Id$
testsuites/libtests/tar02/tar02.doc:# $Id$
testsuites/libtests/malloc03/malloc03.doc:# $Id$
testsuites/libtests/termios08/termios08.doc:# $Id$
testsuites/libtests/gxx02/gxx02.doc:# $Id$
testsuites/libtests/gxx01/gxx01.doc:# $Id$
testsuites/libtests/devnullfatal01/devnullfatal01.doc:# $Id$
testsuites/libtests/tar01/tar01.doc:# $Id$
testsuites/libtests/malloc04/malloc04.doc:# $Id$
testsuites/libtests/bspcmdline01/bspcmdline01.doc:# $Id$
testsuites/samples/capture/capture.doc:# $Id$
testsuites/psxtests/psxkey03/psxkey03.doc:# $Id$
testsuites/psxtests/psxmutexattr01/psxmutexattr01.doc:# $Id$
testsuites/psxtests/psximfs01/psximfs01.doc:# $Id$
testsuites/psxtests/psxcancel01/psxcancel01.doc:# $Id$
testsuites/psxtests/psxsignal04/psxsignal04.doc:# $Id$
testsuites/psxtests/psxsignal05/psxsignal05.doc:# $Id$
testsuites/psxtests/psxspin02/psxspin02.doc:# $Id$
testsuites/psxtests/psxautoinit02/psxautoinit02.doc:# $Id$
testsuites/psxtests/psxgetrusage01/psxgetrusage01.doc:# $Id$
testsuites/psxtests/psxcleanup01/psxcleanup01.doc:# $Id$
testsuites/psxtests/psxpasswd01/psxpasswd01.doc:# $Id$
testsuites/psxtests/psxmsgq04/psxmsgq04.doc:# $Id$
testsuites/psxtests/psxstack01/psxstack01.doc:# $Id$
testsuites/psxtests/psxobj01/psxobj01.doc:# $Id$
testsuites/psxtests/psxcancel/psxcancel.doc:# $Id$
testsuites/psxtests/psxtimes01/psxtimes01.doc:# $Id$
testsuites/psxtests/psxpasswd02/psxpasswd02.doc:# $Id$
testsuites/psxtests/psxintrcritical01/psxintrcritical01.doc:# $Id$
testsuites/psxtests/psxkey02/psxkey02.doc:# $Id$
testsuites/psxtests/psxalarm01/psxalarm01.doc:# $Id$
testsuites/psxtests/psxusleep/psxusleep.doc:# $Id$
testsuites/psxtests/psxfchx01/psxfchx01.doc:# $Id$
testsuites/psxtests/psxid01/psxid01.doc:# $Id$
testsuites/psxtests/psxsignal02/psxsignal02.doc:# $Id$
testsuites/psxtests/psxfile02/psxfile02.doc:# $Id$
testsuites/psxtests/psxclock/psxclock.doc:# $Id$
testsuites/psxtests/psxcond01/psxcond01.doc:# $Id$
testsuites/psxtests/psxenosys/psxenosys.doc:# $Id$
testsuites/psxtests/psxpipe01/psxpipe01.doc:# $Id$
testsuites/psxtests/psxsignal03/psxsignal03.doc:# $Id$
testsuites/psxtests/psxmsgq03/psxmsgq03.doc:# $Id$
testsuites/psxtests/psxfilelock01/psxfilelock01.doc:# $Id$

Change History (3)

comment:1 Changed on Jul 28, 2010 at 1:26:52 PM by Joel Sherrill

Resolution: fixed
Status: newclosed

Replying to comment:2:

Replying to comment:1:

For some reason, some recent version of CVS has decided .doc
files are binary.

Likely it considers *.doc to be Word docs.

Any idea how to tell it .doc files are not binary
for us? I thought this command sequence would work and it does not appear to.

[joel@localhost tar01]$ cvs admin -kv *doc

Shouldn't this be
cvs admin -kkv *doc
?

Yes. Either I hadn't had enough coffee yet or the first hit in Google
had a typo.

So it looks like the admin works but there is still no expansion on the
checkout.

cvs up -dP -A

Note the -A

I will run the admin command on all
of them, make a change, commit, undo it, commit and see if the expansion
is working.

I think
cvs admin -kkv testsuites/*/*/*.doc

combined with
cvs up -dP -A

is the way to go.

I missed the -A. Not an option I use on a regular basis.

I just gave this a try on testsuites/psxtests/psxkey02/psxkey02.doc, which as
far as I can tell seems to have worked out.

I just did it on all .doc files and confirmed it with a grep.

grep \$Id\$ testsuites/*/*/*doc

Now shows nothing.

I am going to close this one.

comment:2 Changed on Nov 24, 2014 at 6:58:28 PM by Gedare Bloom

Version: HEAD4.11

Replace Version=HEAD with Version=4.11 for the tickets with Milestone >= 4.11

comment:3 Changed on Oct 10, 2017 at 6:35:44 AM by Sebastian Huber

Component: miscunspecified
Note: See TracTickets for help on using tickets.