#1539 closed defect (fixed)

ods68302: array subscript is above array bounds

Reported by: Ralf Corsepius Owned by: Chris Johns
Priority: normal Milestone: 4.11
Component: bsps Version: 4.10
Severity: major Keywords:
Cc: Blocked By:
Blocking:

Description

Building to ods68302 BSP currently raises this warning:
...
../../../../../../../../c/src/lib/libbsp/m68k/ods68302/startup/m68k-stub.c:611:19: warning: array subscript is above array bounds
...

AFAIU, this is a classical C array overrun.

Unfortunately, I don't feel sufficiently familiar with this BSP to be able to fix this bug.

Change History (3)

comment:1 Changed on May 30, 2010 at 2:42:53 PM by Joel Sherrill

Owner: changed from Joel Sherrill to Chris Johns

comment:2 Changed on Jun 22, 2010 at 1:04:13 AM by Chris Johns

Milestone: 4.104.11
Resolution: fixed
Status: newclosed

comment:3 Changed on Jun 23, 2010 at 5:00:07 AM by Chris Johns

No reason. It is in older RTEMS releases so if someone wants RTEMS for a 68302 they can pull it out from one of them.

Note: See TracTickets for help on using tickets.