#1450 closed defect (wontfix)

Task stuck in READY state

Reported by: ascesh Owned by: Joel Sherrill
Priority: normal Milestone: 4.10
Component: score Version: 4.5
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description (last modified by Joel Sherrill)

We are using RTEMS (3.2.1) on solaris ,a leagacy code base.

There are 4 timer tasks having max priority (0xFF) , in loaded scenario
we see one of the timer tasks go to READY state , but never gets scheduled againg .i.e not entering RUN state ,

We checked if any wake_after calls are happening in the the timer task context , which can explain that the task never gets resheduled , but its isnt so .

We are strongly suspecting the issue is with the scheduling algorithm.

I tried searching the bug database , but i am not able to search for the 3.2 version of RTEMS being used in my project and i could not see a similar bug in the >4.5 versions.

Change History (2)

comment:1 Changed on Jun 16, 2010 at 6:14:02 PM by Joel Sherrill

Resolution: wontfix
Status: newclosed

3.2.1 is too old for the free project to support. If you want support,
it will have to be on a consulting basis.

comment:2 Changed on Nov 23, 2014 at 7:05:58 PM by Joel Sherrill

Description: modified (diff)
Version: unknown4.5
Note: See TracTickets for help on using tickets.