#1368 closed defect (fixed)

DOSFS/FAT file creation date is incorrect.

Reported by: sgielis Owned by: Chris Johns
Priority: normal Milestone: 4.10
Component: fs/fat Version: 4.10
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

There is a problem with reading and writing the file creation/modification date in the dosfs/fat file system. The cause of the problem has been traced back to the incorrect passing of parameters to the msdos_date_unix2dos and msdos_date_dos2unix functions.

The patch is trivial. It swaps the time and date parameters that are passed to the conversion functions.

The included patch was tested on a variant of the csb337 bsp with ARM cpu.

The problem was detected in rtems 4.6.99.3 but it seems to be still present in the mainline development code.

Stijn

Attachments (1)

msdos_date.patch (2.3 KB) - added by sgielis on Feb 4, 2009 at 11:34:39 AM.
Patch to fix the file creation date bug

Download all attachments as: .zip

Change History (5)

Changed on Feb 4, 2009 at 11:34:39 AM by sgielis

Attachment: msdos_date.patch added

Patch to fix the file creation date bug

comment:1 Changed on Feb 4, 2009 at 5:53:04 PM by Joel Sherrill

Owner: changed from Joel Sherrill to Chris Johns

comment:2 Changed on Feb 5, 2009 at 3:42:01 AM by Chris Johns

Status: newassigned

comment:3 Changed on May 1, 2009 at 9:45:16 PM by Chris Johns

Resolution: fixed
Status: assignedclosed

Fixed in 4.10.

comment:4 Changed on Oct 10, 2017 at 6:50:58 AM by Sebastian Huber

Component: fsfs/fat
Note: See TracTickets for help on using tickets.