#1302 closed defect (fixed)

conflicting types for vmeUniverseMasterPortsShow

Reported by: Ralf Corsepius Owned by: Joel Sherrill
Priority: normal Milestone: 4.9
Component: bsps Version: 4.9
Severity: blocker Keywords:
Cc: Blocked By:
Blocking:

Description

With recently added tightened definitions/declaration/prototypes building rtems-CVS-HEAD triggers this breakdown
(here: --target=powerpc-rtems4.10; RTEMS_BSP=mvme2100)
...
powerpc-rtems4.10-gcc --pipe -B../../../../../.././lib/ -B../../../../../.././mvme2100/lib/ -specs bsp_specs -qrtems -DHAVE_CONFIG_H -isystem ../../../../../.././mvme2100/lib/include -Wall -Wimplicit-function-declaration -Wstrict-prototypes -Wnested-externs -ansi -fasm -mcpu=603e -Dmpc603e -Dppc603e -O2 -g -mmultiple -mstring -mstrict-align -MT vmeUniverse.o -MD -MP -MF .deps/vmeUniverse.Tpo -c -o vmeUniverse.o test -f '../../shared/vmeUniverse/vmeUniverse.c' || echo '../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/'../../shared/vmeUniverse/vmeUniverse.c
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.c:1040: error: conflicting types for 'vmeUniverseMasterPortsShowXX'
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.h:710: error: previous declaration of 'vmeUniverseMasterPortsShowXX' was here
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.c:1046: error: conflicting types for 'vmeUniverseMasterPortsShow'
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.h:525: error: previous declaration of 'vmeUniverseMasterPortsShow' was here
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.c:1053: error: conflicting types for 'vmeUniverseSlavePortsShowXX'
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.h:712: error: previous declaration of 'vmeUniverseSlavePortsShowXX' was here
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.c:1059: error: conflicting types for 'vmeUniverseSlavePortsShow'
../../../../../../../../../rtems.orig/c/src/lib/libbsp/powerpc/motorola_powerpc/../../shared/vmeUniverse/vmeUniverse.h:527: error: previous declaration of 'vmeUniverseSlavePortsShow' was here
gmake[1]: * [vmeUniverse.o] Error 1
gmake[1]: Leaving directory `/users/rtems/src/rtems-cvs/build/powerpc-rtems4.10/powerpc-rtems4.10/c/mvme2100/lib/libbsp/powerpc/motorola_powerpc'

The cause is vmeUniverse.[h|c] containing some weird conditionals aiming at implementing a conditional API.

There are several ways to work around this breakdown, but I am not sure what to do.

I vote for removing _VME_UNIVERSE_DECLARE_SHOW_ROUTINES and to build
vmeUniverseMasterPortsShowXX/vmeUniverseSlavePortsShowXX unconditionally.

Change History (1)

comment:1 Changed on Sep 2, 2008 at 3:22:57 PM by Ralf Corsepius

Resolution: fixed
Status: newclosed

Replying to comment:0:

I vote for removing _VME_UNIVERSE_DECLARE_SHOW_ROUTINES and to build
vmeUniverseMasterPortsShowXX/vmeUniverseSlavePortsShowXX unconditionally.

I implemented this step.

... closing.

Note: See TracTickets for help on using tickets.