#1220 closed defect (fixed)

GCC_PKGVERS not handled by mingw32/gcc.am

Reported by: Chris Johns Owned by: Ralf Corsepius
Priority: normal Milestone: 2
Component: unspecified Version: unspecified
Severity: normal Keywords:
Cc: Blocked By:
Blocking:

Description

The rtems4.8/gcc.am has been changed to handle GCC_PKGVERS. Building MinGW tools with rtems4.8 fails with a package SOURCE not found relating to this label.

I can have changed the mingw/gcc.am file, how-ever cygwin and maybe others may need changing.

Is this patch ok to commit (cut-n-pasted) ?

Index: gcc.am
===================================================================
RCS file: /usr1/CVS/rtems/contrib/crossrpms/mingw32/gcc.am,v
retrieving revision 1.1
diff -u -r1.1 gcc.am
--- gcc.am 14 Jul 2006 06:04:51 -0000 1.1
+++ gcc.am 23 Feb 2007 02:30:23 -0000
@@ -24,6 +24,7 @@

-e "/[@]PREP[@]/r $(srcdir)/../gcc-prep.add" \
-e "/[@]PREP[@]/d" \
-e "s/[@]GCC_VERS[@]/$(GCC_VERS)/g" \

+ -e "s/[@]GCC_PKGVERS[@]/$(GCC_PKGVERS)/g" \

-e "s/[@]GCC_RPMREL[@]/$(GCC_RPMREL)/g" \
-e "/[@]tool_target[@]-newlib/d" \

$(TARGET)-gcc.spec.in

Change History (2)

comment:1 Changed on Dec 2, 2009 at 1:13:32 PM by Ralf Corsepius

Resolution: fixed
Status: newclosed

I think PR is obsolete.

comment:2 Changed on Oct 10, 2017 at 6:05:35 AM by Sebastian Huber

Component: CrossRPMunspecified
Note: See TracTickets for help on using tickets.