Changeset f88fcf3 in rtems-source-builder for source-builder/sb-defaults


Ignore:
Timestamp:
Mar 7, 2016, 12:56:02 AM (4 years ago)
Author:
Chris Johns <chrisj@…>
Branches:
4.11
Children:
e02eaa6
Parents:
76188ee4
git-author:
Chris Johns <chrisj@…> (03/07/16 00:56:02)
git-committer:
Chris Johns <chrisj@…> (03/07/16 02:16:17)
Message:

sb: Update code base to support Python3 and Python2.

Fix Windows support to allow MSYS2 Python to be used.

Updates #2619.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • source-builder/sb-defaults

    r76188ee4 rf88fcf3  
    1919# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
    2020
     21from __future__ import print_function
     22
    2123import sys, os
    2224base = os.path.dirname(sys.argv[0])
     
    2628    options.run(sys.argv)
    2729except ImportError:
    28     print >> sys.stderr, "Incorrect Defaults installation"
     30    print("Incorrect Source Builder installation", file = sys.stderr)
    2931    sys.exit(1)
Note: See TracChangeset for help on using the changeset viewer.