Changeset d5ad667 in rtems-source-builder


Ignore:
Timestamp:
Apr 27, 2020, 7:15:28 PM (6 months ago)
Author:
Anders Montonen <Anders.Montonen@…>
Branches:
5, master
Children:
d14da0a
Parents:
ae9faa2
git-author:
Anders Montonen <Anders.Montonen@…> (04/27/20 19:15:28)
git-committer:
Chris Johns <chrisj@…> (04/27/20 22:49:56)
Message:

source-builder/config/gdb-common-1.cfg: Fix building with Python 3.8

Starting with Python 3.8, python3-config requires the "--embed" flag to
print the flags required for embedding Python in an application.

Fixes:
error: shell macro failed: /home/anders/work/rtems/rsb/source-builder/sb/rtems-build-dep -c gcc -l : 2: error: no library (-l) provided

Signed-off-by: Anders Montonen <Anders.Montonen@…>

File:
1 edited

Legend:

Unmodified
Added
Removed
  • source-builder/config/gdb-common-1.cfg

    rae9faa2 rd5ad667  
    110110  %if %{gdb-python-config} != %{nil}
    111111    %define gdb-python-lib-filter awk 'BEGIN{FS=" "}/python/{for(i=1;i<NF;++i)if(match($i,".*lpython.*")) print "lib"substr($i,3)"*";}'
    112     %define gdb-python-config-libs %(%{gdb-python-config} --ldflags | %{gdb-python-lib-filter})
     112    %if %{gdb-python-ver-mm} < 3.8
     113        %define gdb-python-config-lib-check-flags --ldflags
     114    %else
     115        %define gdb-python-config-lib-check-flags --ldflags --embed
     116    %endif
     117    %define gdb-python-config-libs %(%{gdb-python-config} %{gdb-python-config-lib-check-flags} | %{gdb-python-lib-filter})
    113118    %define gdb-python-lib-check %(%{_sbdir}/sb/rtems-build-dep -c %{__cc} %{gdb-host-libs} -l %{gdb-python-config-libs})
    114119  %else
Note: See TracChangeset for help on using the changeset viewer.