Changeset cfa08cf in rtems


Ignore:
Timestamp:
Nov 10, 2007, 7:05:17 AM (12 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.8
Children:
4ee3225
Parents:
2b6a100
Message:

Regenerate.

Location:
contrib/crossrpms/rtems4.8
Files:
10 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/rtems4.8/arm/rtems-4.8-arm-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "arm-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libarm-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/avr/rtems-4.8-avr-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "avr-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libavr-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/bfin/rtems-4.8-bfin-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "bfin-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    6976    --disable-werror \
    7077    --enable-sim \
     78%if "%{gdb_version}" >= "6.6"
     79    --with-system-readline \
     80    --with-expat \
     81%endif
    7182    --prefix=%{_prefix} --bindir=%{_bindir} \
    7283    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8192
    8293  cd build
    83 %if "%{gdb_version}" >= "6.3"
    8494  make DESTDIR=$RPM_BUILD_ROOT install
    85 %else
    86   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    87     bindir=$RPM_BUILD_ROOT%{_bindir} \
    88     includedir=$RPM_BUILD_ROOT%{_includedir} \
    89     libdir=$RPM_BUILD_ROOT%{_libdir} \
    90     infodir=$RPM_BUILD_ROOT%{_infodir} \
    91     mandir=$RPM_BUILD_ROOT%{_mandir} \
    92     install
    93 
    94   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    95     bindir=$RPM_BUILD_ROOT%{_bindir} \
    96     includedir=$RPM_BUILD_ROOT%{_includedir} \
    97     libdir=$RPM_BUILD_ROOT%{_libdir} \
    98     infodir=$RPM_BUILD_ROOT%{_infodir} \
    99     mandir=$RPM_BUILD_ROOT%{_mandir} \
    100     install-info
    101 %endif
    10295
    10396  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    112105  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    113106
    114 %if "%{gdb_version}" >= "6.4"
    115107# host library, installed to a bogus directory
    116108  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libbfin-rtems4.8-sim.a
    117 %endif
    118109
    119110  cd ..
     
    188179%post -n rtems-4.8-gdb-common
    189180  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    190 %if "%{gdb_version}" < "6.3"
    191   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    192 %endif
    193181  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    198186if [ $1 -eq 0 ]; then
    199187  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    200 %if "%{gdb_version}" < "6.3"
    201   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    202 %endif
    203188  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    212197%{_infodir}/gdb.info*
    213198
    214 # FIXME: When had mmalloc.info been removed?
    215 %if "%{gdb_version}" < "6.3"
    216 %{_infodir}/mmalloc.info*
    217 %endif
    218199%{_infodir}/gdbint.info*
    219200%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/h8300/rtems-4.8-h8300-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "h8300-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libh8300-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/i386/rtems-4.8-i386-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "i386-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libi386-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/m68k/rtems-4.8-m68k-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "m68k-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libm68k-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/mips/rtems-4.8-mips-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "mips-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libmips-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/mipstx39/rtems-4.8-mipstx39-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "mipstx39-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libmipstx39-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/powerpc/rtems-4.8-powerpc-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "powerpc-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpowerpc-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
  • contrib/crossrpms/rtems4.8/sh/rtems-4.8-sh-rtems4.8-gdb.spec

    r2b6a100 rcfa08cf  
    2121Group:          Development/Tools
    2222Version:        %{gdb_rpmvers}
    23 Release:        9%{?dist}
     23Release:        10%{?dist}
    2424License:        GPL/LGPL
    2525URL:            http://sources.redhat.com/gdb
     
    2727
    2828%if "%{gdb_version}" >= "6.6"
     29# suse
    2930%if "%{?suse}"
    30 BuildRequires:  expat
    31 %else
     31%if "%{?suse}" >= "10.3"
     32BuildRequires: libexpat-devel
     33%else
     34BuildRequires: expat
     35%endif
     36%else
     37# fedora/redhat
    3238BuildRequires:  expat-devel
    3339%endif
     
    3743BuildRequires:  texinfo >= 4.2
    3844%if "sh-rtems4.8" == "sparc-rtems4.8"
    39 BuildRequires:  libtermcap-devel
    40 %endif
     45BuildConflicts: libtermcap-devel termcap-devel
     46%endif
     47BuildRequires:  readline-devel
    4148BuildRequires:  ncurses-devel
    4249
     
    4552Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    4653%{?_without_sources:NoSource:   0}
    47 %if "%{gdb_version}" == "6.5"
    48 Patch0:         gdb-6.5-rtems-20060713.diff
    49 %endif
    5054%if "%{gdb_version}" == "6.6"
    51 Patch0:         gdb-6.6-rtems4.8-20070306.diff
     55Patch0:         gdb-6.6-rtems4.8-20071110.diff
    5256%endif
    5357
     
    7478    --disable-werror \
    7579    --enable-sim \
     80%if "%{gdb_version}" >= "6.6"
     81    --with-system-readline \
     82    --with-expat \
     83%endif
    7684    --prefix=%{_prefix} --bindir=%{_bindir} \
    7785    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    8694
    8795  cd build
    88 %if "%{gdb_version}" >= "6.3"
    8996  make DESTDIR=$RPM_BUILD_ROOT install
    90 %else
    91   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    92     bindir=$RPM_BUILD_ROOT%{_bindir} \
    93     includedir=$RPM_BUILD_ROOT%{_includedir} \
    94     libdir=$RPM_BUILD_ROOT%{_libdir} \
    95     infodir=$RPM_BUILD_ROOT%{_infodir} \
    96     mandir=$RPM_BUILD_ROOT%{_mandir} \
    97     install
    98 
    99   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    100     bindir=$RPM_BUILD_ROOT%{_bindir} \
    101     includedir=$RPM_BUILD_ROOT%{_includedir} \
    102     libdir=$RPM_BUILD_ROOT%{_libdir} \
    103     infodir=$RPM_BUILD_ROOT%{_infodir} \
    104     mandir=$RPM_BUILD_ROOT%{_mandir} \
    105     install-info
    106 %endif
    10797
    10898  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
     
    117107  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    118108
    119 %if "%{gdb_version}" >= "6.4"
    120109# host library, installed to a bogus directory
    121110  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsh-rtems4.8-sim.a
    122 %endif
    123111
    124112  cd ..
     
    193181%post -n rtems-4.8-gdb-common
    194182  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    195 %if "%{gdb_version}" < "6.3"
    196   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    197 %endif
    198183  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    199184  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    203188if [ $1 -eq 0 ]; then
    204189  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    205 %if "%{gdb_version}" < "6.3"
    206   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    207 %endif
    208190  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    209191  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    217199%{_infodir}/gdb.info*
    218200
    219 # FIXME: When had mmalloc.info been removed?
    220 %if "%{gdb_version}" < "6.3"
    221 %{_infodir}/mmalloc.info*
    222 %endif
    223201%{_infodir}/gdbint.info*
    224202%{_infodir}/stabs.info*
Note: See TracChangeset for help on using the changeset viewer.