Changeset c3e9378 in rtems


Ignore:
Timestamp:
May 18, 2011, 1:53:47 PM (9 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.10
Children:
c9ea876
Parents:
6d239016
Message:

Regenerate.

Location:
contrib/crossrpms/rtems4.10
Files:
13 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/rtems4.10/arm/rtems-4.10-arm-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-arm-rtems4.10-binutils
    247247Requires:       rtems-4.10-arm-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-arm-rtems4.10-binutils
    632 # Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/arm-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/arm-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/arm-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/avr/rtems-4.10-avr-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-avr-rtems4.10-binutils
    247247Requires:       rtems-4.10-avr-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    270270%if "%{newlib_version}" == "1.18.0"
    271271Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    272 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     272Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    273273%endif
    274274%{?_without_sources:NoSource:   50}
     
    317317  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    318318%if %{with gcc_stdint}
    319 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    320 %endif
     319  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     320%endif
     321  # Make sure not to be using GPL'ed sources
     322  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     323  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    321324
    322325%if 0%{?_build_mpfr}
     
    348351%endif
    349352
    350 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     353echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    351354
    352355
     
    392395    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    393396    --enable-newlib-io-c99-formats \
    394     --enable-languages="$languages" $optargs
     397    --enable-languages="$languages"
    395398
    396399%if "%_host" != "%_build"
     
    443446  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    444447  touch $RPM_BUILD_ROOT%{_infodir}/dir
     448
     449  # We don't want libffi's man-pages
     450  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    445451
    446452  # Bug in gcc-3.4.0pre
     
    617623# Version:        %{gcc_rpmvers}
    618624# Requires:       rtems-4.10-avr-rtems4.10-binutils
    619 # Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     625# Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    620626# License:      GPL
    621627
     
    635641Version:        %{gcc_rpmvers}
    636642%{?_with_noarch_subpackages:BuildArch: noarch}
    637 Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     643Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    638644License:        GPL
    639645
     
    657663%{_bindir}/avr-rtems4.10-gcc-%{gcc_version}%{_exeext}
    658664%{_bindir}/avr-rtems4.10-gcov%{_exeext}
     665%if "%{gcc_version}" < "4.6.0"
    659666%{_bindir}/avr-rtems4.10-gccbug
     667%endif
    660668
    661669%dir %{_libexecdir}
     
    748756License:        Distributable
    749757Version:        %{newlib_version}
    750 Release:        24%{?dist}
     758Release:        25%{?dist}
    751759%{?_with_noarch_subpackages:BuildArch: noarch}
    752760
     
    769777Group:          Development/Tools
    770778Version:        %{newlib_version}
    771 Release:        24%{?dist}
     779Release:        25%{?dist}
    772780%{?_with_noarch_subpackages:BuildArch: noarch}
    773781License:        Distributable
  • contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-bfin-rtems4.10-binutils
    247247Requires:       rtems-4.10-bfin-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-bfin-rtems4.10-binutils
    632 # Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/bfin-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/bfin-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/bfin-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/h8300/rtems-4.10-h8300-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-h8300-rtems4.10-binutils
    247247Requires:       rtems-4.10-h8300-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-h8300-rtems4.10-binutils
    632 # Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/h8300-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/h8300-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/h8300-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/i386/rtems-4.10-i386-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-i386-rtems4.10-binutils
    247247Requires:       rtems-4.10-i386-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-i386-rtems4.10-binutils
    632 # Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/i386-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/i386-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/i386-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/lm32/rtems-4.10-lm32-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-lm32-rtems4.10-binutils
    247247Requires:       rtems-4.10-lm32-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-lm32-rtems4.10-binutils
    632 # Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/lm32-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/lm32-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/lm32-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/m32c/rtems-4.10-m32c-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-m32c-rtems4.10-binutils
    247247Requires:       rtems-4.10-m32c-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    270270%if "%{newlib_version}" == "1.18.0"
    271271Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    272 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     272Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    273273%endif
    274274%{?_without_sources:NoSource:   50}
     
    317317  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    318318%if %{with gcc_stdint}
    319 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    320 %endif
     319  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     320%endif
     321  # Make sure not to be using GPL'ed sources
     322  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     323  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    321324
    322325%if 0%{?_build_mpfr}
     
    348351%endif
    349352
    350 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     353echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    351354
    352355
     
    392395    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    393396    --enable-newlib-io-c99-formats \
    394     --enable-languages="$languages" $optargs
     397    --enable-languages="$languages"
    395398
    396399%if "%_host" != "%_build"
     
    443446  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    444447  touch $RPM_BUILD_ROOT%{_infodir}/dir
     448
     449  # We don't want libffi's man-pages
     450  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    445451
    446452  # Bug in gcc-3.4.0pre
     
    617623# Version:        %{gcc_rpmvers}
    618624# Requires:       rtems-4.10-m32c-rtems4.10-binutils
    619 # Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     625# Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    620626# License:      GPL
    621627
     
    635641Version:        %{gcc_rpmvers}
    636642%{?_with_noarch_subpackages:BuildArch: noarch}
    637 Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     643Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    638644License:        GPL
    639645
     
    657663%{_bindir}/m32c-rtems4.10-gcc-%{gcc_version}%{_exeext}
    658664%{_bindir}/m32c-rtems4.10-gcov%{_exeext}
     665%if "%{gcc_version}" < "4.6.0"
    659666%{_bindir}/m32c-rtems4.10-gccbug
     667%endif
    660668
    661669%dir %{_libexecdir}
     
    749757License:        Distributable
    750758Version:        %{newlib_version}
    751 Release:        24%{?dist}
     759Release:        25%{?dist}
    752760%{?_with_noarch_subpackages:BuildArch: noarch}
    753761
     
    770778Group:          Development/Tools
    771779Version:        %{newlib_version}
    772 Release:        24%{?dist}
     780Release:        25%{?dist}
    773781%{?_with_noarch_subpackages:BuildArch: noarch}
    774782License:        Distributable
  • contrib/crossrpms/rtems4.10/m32r/rtems-4.10-m32r-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-m32r-rtems4.10-binutils
    247247Requires:       rtems-4.10-m32r-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    270270%if "%{newlib_version}" == "1.18.0"
    271271Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    272 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     272Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    273273%endif
    274274%{?_without_sources:NoSource:   50}
     
    317317  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    318318%if %{with gcc_stdint}
    319 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    320 %endif
     319  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     320%endif
     321  # Make sure not to be using GPL'ed sources
     322  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     323  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    321324
    322325%if 0%{?_build_mpfr}
     
    348351%endif
    349352
    350 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     353echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    351354
    352355
     
    392395    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    393396    --enable-newlib-io-c99-formats \
    394     --enable-languages="$languages" $optargs
     397    --enable-languages="$languages"
    395398
    396399%if "%_host" != "%_build"
     
    443446  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    444447  touch $RPM_BUILD_ROOT%{_infodir}/dir
     448
     449  # We don't want libffi's man-pages
     450  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    445451
    446452  # Bug in gcc-3.4.0pre
     
    617623# Version:        %{gcc_rpmvers}
    618624# Requires:       rtems-4.10-m32r-rtems4.10-binutils
    619 # Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     625# Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    620626# License:      GPL
    621627
     
    635641Version:        %{gcc_rpmvers}
    636642%{?_with_noarch_subpackages:BuildArch: noarch}
    637 Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     643Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    638644License:        GPL
    639645
     
    657663%{_bindir}/m32r-rtems4.10-gcc-%{gcc_version}%{_exeext}
    658664%{_bindir}/m32r-rtems4.10-gcov%{_exeext}
     665%if "%{gcc_version}" < "4.6.0"
    659666%{_bindir}/m32r-rtems4.10-gccbug
     667%endif
    660668
    661669%dir %{_libexecdir}
     
    749757License:        Distributable
    750758Version:        %{newlib_version}
    751 Release:        24%{?dist}
     759Release:        25%{?dist}
    752760%{?_with_noarch_subpackages:BuildArch: noarch}
    753761
     
    770778Group:          Development/Tools
    771779Version:        %{newlib_version}
    772 Release:        24%{?dist}
     780Release:        25%{?dist}
    773781%{?_with_noarch_subpackages:BuildArch: noarch}
    774782License:        Distributable
  • contrib/crossrpms/rtems4.10/m68k/rtems-4.10-m68k-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-m68k-rtems4.10-binutils
    247247Requires:       rtems-4.10-m68k-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-m68k-rtems4.10-binutils
    632 # Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/m68k-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/m68k-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/m68k-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/mips/rtems-4.10-mips-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-mips-rtems4.10-binutils
    247247Requires:       rtems-4.10-mips-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-mips-rtems4.10-binutils
    632 # Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/mips-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/mips-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/mips-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/powerpc/rtems-4.10-powerpc-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-powerpc-rtems4.10-binutils
    247247Requires:       rtems-4.10-powerpc-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-powerpc-rtems4.10-binutils
    632 # Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/powerpc-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/powerpc-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/powerpc-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-sh-rtems4.10-binutils
    247247Requires:       rtems-4.10-sh-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-sh-rtems4.10-binutils
    632 # Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/sh-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/sh-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/sh-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
  • contrib/crossrpms/rtems4.10/sparc/rtems-4.10-sparc-rtems4.10-gcc.spec

    r6d239016 rc3e9378  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    9090
    9191# versions of libraries these distros are known to ship
     92%if 0%{?fc16}
     93%global mpc_provided 0.8.3
     94%global mpfr_provided 3.0.0
     95%global gmp_provided 4.3.2
     96%endif
     97
    9298%if 0%{?fc15}
    9399%global mpc_provided 0.8.3
     
    118124%global mpfr_provided %{nil}
    119125%global gmp_provided 4.1.4
    120 %endif
    121 
    122 %if 0%{?suse11_2}
    123 %global mpc_provided 0.7
    124 %global mpfr_provided 2.4.1
    125 %global gmp_provided 4.3.1
    126126%endif
    127127
     
    213213%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
    214214%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
     215%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    215216%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
    216217%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    217218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    218 %{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219219%endif
    220220
     
    246246Requires:       rtems-4.10-sparc-rtems4.10-binutils
    247247Requires:       rtems-4.10-sparc-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    248 Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     248Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    249249
    250250%if "%{gcc_version}" >= "4.5.0"
     
    278278%if "%{newlib_version}" == "1.18.0"
    279279Source50:       ftp://sources.redhat.com/pub/newlib/newlib-%{newlib_pkgvers}.tar.gz
    280 Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110419.diff
     280Patch50:        ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/newlib-1.18.0-rtems4.10-20110518.diff
    281281%endif
    282282%{?_without_sources:NoSource:   50}
     
    329329  ln -s ../newlib-%{newlib_version}/newlib gcc-%{gcc_pkgvers}
    330330%if %{with gcc_stdint}
    331 rm newlib-%{newlib_version}/newlib/libc/include/stdint.h
    332 %endif
     331  rm gcc-%{gcc_pkgvers}/newlib/libc/include/stdint.h
     332%endif
     333  # Make sure not to be using GPL'ed sources
     334  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/linux
     335  rm -rf gcc-%{gcc_pkgvers}/newlib/libc/sys/rdos
    333336
    334337%if 0%{?_build_mpfr}
     
    360363%endif
    361364
    362 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-24%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-25%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    363366
    364367
     
    405408    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
    406409    --enable-newlib-io-c99-formats \
    407     --enable-languages="$languages" $optargs
     410    --enable-languages="$languages"
    408411
    409412%if "%_host" != "%_build"
     
    456459  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
    457460  touch $RPM_BUILD_ROOT%{_infodir}/dir
     461
     462  # We don't want libffi's man-pages
     463  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
    458464
    459465  # Bug in gcc-3.4.0pre
     
    630636# Version:        %{gcc_rpmvers}
    631637# Requires:       rtems-4.10-sparc-rtems4.10-binutils
    632 # Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     638# Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    633639# License:      GPL
    634640
     
    648654Version:        %{gcc_rpmvers}
    649655%{?_with_noarch_subpackages:BuildArch: noarch}
    650 Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-24%{?dist}
     656Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-25%{?dist}
    651657License:        GPL
    652658
     
    670676%{_bindir}/sparc-rtems4.10-gcc-%{gcc_version}%{_exeext}
    671677%{_bindir}/sparc-rtems4.10-gcov%{_exeext}
     678%if "%{gcc_version}" < "4.6.0"
    672679%{_bindir}/sparc-rtems4.10-gccbug
     680%endif
    673681
    674682%dir %{_libexecdir}
     
    822830License:        Distributable
    823831Version:        %{newlib_version}
    824 Release:        24%{?dist}
     832Release:        25%{?dist}
    825833%{?_with_noarch_subpackages:BuildArch: noarch}
    826834
     
    843851Group:          Development/Tools
    844852Version:        %{newlib_version}
    845 Release:        24%{?dist}
     853Release:        25%{?dist}
    846854%{?_with_noarch_subpackages:BuildArch: noarch}
    847855License:        Distributable
Note: See TracChangeset for help on using the changeset viewer.