Changeset c0456d7f in rtems for missing


Ignore:
Timestamp:
Jul 19, 2012, 1:24:36 PM (7 years ago)
Author:
Ralf Corsépius <ralf.corsepius@…>
Branches:
4.11, master
Children:
0f77281
Parents:
cece8db
Message:

Update from automake-1.12.2.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • missing

    rcece8db rc0456d7f  
    22# Common stub for a few missing GNU programs while installing.
    33
    4 scriptversion=2012-01-06.13; # UTC
    5 
    6 # Copyright (C) 1996, 1997, 1999, 2000, 2002, 2003, 2004, 2005, 2006,
    7 # 2008, 2009, 2010, 2011, 2012 Free Software Foundation, Inc.
     4scriptversion=2012-01-06.18; # UTC
     5
     6# Copyright (C) 1996-2012 Free Software Foundation, Inc.
    87# Originally by Fran,cois Pinard <pinard@iro.umontreal.ca>, 1996.
    98
     
    2726
    2827if test $# -eq 0; then
    29   echo 1>&2 "Try \`$0 --help' for more information"
     28  echo 1>&2 "Try '$0 --help' for more information"
    3029  exit 1
    3130fi
     
    3534sed_minuso='s/.* -o \([^ ]*\).*/\1/p'
    3635
    37 # In the cases where this matters, `missing' is being run in the
     36# In the cases where this matters, 'missing' is being run in the
    3837# srcdir already.
    3938if test -f configure.ac; then
     
    6665$0 [OPTION]... PROGRAM [ARGUMENT]...
    6766
    68 Handle \`PROGRAM [ARGUMENT]...' for when PROGRAM is missing, or return an
     67Handle 'PROGRAM [ARGUMENT]...' for when PROGRAM is missing, or return an
    6968error status if there is no known handling for PROGRAM.
    7069
     
    7574
    7675Supported PROGRAM values:
    77   aclocal      touch file \`aclocal.m4'
    78   autoconf     touch file \`configure'
    79   autoheader   touch file \`config.h.in'
     76  aclocal      touch file 'aclocal.m4'
     77  autoconf     touch file 'configure'
     78  autoheader   touch file 'config.h.in'
    8079  autom4te     touch the output file, or create a stub one
    81   automake     touch all \`Makefile.in' files
    82   bison        create \`y.tab.[ch]', if possible, from existing .[ch]
    83   flex         create \`lex.yy.c', if possible, from existing .c
     80  automake     touch all 'Makefile.in' files
     81  bison        create 'y.tab.[ch]', if possible, from existing .[ch]
     82  flex         create 'lex.yy.c', if possible, from existing .c
    8483  help2man     touch the output file
    85   lex          create \`lex.yy.c', if possible, from existing .c
     84  lex          create 'lex.yy.c', if possible, from existing .c
    8685  makeinfo     touch the output file
    87   yacc         create \`y.tab.[ch]', if possible, from existing .[ch]
    88 
    89 Version suffixes to PROGRAM as well as the prefixes \`gnu-', \`gnu', and
    90 \`g' are ignored when checking the name.
     86  yacc         create 'y.tab.[ch]', if possible, from existing .[ch]
     87
     88Version suffixes to PROGRAM as well as the prefixes 'gnu-', 'gnu', and
     89'g' are ignored when checking the name.
    9190
    9291Send bug reports to <bug-automake@gnu.org>."
     
    10099
    101100  -*)
    102     echo 1>&2 "$0: Unknown \`$1' option"
    103     echo 1>&2 "Try \`$0 --help' for more information"
     101    echo 1>&2 "$0: Unknown '$1' option"
     102    echo 1>&2 "Try '$0 --help' for more information"
    104103    exit 1
    105104    ;;
     
    128127    elif test "x$2" = "x--version" || test "x$2" = "x--help"; then
    129128       # Could not run --version or --help.  This is probably someone
    130        # running `$TOOL --version' or `$TOOL --help' to check whether
     129       # running '$TOOL --version' or '$TOOL --help' to check whether
    131130       # $TOOL exists and not knowing $TOOL uses missing.
    132131       exit 1
     
    140139  aclocal*)
    141140    echo 1>&2 "\
    142 WARNING: \`$1' is $msg.  You should only need it if
    143          you modified \`acinclude.m4' or \`${configure_ac}'.  You might want
    144          to install the \`Automake' and \`Perl' packages.  Grab them from
     141WARNING: '$1' is $msg.  You should only need it if
     142         you modified 'acinclude.m4' or '${configure_ac}'.  You might want
     143         to install the Automake and Perl packages.  Grab them from
    145144         any GNU archive site."
    146145    touch aclocal.m4
     
    149148  autoconf*)
    150149    echo 1>&2 "\
    151 WARNING: \`$1' is $msg.  You should only need it if
    152          you modified \`${configure_ac}'.  You might want to install the
    153          \`Autoconf' and \`GNU m4' packages.  Grab them from any GNU
     150WARNING: '$1' is $msg.  You should only need it if
     151         you modified '${configure_ac}'.  You might want to install the
     152         Autoconf and GNU m4 packages.  Grab them from any GNU
    154153         archive site."
    155154    touch configure
     
    158157  autoheader*)
    159158    echo 1>&2 "\
    160 WARNING: \`$1' is $msg.  You should only need it if
    161          you modified \`acconfig.h' or \`${configure_ac}'.  You might want
    162          to install the \`Autoconf' and \`GNU m4' packages.  Grab them
     159WARNING: '$1' is $msg.  You should only need it if
     160         you modified 'acconfig.h' or '${configure_ac}'.  You might want
     161         to install the Autoconf and GNU m4 packages.  Grab them
    163162         from any GNU archive site."
    164163    files=`sed -n 's/^[ ]*A[CM]_CONFIG_HEADER(\([^)]*\)).*/\1/p' ${configure_ac}`
     
    177176  automake*)
    178177    echo 1>&2 "\
    179 WARNING: \`$1' is $msg.  You should only need it if
    180          you modified \`Makefile.am', \`acinclude.m4' or \`${configure_ac}'.
    181          You might want to install the \`Automake' and \`Perl' packages.
     178WARNING: '$1' is $msg.  You should only need it if
     179         you modified 'Makefile.am', 'acinclude.m4' or '${configure_ac}'.
     180         You might want to install the Automake and Perl packages.
    182181         Grab them from any GNU archive site."
    183182    find . -type f -name Makefile.am -print |
     
    188187  autom4te*)
    189188    echo 1>&2 "\
    190 WARNING: \`$1' is needed, but is $msg.
     189WARNING: '$1' is needed, but is $msg.
    191190         You might have modified some files without having the
    192191         proper tools for further handling them.
    193          You can get \`$1' as part of \`Autoconf' from any GNU
     192         You can get '$1' as part of Autoconf from any GNU
    194193         archive site."
    195194
     
    211210  bison*|yacc*)
    212211    echo 1>&2 "\
    213 WARNING: \`$1' $msg.  You should only need it if
    214          you modified a \`.y' file.  You may need the \`Bison' package
     212WARNING: '$1' $msg.  You should only need it if
     213         you modified a '.y' file.  You may need the Bison package
    215214         in order for those modifications to take effect.  You can get
    216          \`Bison' from any GNU archive site."
     215         Bison from any GNU archive site."
    217216    rm -f y.tab.c y.tab.h
    218217    if test $# -ne 1; then
     
    241240  lex*|flex*)
    242241    echo 1>&2 "\
    243 WARNING: \`$1' is $msg.  You should only need it if
    244          you modified a \`.l' file.  You may need the \`Flex' package
     242WARNING: '$1' is $msg.  You should only need it if
     243         you modified a '.l' file.  You may need the Flex package
    245244         in order for those modifications to take effect.  You can get
    246          \`Flex' from any GNU archive site."
     245         Flex from any GNU archive site."
    247246    rm -f lex.yy.c
    248247    if test $# -ne 1; then
     
    264263  help2man*)
    265264    echo 1>&2 "\
    266 WARNING: \`$1' is $msg.  You should only need it if
     265WARNING: '$1' is $msg.  You should only need it if
    267266         you modified a dependency of a manual page.  You may need the
    268          \`Help2man' package in order for those modifications to take
    269          effect.  You can get \`Help2man' from any GNU archive site."
     267         Help2man package in order for those modifications to take
     268         effect.  You can get Help2man from any GNU archive site."
    270269
    271270    file=`echo "$*" | sed -n "$sed_output"`
     
    282281  makeinfo*)
    283282    echo 1>&2 "\
    284 WARNING: \`$1' is $msg.  You should only need it if
    285          you modified a \`.texi' or \`.texinfo' file, or any other file
     283WARNING: '$1' is $msg.  You should only need it if
     284         you modified a '.texi' or '.texinfo' file, or any other file
    286285         indirectly affecting the aspect of the manual.  The spurious
    287          call might also be the consequence of using a buggy \`make' (AIX,
    288          DU, IRIX).  You might want to install the \`Texinfo' package or
    289          the \`GNU make' package.  Grab either from any GNU archive site."
     286         call might also be the consequence of using a buggy 'make' (AIX,
     287         DU, IRIX).  You might want to install the Texinfo package or
     288         the GNU make package.  Grab either from any GNU archive site."
    290289    # The file to touch is that specified with -o ...
    291290    file=`echo "$*" | sed -n "$sed_output"`
     
    311310  *)
    312311    echo 1>&2 "\
    313 WARNING: \`$1' is needed, and is $msg.
     312WARNING: '$1' is needed, and is $msg.
    314313         You might have modified some files without having the
    315          proper tools for further handling them.  Check the \`README' file,
     314         proper tools for further handling them.  Check the 'README' file,
    316315         it often tells you about the needed prerequisites for installing
    317316         this package.  You may also peek at any GNU archive site, in case
    318          some other package would contain this missing \`$1' program."
     317         some other package would contain this missing '$1' program."
    319318    exit 1
    320319    ;;
Note: See TracChangeset for help on using the changeset viewer.