Changeset aa26724 in rtems


Ignore:
Timestamp:
Nov 1, 2007, 7:35:16 AM (13 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.8
Children:
6d837a6
Parents:
21b3f3b1
Message:

Sync with trunk

Location:
contrib/crossrpms/gdb
Files:
4 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/gdb/base-gdb.add

    r21b3f3b1 raa26724  
    1515%post -n @rpmprefix@gdb-common
    1616  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    17 %if "%{gdb_version}" < "6.3"
    18   /sbin/install-info --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    19 %endif
    2017  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    2118  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    2522if [ $1 -eq 0 ]; then
    2623  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
    27 %if "%{gdb_version}" < "6.3"
    28   /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/mmalloc.info.gz || :
    29 %endif
    3024  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
    3125  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
     
    3933%{_infodir}/gdb.info*
    4034
    41 # FIXME: When had mmalloc.info been removed?
    42 %if "%{gdb_version}" < "6.3"
    43 %{_infodir}/mmalloc.info*
    44 %endif
    4535%{_infodir}/gdbint.info*
    4636%{_infodir}/stabs.info*
  • contrib/crossrpms/gdb/build.add

    r21b3f3b1 raa26724  
    1111    --disable-werror \
    1212    --enable-sim \
     13%if "%{gdb_version}" >= "6.6"
     14    --with-system-readline \
     15    --with-expat \
     16%endif
    1317    --with-sysroot=%{_prefix}/@tool_target@/sys-root \
    1418    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/gdb/gdb.add

    r21b3f3b1 raa26724  
    1212
    1313%if "%{gdb_version}" >= "6.6"
     14# suse
    1415%if "%{?suse}"
    15 BuildRequires:  expat
    16 %else
     16%if "%{?suse}" >= "10.3"
     17BuildRequires: libexpat-devel
     18%else
     19BuildRequires: expat
     20%endif
     21%else
     22# fedora/redhat
    1723BuildRequires:  expat-devel
    1824%endif
     
    2329BuildRequires:  texinfo >= 4.2
    2430%endif
    25 %if "@tool_target@" == "sparc-rtems4.8"
    26 BuildRequires:  libtermcap-devel
     31%if "@tool_target@" == "sparc-rtems4.9"
     32BuildConflicts: libtermcap-devel termcap-devel
    2733%endif
     34BuildRequires:  readline-devel
    2835BuildRequires:  ncurses-devel
    2936%if %build_infos
  • contrib/crossrpms/gdb/install.add

    r21b3f3b1 raa26724  
    33
    44  cd build
    5 %if "%{gdb_version}" >= "6.3"
    65  make DESTDIR=$RPM_BUILD_ROOT install
    7 %else
    8   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    9     bindir=$RPM_BUILD_ROOT%{_bindir} \
    10     includedir=$RPM_BUILD_ROOT%{_includedir} \
    11     libdir=$RPM_BUILD_ROOT%{_libdir} \
    12     infodir=$RPM_BUILD_ROOT%{_infodir} \
    13     mandir=$RPM_BUILD_ROOT%{_mandir} \
    14     install
    15 
    16 %if %build_infos
    17   make prefix=$RPM_BUILD_ROOT%{_prefix} \
    18     bindir=$RPM_BUILD_ROOT%{_bindir} \
    19     includedir=$RPM_BUILD_ROOT%{_includedir} \
    20     libdir=$RPM_BUILD_ROOT%{_libdir} \
    21     infodir=$RPM_BUILD_ROOT%{_infodir} \
    22     mandir=$RPM_BUILD_ROOT%{_mandir} \
    23     install-info
    24 %endif
    25 %endif
    266
    277%if %build_infos
     
    4121  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
    4222
    43 %if "%{gdb_version}" >= "6.4"
    4423# host library, installed to a bogus directory
    4524  rm -f ${RPM_BUILD_ROOT}%{_libdir}/lib@tool_target@-sim.a
    46 %endif
    4725
    4826  cd ..
Note: See TracChangeset for help on using the changeset viewer.