Changeset a9c3667 in rtems


Ignore:
Timestamp:
Jul 20, 2009, 7:44:48 AM (10 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.9
Children:
0e7cd63c
Parents:
3985708f
Message:

Regenerate.

Location:
contrib/crossrpms/rtems4.9
Files:
11 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/rtems4.9/arm/rtems-4.9-arm-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "arm-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "arm-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "arm-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "arm-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "arm-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "arm-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/avr/rtems-4.9-avr-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "avr-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "avr-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "avr-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "avr-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "avr-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "avr-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/bfin/rtems-4.9-bfin-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "bfin-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "bfin-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "bfin-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "bfin-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "bfin-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "bfin-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    122147    --disable-win32-registry \
    123148    --disable-werror \
    124     --enable-sim \
     149    %{build_sim} \
    125150%if "%{gdb_version}" >= "6.7"
    126151    --with-system-readline \
     
    128153%if "%{gdb_version}" >= "6.6"
    129154    --with-expat \
     155%endif
     156%if "%{gdb_version}" >= "6.8.50"
     157    --without-python \
    130158%endif
    131159    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/h8300/rtems-4.9-h8300-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "h8300-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "h8300-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "h8300-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "h8300-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "h8300-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "h8300-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/i386/rtems-4.9-i386-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "i386-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "i386-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "i386-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "i386-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "i386-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "i386-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/m68k/rtems-4.9-m68k-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "m68k-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "m68k-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "m68k-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "m68k-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "m68k-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "m68k-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/mips/rtems-4.9-mips-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "mips-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "mips-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "mips-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "mips-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "mips-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "mips-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/mipstx39/rtems-4.9-mipstx39-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "mipstx39-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "mipstx39-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "mipstx39-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "mipstx39-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "mipstx39-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "mipstx39-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/powerpc/rtems-4.9-powerpc-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        6%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
  • contrib/crossrpms/rtems4.9/sh/rtems-4.9-sh-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "sh-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "sh-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "sh-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "sh-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "sh-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "sh-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
  • contrib/crossrpms/rtems4.9/sparc/rtems-4.9-sparc-rtems4.9-gdb.spec

    r3985708f ra9c3667  
    4141
    4242%if "%{_build}" != "%{_host}"
    43 %define _host_rpmprefix rtems-4.9-%{_host}-
     43%define _host_rpmprefix %{_host}-
    4444%else
    4545%define _host_rpmprefix %{nil}
     
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        5%{?dist}
     55Release:        7%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6060BuildRequires:  %{_host_rpmprefix}gcc
    6161
     62%define build_sim --enable-sim
     63%if "%{_build}" != "%{_host}"
     64# psim doesn't support Cdn-X
     65%if "sparc-rtems4.9" == "powerpc-rtems4.9"
     66%define build_sim --disable-sim
     67%endif
     68%endif
     69
     70%ifos mingw mingw32
     71# Mingw lacks functions required by the simulator
     72%if "sparc-rtems4.9" == "sparc-rtems4.9"
     73%define build_sim --disable-sim
     74%endif
     75%if "sparc-rtems4.9" == "h8300-rtems4.9"
     76%define build_sim --disable-sim
     77%endif
     78%if "%{gdb_version}" >= "6.8.50"
     79%if "sparc-rtems4.9" == "m32c-rtems4.9"
     80%define build_sim --disable-sim
     81%endif
     82%endif
     83%if "sparc-rtems4.9" == "lm32-rtems4.9"
     84%define build_sim --disable-sim
     85%endif
     86%if "sparc-rtems4.9" == "mipstx39-rtems4.9"
     87%define build_sim --disable-sim
     88%endif
     89%endif
     90
    6291%if "%{gdb_version}" >= "6.6"
    6392# suse
    64 %if "%{?suse}"
    6593%if "%{?suse}" >= "10.3"
    6694BuildRequires: libexpat-devel
    6795%else
    68 BuildRequires: expat
    69 %endif
    70 %else
    71 # fedora/redhat/cygwin
     96# Fedora/CentOS/Cygwin/MinGW
    7297BuildRequires: %{_host_rpmprefix}expat-devel
    7398%endif
     
    92117%{?_without_sources:NoSource:   0}
    93118%if "%{gdb_version}" == "6.8"
    94 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20080917.diff
     119Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.9/gdb-6.8-rtems4.9-20090312.diff
    95120%endif
    96121
     
    124149    --disable-win32-registry \
    125150    --disable-werror \
    126     --enable-sim \
     151    %{build_sim} \
    127152%if "%{gdb_version}" >= "6.7"
    128153    --with-system-readline \
     
    130155%if "%{gdb_version}" >= "6.6"
    131156    --with-expat \
     157%endif
     158%if "%{gdb_version}" >= "6.8.50"
     159    --without-python \
    132160%endif
    133161    --prefix=%{_prefix} --bindir=%{_bindir} \
Note: See TracChangeset for help on using the changeset viewer.