Changeset a46b025 in rtems-docs


Ignore:
Timestamp:
Dec 5, 2018, 7:31:53 PM (5 months ago)
Author:
Amar Takhar <verm@…>
Branches:
master
Children:
048b03e
Parents:
5628d8b
Message:

Fix error messages when Sphinx version cannot be checked.

This is kind of a dual-check since it checks for the version while simultaneously
checking to see if Sphinx exists on the system.

Changed the error messages to be clear on the error and removed a reference to
version which cannot be set due to the check failure.

Reported by: Shashvat Jain

File:
1 edited

Legend:

Unmodified
Added
Removed
  • common/waf.py

    r5628d8b ra46b025  
    120120                    ver = tuple(map(int, re.split('[\D]', version)))
    121121                except:
    122                     ctx.fatal("Sphinx version cannot be checked")
     122                    ctx.fatal("Sphinx version cannot be checked or Sphinx is not installed")
    123123            except:
    124                 ctx.fatal("Sphinx version cannot be checked: %s" % version)
     124                ctx.fatal("Sphinx version cannot be checked or Sphinx is not installed")
    125125    if ver < minver:
    126126        ctx.fatal("Sphinx version is too old: %s" % ".".join(map(str, ver)))
Note: See TracChangeset for help on using the changeset viewer.