Changeset 986e1113 in rtems for missing


Ignore:
Timestamp:
Sep 13, 2001, 1:15:41 PM (18 years ago)
Author:
Joel Sherrill <joel.sherrill@…>
Branches:
4.10, 4.11, 4.8, 4.9, master
Children:
bc51d7e9
Parents:
e712997
Message:

2001-09-13 Joel Sherrill <joel@…>

  • missing: Updated to latest version.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • missing

    re712997 r986e1113  
    11#! /bin/sh
    22# Common stub for a few missing GNU programs while installing.
    3 # Copyright (C) 1996, 1997 Free Software Foundation, Inc.
    4 # Franc,ois Pinard <pinard@iro.umontreal.ca>, 1996.
     3# Copyright 1996, 1997, 1999, 2000 Free Software Foundation, Inc.
     4# Originally by Fran,cois Pinard <pinard@iro.umontreal.ca>, 1996.
    55
    66# This program is free software; you can redistribute it and/or modify
     
    1919# 02111-1307, USA.
    2020
     21# As a special exception to the GNU General Public License, if you
     22# distribute this file as part of a program that contains a
     23# configuration script generated by Autoconf, you may include it under
     24# the same distribution terms that you use for the rest of that program.
     25
    2126if test $# -eq 0; then
    2227  echo 1>&2 "Try \`$0 --help' for more information"
     
    2429fi
    2530
     31run=:
     32
     33# In the cases where this matters, `missing' is being run in the
     34# srcdir already.
     35if test -f configure.ac; then
     36  configure_ac=configure.ac
     37else
     38  configure_ac=configure.in
     39fi
     40
     41case "$1" in
     42--run)
     43  # Try to run requested program, and just exit if it succeeds.
     44  run=
     45  shift
     46  "$@" && exit 0
     47  ;;
     48esac
     49
     50# If it does not exist, or fails to run (possibly an outdated version),
     51# try to emulate it.
    2652case "$1" in
    2753
     
    3662  -h, --help      display this help and exit
    3763  -v, --version   output version information and exit
     64  --run           try to run the given command, and emulate it if it fails
    3865
    3966Supported PROGRAM values:
     
    4471  bison        create \`y.tab.[ch]', if possible, from existing .[ch]
    4572  flex         create \`lex.yy.c', if possible, from existing .c
     73  help2man     touch the output file
    4674  lex          create \`lex.yy.c', if possible, from existing .c
    4775  makeinfo     touch the output file
     76  tar          try tar, gnutar, gtar, then tar without non-portable flags
    4877  yacc         create \`y.tab.[ch]', if possible, from existing .[ch]"
    4978    ;;
    5079
    5180  -v|--v|--ve|--ver|--vers|--versi|--versio|--version)
    52     echo "missing - GNU libit 0.0"
     81    echo "missing 0.3 - GNU automake"
    5382    ;;
    5483
     
    6291    echo 1>&2 "\
    6392WARNING: \`$1' is missing on your system.  You should only need it if
    64          you modified \`acinclude.m4' or \`configure.in'.  You might want
     93         you modified \`acinclude.m4' or \`${configure_ac}'.  You might want
    6594         to install the \`Automake' and \`Perl' packages.  Grab them from
    6695         any GNU archive site."
     
    71100    echo 1>&2 "\
    72101WARNING: \`$1' is missing on your system.  You should only need it if
    73          you modified \`configure.in'.  You might want to install the
     102         you modified \`${configure_ac}'.  You might want to install the
    74103         \`Autoconf' and \`GNU m4' packages.  Grab them from any GNU
    75104         archive site."
     
    80109    echo 1>&2 "\
    81110WARNING: \`$1' is missing on your system.  You should only need it if
    82          you modified \`acconfig.h' or \`configure.in'.  You might want
     111         you modified \`acconfig.h' or \`${configure_ac}'.  You might want
    83112         to install the \`Autoconf' and \`GNU m4' packages.  Grab them
    84113         from any GNU archive site."
    85     files=`sed -n 's/^[ ]*A[CM]_CONFIG_HEADER(\([^)]*\)).*/\1/p' configure.in`
     114    files=`sed -n 's/^[ ]*A[CM]_CONFIG_HEADER(\([^)]*\)).*/\1/p' ${configure_ac}`
    86115    test -z "$files" && files="config.h"
    87116    touch_files=
     
    99128    echo 1>&2 "\
    100129WARNING: \`$1' is missing on your system.  You should only need it if
    101          you modified \`Makefile.am', \`acinclude.m4' or \`configure.in'.
     130         you modified \`Makefile.am', \`acinclude.m4' or \`${configure_ac}'.
    102131         You might want to install the \`Automake' and \`Perl' packages.
    103132         Grab them from any GNU archive site."
     
    160189    ;;
    161190
     191  help2man)
     192    echo 1>&2 "\
     193WARNING: \`$1' is missing on your system.  You should only need it if
     194         you modified a dependency of a manual page.  You may need the
     195         \`Help2man' package in order for those modifications to take
     196         effect.  You can get \`Help2man' from any GNU archive site."
     197
     198    file=`echo "$*" | sed -n 's/.*-o \([^ ]*\).*/\1/p'`
     199    if test -z "$file"; then
     200        file=`echo "$*" | sed -n 's/.*--output=\([^ ]*\).*/\1/p'`
     201    fi
     202    if [ -f "$file" ]; then
     203        touch $file
     204    else
     205        test -z "$file" || exec >$file
     206        echo ".ab help2man is required to generate this page"
     207        exit 1
     208    fi
     209    ;;
     210
    162211  makeinfo)
     212    if test -z "$run" && (makeinfo --version) > /dev/null 2>&1; then
     213       # We have makeinfo, but it failed.
     214       exit 1
     215    fi
     216
    163217    echo 1>&2 "\
    164218WARNING: \`$1' is missing on your system.  You should only need it if
     
    176230    ;;
    177231
     232  tar)
     233    shift
     234    if test -n "$run"; then
     235      echo 1>&2 "ERROR: \`tar' requires --run"
     236      exit 1
     237    fi
     238
     239    # We have already tried tar in the generic part.
     240    # Look for gnutar/gtar before invocation to avoid ugly error
     241    # messages.
     242    if (gnutar --version > /dev/null 2>&1); then
     243       gnutar ${1+"$@"} && exit 0
     244    fi
     245    if (gtar --version > /dev/null 2>&1); then
     246       gtar ${1+"$@"} && exit 0
     247    fi
     248    firstarg="$1"
     249    if shift; then
     250        case "$firstarg" in
     251        *o*)
     252            firstarg=`echo "$firstarg" | sed s/o//`
     253            tar "$firstarg" ${1+"$@"} && exit 0
     254            ;;
     255        esac
     256        case "$firstarg" in
     257        *h*)
     258            firstarg=`echo "$firstarg" | sed s/h//`
     259            tar "$firstarg" ${1+"$@"} && exit 0
     260            ;;
     261        esac
     262    fi
     263
     264    echo 1>&2 "\
     265WARNING: I can't seem to be able to run \`tar' with the given arguments.
     266         You may want to install GNU tar or Free paxutils, or check the
     267         command line arguments."
     268    exit 1
     269    ;;
     270
    178271  *)
    179272    echo 1>&2 "\
Note: See TracChangeset for help on using the changeset viewer.