Changeset 86b2b4f in rtems-source-builder


Ignore:
Timestamp:
Apr 23, 2013, 6:03:25 AM (6 years ago)
Author:
Chris Johns <chrisj@…>
Branches:
4.10, 4.11, 4.9, master
Children:
b328e49
Parents:
1869040
Message:

Add support to check for a valid autoconf for RTEMS.

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • rtems/config/tools/rtems-kernel-4.11.cfg

    r1869040 r86b2b4f  
    55%include %{_configdir}/checks.cfg
    66%include %{_configdir}/base.cfg
     7%include %{_configdir}/versions.cfg
    78
    89%define rtems_kernel_version 4.11
     10
     11#
     12# Check the version of autoconf.
     13#
     14%if %{__autoconf_ver} <= 2.68
     15 %error Autoconf version 2.69 or higher is needed.
     16%endif
    917
    1018#
  • source-builder/config/versions.cfg

    r1869040 r86b2b4f  
    22
    33%define __makeinfo_ver          %(%{__makeinfo} --version | %{__awk} 'NR==1 {print $NF}')
     4%define __autoconf_ver          %(%{__autoconf} --version | %{__awk} 'NR==1 {print $NF}')
     5%define __automake_ver          %(%{__automake} --version | %{__awk} 'NR==1 {print $NF}')
    46
    57
Note: See TracChangeset for help on using the changeset viewer.