Changeset 7ef633e in rtems


Ignore:
Timestamp:
Jul 13, 2010, 5:11:58 AM (9 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.10
Children:
b865cb4
Parents:
018d687
Message:

Regenerate.

Location:
contrib/crossrpms/rtems4.10
Files:
13 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/rtems4.10/arm/rtems-4.10-arm-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-arm-rtems4.10-binutils
    243249Requires:       rtems-4.10-arm-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-arm-rtems4.10-binutils
    614 # Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-arm-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/avr/rtems-4.10-avr-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-avr-rtems4.10-binutils
    243249Requires:       rtems-4.10-avr-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    333339%endif
    334340
    335 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     341echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    336342
    337343
     
    602608# Version:        %{gcc_rpmvers}
    603609# Requires:       rtems-4.10-avr-rtems4.10-binutils
    604 # Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     610# Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    605611# License:      GPL
    606612
     
    620626Version:        %{gcc_rpmvers}
    621627%{?_with_noarch_subpackages:BuildArch: noarch}
    622 Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     628Requires:       rtems-4.10-avr-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    623629License:        GPL
    624630
     
    733739License:        Distributable
    734740Version:        %{newlib_version}
    735 Release:        12%{?dist}
     741Release:        13%{?dist}
    736742%{?_with_noarch_subpackages:BuildArch: noarch}
    737743
     
    754760Group:          Development/Tools
    755761Version:        %{newlib_version}
    756 Release:        12%{?dist}
     762Release:        13%{?dist}
    757763%{?_with_noarch_subpackages:BuildArch: noarch}
    758764License:        Distributable
  • contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-bfin-rtems4.10-binutils
    243249Requires:       rtems-4.10-bfin-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-bfin-rtems4.10-binutils
    614 # Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-bfin-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/h8300/rtems-4.10-h8300-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-h8300-rtems4.10-binutils
    243249Requires:       rtems-4.10-h8300-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-h8300-rtems4.10-binutils
    614 # Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-h8300-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/i386/rtems-4.10-i386-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-i386-rtems4.10-binutils
    243249Requires:       rtems-4.10-i386-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-i386-rtems4.10-binutils
    614 # Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-i386-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/lm32/rtems-4.10-lm32-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-lm32-rtems4.10-binutils
    243249Requires:       rtems-4.10-lm32-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-lm32-rtems4.10-binutils
    614 # Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-lm32-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/m32c/rtems-4.10-m32c-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-m32c-rtems4.10-binutils
    243249Requires:       rtems-4.10-m32c-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    333339%endif
    334340
    335 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     341echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    336342
    337343
     
    602608# Version:        %{gcc_rpmvers}
    603609# Requires:       rtems-4.10-m32c-rtems4.10-binutils
    604 # Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     610# Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    605611# License:      GPL
    606612
     
    620626Version:        %{gcc_rpmvers}
    621627%{?_with_noarch_subpackages:BuildArch: noarch}
    622 Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     628Requires:       rtems-4.10-m32c-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    623629License:        GPL
    624630
     
    734740License:        Distributable
    735741Version:        %{newlib_version}
    736 Release:        12%{?dist}
     742Release:        13%{?dist}
    737743%{?_with_noarch_subpackages:BuildArch: noarch}
    738744
     
    755761Group:          Development/Tools
    756762Version:        %{newlib_version}
    757 Release:        12%{?dist}
     763Release:        13%{?dist}
    758764%{?_with_noarch_subpackages:BuildArch: noarch}
    759765License:        Distributable
  • contrib/crossrpms/rtems4.10/m32r/rtems-4.10-m32r-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-m32r-rtems4.10-binutils
    243249Requires:       rtems-4.10-m32r-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    333339%endif
    334340
    335 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     341echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    336342
    337343
     
    602608# Version:        %{gcc_rpmvers}
    603609# Requires:       rtems-4.10-m32r-rtems4.10-binutils
    604 # Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     610# Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    605611# License:      GPL
    606612
     
    620626Version:        %{gcc_rpmvers}
    621627%{?_with_noarch_subpackages:BuildArch: noarch}
    622 Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     628Requires:       rtems-4.10-m32r-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    623629License:        GPL
    624630
     
    734740License:        Distributable
    735741Version:        %{newlib_version}
    736 Release:        12%{?dist}
     742Release:        13%{?dist}
    737743%{?_with_noarch_subpackages:BuildArch: noarch}
    738744
     
    755761Group:          Development/Tools
    756762Version:        %{newlib_version}
    757 Release:        12%{?dist}
     763Release:        13%{?dist}
    758764%{?_with_noarch_subpackages:BuildArch: noarch}
    759765License:        Distributable
  • contrib/crossrpms/rtems4.10/m68k/rtems-4.10-m68k-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-m68k-rtems4.10-binutils
    243249Requires:       rtems-4.10-m68k-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-m68k-rtems4.10-binutils
    614 # Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-m68k-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/mips/rtems-4.10-mips-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-mips-rtems4.10-binutils
    243249Requires:       rtems-4.10-mips-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-mips-rtems4.10-binutils
    614 # Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-mips-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/powerpc/rtems-4.10-powerpc-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-powerpc-rtems4.10-binutils
    243249Requires:       rtems-4.10-powerpc-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-powerpc-rtems4.10-binutils
    614 # Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-powerpc-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/sh/rtems-4.10-sh-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-sh-rtems4.10-binutils
    243249Requires:       rtems-4.10-sh-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-sh-rtems4.10-binutils
    614 # Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-sh-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
  • contrib/crossrpms/rtems4.10/sparc/rtems-4.10-sparc-rtems4.10-gcc.spec

    r018d687 r7ef633e  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        1%{?dist}
     61Release:        2%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    8181# versions of libraries, we conditionally bundle if necessary
    8282%global mpc_version     0.8.1
    83 %global mpfr_version    2.4.1
     83%global mpfr_version    2.4.2
    8484%global gmp_version     4.3.2
    8585%global libelf_version  0.8.13
     
    8888%if 0%{?fc13}
    8989%global mpc_provided 0.8.1
    90 %global mpfr_provided 2.4.1
     90%global mpfr_provided 2.4.2
    9191%global gmp_provided 4.3.1
    9292%endif
     
    106106%if 0%{?el6}
    107107%global mpc_provided %{nil}
    108 # el6 beta ships mpfr but mpfr-devel is missing
    109 %global mpfr_provided %{nil}
     108%global mpfr_provided 2.4.1
    110109%global gmp_provided 4.3.1
    111110%endif
     
    133132%global mpfr_provided 2.4.1
    134133%global gmp_provided 4.3.1
     134%endif
     135
     136%if 0%{?suse11_3}
     137%global mpc_provided 0.8.1
     138%global mpfr_provided 2.4.2
     139%global gmp_provided 4.3.2
    135140%endif
    136141
     
    210215%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
    211216%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
    212 # el6 ships cloog-ppl, but cloog-ppl-devel is missing
     217%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     218%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    213219%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    214220%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    242248Requires:       rtems-4.10-sparc-rtems4.10-binutils
    243249Requires:       rtems-4.10-sparc-rtems4.10-gcc-libgcc = %{gcc_rpmvers}-%{release}
    244 Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     250Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    245251
    246252%if "%{gcc_version}" >= "4.5.0"
     
    342348%endif
    343349
    344 echo "RTEMS gcc-%{gcc_version}-1%{?dist}/newlib-%{newlib_version}-12%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     350echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-13%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    345351
    346352
     
    612618# Version:        %{gcc_rpmvers}
    613619# Requires:       rtems-4.10-sparc-rtems4.10-binutils
    614 # Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     620# Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    615621# License:      GPL
    616622
     
    630636Version:        %{gcc_rpmvers}
    631637%{?_with_noarch_subpackages:BuildArch: noarch}
    632 Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-12%{?dist}
     638Requires:       rtems-4.10-sparc-rtems4.10-newlib = %{newlib_version}-13%{?dist}
    633639License:        GPL
    634640
     
    804810License:        Distributable
    805811Version:        %{newlib_version}
    806 Release:        12%{?dist}
     812Release:        13%{?dist}
    807813%{?_with_noarch_subpackages:BuildArch: noarch}
    808814
     
    825831Group:          Development/Tools
    826832Version:        %{newlib_version}
    827 Release:        12%{?dist}
     833Release:        13%{?dist}
    828834%{?_with_noarch_subpackages:BuildArch: noarch}
    829835License:        Distributable
Note: See TracChangeset for help on using the changeset viewer.