Changeset 6fbf65fd in rtems


Ignore:
Timestamp:
Aug 31, 2011, 2:30:21 PM (10 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.11, 5, master
Children:
b2aa729
Parents:
6f95e2f
Message:

Regenerate.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/rtems4.11/bfin/rtems-4.11-bfin-rtems4.11-gdb.spec

    r6f95e2f r6fbf65fd  
    4646%endif
    4747
    48 %define gdb_version 6.5
    49 %define gdb_rpmvers %{expand:%(echo 6.5 | tr - _)}
     48%define gdb_version 7.3
     49%define gdb_rpmvers %{expand:%(echo 7.3 | tr - _)}
    5050
    5151Name:           rtems-4.11-bfin-rtems4.11-gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    95 
    96 
    97 
    98 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
    99 Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-6.5-bfinrtems-20090122.diff
     97
     98
     99
     100BuildRequires:  rtems-4.11-bfin-rtems4.11-binutils
     101BuildRequires:  texinfo
     102
     103# The bfin simulator silently tries to conditionally build an SDL based GUI,
     104# but fails to link correctly
     105# Force not building the GUI.
     106%{!?suse:BuildConflicts: SDL-devel}
     107%{?suse:BuildConflicts: libSDL-devel}
     108
     109Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}a.tar.bz2
     110Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.3-rtems4.11-20110831.diff
    100111
    101112%description
     
    128139    %{build_sim} \
    129140    %{?with_system_readline:--with-system-readline} \
    130 %if "%{gdb_version}" >= "6.6"
    131141    --with-expat \
    132 %endif
    133 %if "%{gdb_version}" >= "6.8.50"
    134 %if %{with python}
    135     --with-python \
    136 %else
    137     --without-python \
    138 %endif
    139 %endif
     142    %{?with_python:--with-python}%{!?with_python:--without-python} \
    140143    --prefix=%{_prefix} --bindir=%{_bindir} \
    141144    --includedir=%{_includedir} --libdir=%{_libdir} \
     
    175178%endif
    176179
     180%if "{gdb_version}" >= "7.3"
     181%if ! %{with python}
     182# gdb-7.3 doesn't honor --without-python correctly
     183  rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gdb/python
     184%endif
     185%endif
    177186  cd ..
    178187
Note: See TracChangeset for help on using the changeset viewer.