Changeset 6765b71d in rtems


Ignore:
Timestamp:
11/18/11 12:34:02 (11 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.11, 5, master
Children:
ce017f90
Parents:
49df63a
Message:

Regenerate.

Location:
contrib/crossrpms/rtems4.11
Files:
14 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/rtems4.11/arm/rtems-4.11-arm-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-arm-rtems4.11-binutils
    248249Requires:       rtems-4.11-arm-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-arm-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-arm-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-arm-rtems4.11-binutils
    649 # Requires:       rtems-4.11-arm-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-arm-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-arm-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-arm-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/avr/rtems-4.11-avr-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-avr-rtems4.11-binutils
    248249Requires:       rtems-4.11-avr-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-avr-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-avr-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    350351%endif
    351352
    352 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     353echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    353354
    354355
     
    634635# Version:        %{gcc_rpmvers}
    635636# Requires:       rtems-4.11-avr-rtems4.11-binutils
    636 # Requires:       rtems-4.11-avr-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     637# Requires:       rtems-4.11-avr-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    637638# License:      GPL
    638639
     
    652653Version:        %{gcc_rpmvers}
    653654%{?_with_noarch_subpackages:BuildArch: noarch}
    654 Requires:       rtems-4.11-avr-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     655Requires:       rtems-4.11-avr-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    655656License:        GPL
    656657
     
    770771License:        Distributable
    771772Version:        %{newlib_version}
    772 Release:        21%{?dist}
     773Release:        22%{?dist}
    773774%{?_with_noarch_subpackages:BuildArch: noarch}
    774775
     
    791792Group:          Development/Tools
    792793Version:        %{newlib_version}
    793 Release:        21%{?dist}
     794Release:        22%{?dist}
    794795%{?_with_noarch_subpackages:BuildArch: noarch}
    795796License:        Distributable
  • contrib/crossrpms/rtems4.11/bfin/rtems-4.11-bfin-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-bfin-rtems4.11-binutils
    248249Requires:       rtems-4.11-bfin-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-bfin-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-bfin-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-bfin-rtems4.11-binutils
    649 # Requires:       rtems-4.11-bfin-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-bfin-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-bfin-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-bfin-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    843844License:        Distributable
    844845Version:        %{newlib_version}
    845 Release:        21%{?dist}
     846Release:        22%{?dist}
    846847%{?_with_noarch_subpackages:BuildArch: noarch}
    847848
     
    864865Group:          Development/Tools
    865866Version:        %{newlib_version}
    866 Release:        21%{?dist}
     867Release:        22%{?dist}
    867868%{?_with_noarch_subpackages:BuildArch: noarch}
    868869License:        Distributable
  • contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        20%{?dist}
     61Release:        21%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-h8300-rtems4.11-binutils
    248249Requires:       rtems-4.11-h8300-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-h8300-rtems4.11-newlib = %{newlib_version}-27%{?dist}
     250Requires:       rtems-4.11-h8300-rtems4.11-newlib = %{newlib_version}-28%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-20%{?dist}/newlib-%{newlib_version}-27%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-21%{?dist}/newlib-%{newlib_version}-28%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-h8300-rtems4.11-binutils
    649 # Requires:       rtems-4.11-h8300-rtems4.11-newlib = %{newlib_version}-27%{?dist}
     650# Requires:       rtems-4.11-h8300-rtems4.11-newlib = %{newlib_version}-28%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-h8300-rtems4.11-newlib = %{newlib_version}-27%{?dist}
     668Requires:       rtems-4.11-h8300-rtems4.11-newlib = %{newlib_version}-28%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        27%{?dist}
     847Release:        28%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        27%{?dist}
     868Release:        28%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/i386/rtems-4.11-i386-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-i386-rtems4.11-binutils
    248249Requires:       rtems-4.11-i386-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-i386-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-i386-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-i386-rtems4.11-binutils
    649 # Requires:       rtems-4.11-i386-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-i386-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-i386-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-i386-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/lm32/rtems-4.11-lm32-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        20%{?dist}
     61Release:        21%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-lm32-rtems4.11-binutils
    248249Requires:       rtems-4.11-lm32-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-lm32-rtems4.11-newlib = %{newlib_version}-27%{?dist}
     250Requires:       rtems-4.11-lm32-rtems4.11-newlib = %{newlib_version}-28%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-20%{?dist}/newlib-%{newlib_version}-27%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-21%{?dist}/newlib-%{newlib_version}-28%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-lm32-rtems4.11-binutils
    649 # Requires:       rtems-4.11-lm32-rtems4.11-newlib = %{newlib_version}-27%{?dist}
     650# Requires:       rtems-4.11-lm32-rtems4.11-newlib = %{newlib_version}-28%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-lm32-rtems4.11-newlib = %{newlib_version}-27%{?dist}
     668Requires:       rtems-4.11-lm32-rtems4.11-newlib = %{newlib_version}-28%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        27%{?dist}
     847Release:        28%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        27%{?dist}
     868Release:        28%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/m32c/rtems-4.11-m32c-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-m32c-rtems4.11-binutils
    248249Requires:       rtems-4.11-m32c-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-m32c-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-m32c-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    350351%endif
    351352
    352 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     353echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    353354
    354355
     
    634635# Version:        %{gcc_rpmvers}
    635636# Requires:       rtems-4.11-m32c-rtems4.11-binutils
    636 # Requires:       rtems-4.11-m32c-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     637# Requires:       rtems-4.11-m32c-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    637638# License:      GPL
    638639
     
    652653Version:        %{gcc_rpmvers}
    653654%{?_with_noarch_subpackages:BuildArch: noarch}
    654 Requires:       rtems-4.11-m32c-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     655Requires:       rtems-4.11-m32c-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    655656License:        GPL
    656657
     
    771772License:        Distributable
    772773Version:        %{newlib_version}
    773 Release:        21%{?dist}
     774Release:        22%{?dist}
    774775%{?_with_noarch_subpackages:BuildArch: noarch}
    775776
     
    792793Group:          Development/Tools
    793794Version:        %{newlib_version}
    794 Release:        21%{?dist}
     795Release:        22%{?dist}
    795796%{?_with_noarch_subpackages:BuildArch: noarch}
    796797License:        Distributable
  • contrib/crossrpms/rtems4.11/m32r/rtems-4.11-m32r-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-m32r-rtems4.11-binutils
    248249Requires:       rtems-4.11-m32r-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-m32r-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-m32r-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    350351%endif
    351352
    352 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     353echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    353354
    354355
     
    634635# Version:        %{gcc_rpmvers}
    635636# Requires:       rtems-4.11-m32r-rtems4.11-binutils
    636 # Requires:       rtems-4.11-m32r-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     637# Requires:       rtems-4.11-m32r-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    637638# License:      GPL
    638639
     
    652653Version:        %{gcc_rpmvers}
    653654%{?_with_noarch_subpackages:BuildArch: noarch}
    654 Requires:       rtems-4.11-m32r-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     655Requires:       rtems-4.11-m32r-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    655656License:        GPL
    656657
     
    771772License:        Distributable
    772773Version:        %{newlib_version}
    773 Release:        21%{?dist}
     774Release:        22%{?dist}
    774775%{?_with_noarch_subpackages:BuildArch: noarch}
    775776
     
    792793Group:          Development/Tools
    793794Version:        %{newlib_version}
    794 Release:        21%{?dist}
     795Release:        22%{?dist}
    795796%{?_with_noarch_subpackages:BuildArch: noarch}
    796797License:        Distributable
  • contrib/crossrpms/rtems4.11/m68k/rtems-4.11-m68k-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-m68k-rtems4.11-binutils
    248249Requires:       rtems-4.11-m68k-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-m68k-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-m68k-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-m68k-rtems4.11-binutils
    649 # Requires:       rtems-4.11-m68k-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-m68k-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-m68k-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-m68k-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/mips/rtems-4.11-mips-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-mips-rtems4.11-binutils
    248249Requires:       rtems-4.11-mips-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-mips-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-mips-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-mips-rtems4.11-binutils
    649 # Requires:       rtems-4.11-mips-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-mips-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-mips-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-mips-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-powerpc-rtems4.11-binutils
    248249Requires:       rtems-4.11-powerpc-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-powerpc-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-powerpc-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-powerpc-rtems4.11-binutils
    649 # Requires:       rtems-4.11-powerpc-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-powerpc-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-powerpc-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-powerpc-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/sh/rtems-4.11-sh-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-sh-rtems4.11-binutils
    248249Requires:       rtems-4.11-sh-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-sh-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-sh-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-sh-rtems4.11-binutils
    649 # Requires:       rtems-4.11-sh-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-sh-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-sh-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-sh-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/sparc/rtems-4.11-sparc-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-sparc-rtems4.11-binutils
    248249Requires:       rtems-4.11-sparc-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-sparc-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-sparc-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-sparc-rtems4.11-binutils
    649 # Requires:       rtems-4.11-sparc-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-sparc-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-sparc-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-sparc-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
  • contrib/crossrpms/rtems4.11/sparc64/rtems-4.11-sparc64-rtems4.11-gcc.spec

    r49df63a r6765b71d  
    5959Group:          Development/Tools
    6060Version:        %{gcc_rpmvers}
    61 Release:        2%{?dist}
     61Release:        3%{?dist}
    6262License:        GPL
    6363URL:            http://gcc.gnu.org
     
    217217%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
    218218%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
     219%{?suse12_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    219220%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
    220221%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
     
    247248Requires:       rtems-4.11-sparc64-rtems4.11-binutils
    248249Requires:       rtems-4.11-sparc64-rtems4.11-gcc-libgcc = %{gcc_rpmvers}-%{release}
    249 Requires:       rtems-4.11-sparc64-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     250Requires:       rtems-4.11-sparc64-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    250251
    251252%if "%{gcc_version}" >= "4.5.0"
     
    362363%endif
    363364
    364 echo "RTEMS gcc-%{gcc_version}-2%{?dist}/newlib-%{newlib_version}-21%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
     365echo "RTEMS gcc-%{gcc_version}-3%{?dist}/newlib-%{newlib_version}-22%{?dist}" > gcc-%{gcc_pkgvers}/gcc/DEV-PHASE
    365366
    366367
     
    647648# Version:        %{gcc_rpmvers}
    648649# Requires:       rtems-4.11-sparc64-rtems4.11-binutils
    649 # Requires:       rtems-4.11-sparc64-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     650# Requires:       rtems-4.11-sparc64-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    650651# License:      GPL
    651652
     
    665666Version:        %{gcc_rpmvers}
    666667%{?_with_noarch_subpackages:BuildArch: noarch}
    667 Requires:       rtems-4.11-sparc64-rtems4.11-newlib = %{newlib_version}-21%{?dist}
     668Requires:       rtems-4.11-sparc64-rtems4.11-newlib = %{newlib_version}-22%{?dist}
    668669License:        GPL
    669670
     
    844845License:        Distributable
    845846Version:        %{newlib_version}
    846 Release:        21%{?dist}
     847Release:        22%{?dist}
    847848%{?_with_noarch_subpackages:BuildArch: noarch}
    848849
     
    865866Group:          Development/Tools
    866867Version:        %{newlib_version}
    867 Release:        21%{?dist}
     868Release:        22%{?dist}
    868869%{?_with_noarch_subpackages:BuildArch: noarch}
    869870License:        Distributable
Note: See TracChangeset for help on using the changeset viewer.