Changeset 4e22dfe in rtems-docs


Ignore:
Timestamp:
12/17/21 21:26:53 (11 months ago)
Author:
Ryan Long <ryan.long@…>
Branches:
master
Children:
7be2da1
Parents:
786b89a
git-author:
Ryan Long <ryan.long@…> (12/17/21 21:26:53)
git-committer:
Joel Sherrill <joel@…> (12/22/21 15:03:18)
Message:

Update package list for Ubuntu

Updated the latest version referenced of Ubuntu to 20.04, updated
package list, and identified what packages need to still be installed
afterwards to pass sb-check.

Closes #4110

File:
1 edited

Legend:

Unmodified
Added
Removed
  • user/hosts/posix.rst

    r786b89a r4e22dfe  
    138138~~~~~~
    139139
    140 The latest version is Ubuntu 18.04.1 LTS 64-bit. This section also includes
     140The latest version is Ubuntu 20.04.3 LTS 64-bit. This section also includes
    141141Xubuntu. A minimal installation was used and the following packages installed:
    142142
    143143.. code-block:: none
    144144
    145   $ sudo apt-get build-dep build-essential gcc-defaults g++ gdb git \
    146   unzip pax bison flex texinfo unzip python3-dev libpython-dev \
    147   libncurses5-dev zlib1g-dev
    148 
    149 Note that in previous versions of Ubuntu, the package libpython-dev was
     145  $ sudo apt-get build-dep build-essential gcc-defaults g++ gdb unzip \
     146  pax bison flex texinfo python3-dev libpython2-dev libncurses5-dev \
     147  zlib1g-dev
     148
     149Note that in previous versions of Ubuntu, the package libpython2-dev was
    150150python2.7-dev. The name of packages changes over time. You need the
    151151package with Python development libraries for C/C++ programs. The following
     
    154154.. code-block:: none
    155155
    156   $ sudo apt-get install python-dev
     156  $ sudo apt-get install python git
    157157
    158158It is likely necessary that you will have to enable the Ubuntu Source
Note: See TracChangeset for help on using the changeset viewer.