Changeset 09e920b in rtems


Ignore:
Timestamp:
Aug 31, 2011, 9:17:31 AM (10 years ago)
Author:
Ralf Corsepius <ralf.corsepius@…>
Branches:
4.11, 5, master
Children:
a917c19
Parents:
7594821
Message:

Regenerate.

Location:
contrib/crossrpms/rtems4.11
Files:
15 edited

Legend:

Unmodified
Added
Removed
  • contrib/crossrpms/rtems4.11/arm-eabi/rtems-4.11-arm-rtemseabi4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/arm/rtems-4.11-arm-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/avr/rtems-4.11-avr-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
    6485%ifos mingw mingw32
    6586# Mingw lacks functions required by the h8300 simulator
     
    6788%endif
    6889
    69 %if "%{gdb_version}" >= "6.6"
    7090# suse
    7191%if "%{?suse}" >= "10.3"
     
    7595BuildRequires: %{_host_rpmprefix}expat-devel
    7696%endif
    77 %endif
    78 
    79 %if "%{gdb_version}" < "6.7"
    80 %if "%{_build}" != "%{_host}"
    81 BuildRequires:  %{_host_rpmprefix}termcap-devel
    82 %endif
    83 %bcond_with system_readline
    84 %else
    85 %bcond_without system_readline
    86 %endif
     97
    8798%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8899BuildRequires:  %{_host_rpmprefix}ncurses-devel
    89100
    90 %if "%{gdb_version}" >= "6.8.50"
    91 %if "%{_build}" != "%{_host}"
    92 # Can't build python Cdn-X
    93 %bcond_with python
    94 %else
    95 %bcond_without python
    96 %endif
    97 %endif
    98 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    99101
    100102# Required for building the infos
     
    107109%if "%{gdb_version}" == "7.2"
    108110Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    109 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     111Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    110112%endif
    111113%if "%{gdb_version}" == "7.1"
     
    143145    %{build_sim} \
    144146    %{?with_system_readline:--with-system-readline} \
    145 %if "%{gdb_version}" >= "6.6"
    146147    --with-expat \
    147 %endif
    148 %if "%{gdb_version}" >= "6.8.50"
    149 %if %{with python}
    150     --with-python \
    151 %else
    152     --without-python \
    153 %endif
    154 %endif
     148    %{?with_python:--with-python}%{!?with_python:--without-python} \
    155149    --prefix=%{_prefix} --bindir=%{_bindir} \
    156150    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/i386/rtems-4.11-i386-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/lm32/rtems-4.11-lm32-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
    6485%ifos mingw mingw32
    6586# Mingw lacks functions required by the lm32 simulator
     
    6788%endif
    6889
    69 %if "%{gdb_version}" >= "6.6"
    7090# suse
    7191%if "%{?suse}" >= "10.3"
     
    7595BuildRequires: %{_host_rpmprefix}expat-devel
    7696%endif
    77 %endif
    78 
    79 %if "%{gdb_version}" < "6.7"
    80 %if "%{_build}" != "%{_host}"
    81 BuildRequires:  %{_host_rpmprefix}termcap-devel
    82 %endif
    83 %bcond_with system_readline
    84 %else
    85 %bcond_without system_readline
    86 %endif
     97
    8798%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8899BuildRequires:  %{_host_rpmprefix}ncurses-devel
    89100
    90 %if "%{gdb_version}" >= "6.8.50"
    91 %if "%{_build}" != "%{_host}"
    92 # Can't build python Cdn-X
    93 %bcond_with python
    94 %else
    95 %bcond_without python
    96 %endif
    97 %endif
    98 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    99101
    100102# Required for building the infos
     
    107109%if "%{gdb_version}" == "7.2"
    108110Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    109 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     111Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    110112%endif
    111113%if "%{gdb_version}" == "7.1"
     
    143145    %{build_sim} \
    144146    %{?with_system_readline:--with-system-readline} \
    145 %if "%{gdb_version}" >= "6.6"
    146147    --with-expat \
    147 %endif
    148 %if "%{gdb_version}" >= "6.8.50"
    149 %if %{with python}
    150     --with-python \
    151 %else
    152     --without-python \
    153 %endif
    154 %endif
     148    %{?with_python:--with-python}%{!?with_python:--without-python} \
    155149    --prefix=%{_prefix} --bindir=%{_bindir} \
    156150    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/m32c/rtems-4.11-m32c-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
    6485%ifos mingw mingw32
    6586# Mingw lacks functions required by the m32c simulator
     
    6788%endif
    6889
    69 %if "%{gdb_version}" >= "6.6"
    7090# suse
    7191%if "%{?suse}" >= "10.3"
     
    7595BuildRequires: %{_host_rpmprefix}expat-devel
    7696%endif
    77 %endif
    78 
    79 %if "%{gdb_version}" < "6.7"
    80 %if "%{_build}" != "%{_host}"
    81 BuildRequires:  %{_host_rpmprefix}termcap-devel
    82 %endif
    83 %bcond_with system_readline
    84 %else
    85 %bcond_without system_readline
    86 %endif
     97
    8798%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8899BuildRequires:  %{_host_rpmprefix}ncurses-devel
    89100
    90 %if "%{gdb_version}" >= "6.8.50"
    91 %if "%{_build}" != "%{_host}"
    92 # Can't build python Cdn-X
    93 %bcond_with python
    94 %else
    95 %bcond_without python
    96 %endif
    97 %endif
    98 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    99101
    100102# Required for building the infos
     
    107109%if "%{gdb_version}" == "7.2"
    108110Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    109 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     111Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    110112%endif
    111113%if "%{gdb_version}" == "7.1"
     
    143145    %{build_sim} \
    144146    %{?with_system_readline:--with-system-readline} \
    145 %if "%{gdb_version}" >= "6.6"
    146147    --with-expat \
    147 %endif
    148 %if "%{gdb_version}" >= "6.8.50"
    149 %if %{with python}
    150     --with-python \
    151 %else
    152     --without-python \
    153 %endif
    154 %endif
     148    %{?with_python:--with-python}%{!?with_python:--without-python} \
    155149    --prefix=%{_prefix} --bindir=%{_bindir} \
    156150    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/m32r/rtems-4.11-m32r-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/m68k/rtems-4.11-m68k-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/mips/rtems-4.11-mips-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/mipstx39/rtems-4.11-mipstx39-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
    6485%ifos mingw mingw32
    6586# Mingw lacks functions required by the mipstx39 simulator
     
    6788%endif
    6889
    69 %if "%{gdb_version}" >= "6.6"
    7090# suse
    7191%if "%{?suse}" >= "10.3"
     
    7595BuildRequires: %{_host_rpmprefix}expat-devel
    7696%endif
    77 %endif
    78 
    79 %if "%{gdb_version}" < "6.7"
    80 %if "%{_build}" != "%{_host}"
    81 BuildRequires:  %{_host_rpmprefix}termcap-devel
    82 %endif
    83 %bcond_with system_readline
    84 %else
    85 %bcond_without system_readline
    86 %endif
     97
    8798%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8899BuildRequires:  %{_host_rpmprefix}ncurses-devel
    89100
    90 %if "%{gdb_version}" >= "6.8.50"
    91 %if "%{_build}" != "%{_host}"
    92 # Can't build python Cdn-X
    93 %bcond_with python
    94 %else
    95 %bcond_without python
    96 %endif
    97 %endif
    98 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    99101
    100102# Required for building the infos
     
    107109%if "%{gdb_version}" == "7.2"
    108110Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    109 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     111Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    110112%endif
    111113%if "%{gdb_version}" == "7.1"
     
    143145    %{build_sim} \
    144146    %{?with_system_readline:--with-system-readline} \
    145 %if "%{gdb_version}" >= "6.6"
    146147    --with-expat \
    147 %endif
    148 %if "%{gdb_version}" >= "6.8.50"
    149 %if %{with python}
    150     --with-python \
    151 %else
    152     --without-python \
    153 %endif
    154 %endif
     148    %{?with_python:--with-python}%{!?with_python:--without-python} \
    155149    --prefix=%{_prefix} --bindir=%{_bindir} \
    156150    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/powerpc/rtems-4.11-powerpc-rtems4.11-gdb.spec

    r7594821 r09e920b  
    6262%define build_sim --enable-sim
    6363
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
    6485%if "%{_build}" != "%{_host}"
    6586# psim doesn't support Cdn-X
     
    6990%endif
    7091
    71 %if "%{gdb_version}" >= "6.6"
    7292# suse
    7393%if "%{?suse}" >= "10.3"
     
    7797BuildRequires: %{_host_rpmprefix}expat-devel
    7898%endif
    79 %endif
    80 
    81 %if "%{gdb_version}" < "6.7"
    82 %if "%{_build}" != "%{_host}"
    83 BuildRequires:  %{_host_rpmprefix}termcap-devel
    84 %endif
    85 %bcond_with system_readline
    86 %else
    87 %bcond_without system_readline
    88 %endif
     99
    89100%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    90101BuildRequires:  %{_host_rpmprefix}ncurses-devel
    91102
    92 %if "%{gdb_version}" >= "6.8.50"
    93 %if "%{_build}" != "%{_host}"
    94 # Can't build python Cdn-X
    95 %bcond_with python
    96 %else
    97 %bcond_without python
    98 %endif
    99 %endif
    100 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    101103
    102104# Required for building the infos
     
    145147    %{build_sim} \
    146148    %{?with_system_readline:--with-system-readline} \
    147 %if "%{gdb_version}" >= "6.6"
    148149    --with-expat \
    149 %endif
    150 %if "%{gdb_version}" >= "6.8.50"
    151 %if %{with python}
    152     --with-python \
    153 %else
    154     --without-python \
    155 %endif
    156 %endif
     150    %{?with_python:--with-python}%{!?with_python:--without-python} \
    157151    --prefix=%{_prefix} --bindir=%{_bindir} \
    158152    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/sh/rtems-4.11-sh-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/sparc/rtems-4.11-sparc-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
    6485%ifos mingw mingw32
    6586# Mingw lacks functions required by the sparc simulator
     
    6788%endif
    6889
    69 %if "%{gdb_version}" >= "6.6"
    7090# suse
    7191%if "%{?suse}" >= "10.3"
     
    7595BuildRequires: %{_host_rpmprefix}expat-devel
    7696%endif
    77 %endif
    78 
    79 %if "%{gdb_version}" < "6.7"
    80 %if "%{_build}" != "%{_host}"
    81 BuildRequires:  %{_host_rpmprefix}termcap-devel
    82 %endif
    83 %bcond_with system_readline
    84 %else
    85 %bcond_without system_readline
    86 %endif
     97
    8798%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8899BuildRequires:  %{_host_rpmprefix}ncurses-devel
    89100
    90 %if "%{gdb_version}" >= "6.8.50"
    91 %if "%{_build}" != "%{_host}"
    92 # Can't build python Cdn-X
    93 %bcond_with python
    94 %else
    95 %bcond_without python
    96 %endif
    97 %endif
    98 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    99101
    100102# Required for building the infos
     
    107109%if "%{gdb_version}" == "7.2"
    108110Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    109 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     111Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    110112%endif
    111113%if "%{gdb_version}" == "7.1"
     
    143145    %{build_sim} \
    144146    %{?with_system_readline:--with-system-readline} \
    145 %if "%{gdb_version}" >= "6.6"
    146147    --with-expat \
    147 %endif
    148 %if "%{gdb_version}" >= "6.8.50"
    149 %if %{with python}
    150     --with-python \
    151 %else
    152     --without-python \
    153 %endif
    154 %endif
     148    %{?with_python:--with-python}%{!?with_python:--without-python} \
    155149    --prefix=%{_prefix} --bindir=%{_bindir} \
    156150    --includedir=%{_includedir} --libdir=%{_libdir} \
  • contrib/crossrpms/rtems4.11/sparc64/rtems-4.11-sparc64-rtems4.11-gdb.spec

    r7594821 r09e920b  
    5353Group:          Development/Tools
    5454Version:        %{gdb_rpmvers}
    55 Release:        1%{?dist}
     55Release:        2%{?dist}
    5656License:        GPL/LGPL
    5757URL:            http://sources.redhat.com/gdb
     
    6262%define build_sim --enable-sim
    6363
    64 
    65 %if "%{gdb_version}" >= "6.6"
     64# Whether to build against system readline
     65# Default: yes
     66%bcond_without system_readline
     67
     68# Whether to build python support
     69%if "%{_build}" != "%{_host}"
     70# Can't build python Cdn-X
     71%bcond_with python
     72%else
     73%if "%{gdb_version}" >= "7.3"
     74# Python support is broken
     75%bcond_with python
     76%elseif "%{gdb_version}" >= "6.8.50"
     77%bcond_without python
     78%else
     79# python is unsupported
     80%bcond_with python
     81%endif
     82%endif
     83%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
     84
     85
    6686# suse
    6787%if "%{?suse}" >= "10.3"
     
    7191BuildRequires: %{_host_rpmprefix}expat-devel
    7292%endif
    73 %endif
    74 
    75 %if "%{gdb_version}" < "6.7"
    76 %if "%{_build}" != "%{_host}"
    77 BuildRequires:  %{_host_rpmprefix}termcap-devel
    78 %endif
    79 %bcond_with system_readline
    80 %else
    81 %bcond_without system_readline
    82 %endif
     93
    8394%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
    8495BuildRequires:  %{_host_rpmprefix}ncurses-devel
    8596
    86 %if "%{gdb_version}" >= "6.8.50"
    87 %if "%{_build}" != "%{_host}"
    88 # Can't build python Cdn-X
    89 %bcond_with python
    90 %else
    91 %bcond_without python
    92 %endif
    93 %endif
    94 %{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
    9597
    9698# Required for building the infos
     
    103105%if "%{gdb_version}" == "7.2"
    104106Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
    105 Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
     107Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
    106108%endif
    107109%if "%{gdb_version}" == "7.1"
     
    139141    %{build_sim} \
    140142    %{?with_system_readline:--with-system-readline} \
    141 %if "%{gdb_version}" >= "6.6"
    142143    --with-expat \
    143 %endif
    144 %if "%{gdb_version}" >= "6.8.50"
    145 %if %{with python}
    146     --with-python \
    147 %else
    148     --without-python \
    149 %endif
    150 %endif
     144    %{?with_python:--with-python}%{!?with_python:--without-python} \
    151145    --prefix=%{_prefix} --bindir=%{_bindir} \
    152146    --includedir=%{_includedir} --libdir=%{_libdir} \
Note: See TracChangeset for help on using the changeset viewer.