source: rtems/scripts/autotools/autoconf-rtems.spec @ 17a11842

4.104.114.84.95
Last change on this file since 17a11842 was a792b78, checked in by Joel Sherrill <joel.sherrill@…>, on 09/06/01 at 18:38:31

2001-07-19 Ralf Corsepius <corsepiu@…>

  • autotools/Makefile.am, autotools/autoconf-rtems.spec, autotools/automake-rtems.spec: New.
  • configure.in, Makefile.am: Add autotools/.
  • Property mode set to 100644
File size: 2.5 KB
Line 
1#
2# spec file for autoconf
3#
4
5%define rpmvers 2.52
6%define srcvers 2.52
7
8%define _defaultbuildroot       /var/tmp/%{name}-%{srcvers}-root
9%define _prefix                 /opt/rtems
10%define _name                   autoconf
11
12%if "%{_prefix}" != "/usr"
13%define name                    %{_name}-rtems
14%define _infodir                %{_prefix}/info
15%define _mandir                 %{_prefix}/man
16%else
17%define name                    %{_name}
18%endif
19
20
21Vendor:       http://www.rtems.com
22Name:         %{name}
23Packager:     Ralf Corsepius <corsepiu@faw.uni-ulm.de>
24
25Copyright:    GPL
26URL:          http://www.gnu.org/software/autoconf
27Group:        rtems
28Provides:     autoconf
29Autoreqprov:  on
30Version:      %{rpmvers}
31Release:      0
32Summary:      Tool for automatically generating GNU style Makefile.in's
33BuildArch:    noarch
34BuildRoot:    %{_defaultbuildroot}
35BuildPreReq:  autoconf perl m4 gawk
36PreReq:       /sbin/install-info
37
38Source: autoconf-%{srcvers}.tar.bz2
39
40%description
41GNU's Autoconf is a tool for configuring source code and Makefiles.
42Using Autoconf, programmers can create portable and configurable
43packages, since the person building the package is allowed to
44specify various configuration options.
45You should install Autoconf if you are developing software and you'd
46like to use it to create shell scripts which will configure your
47source code packages.
48Note that the Autoconf package is not required for the end user who
49may be configuring software with an Autoconf-generated script;
50Autoconf is only required for the generation of the scripts, not
51their use.
52
53%prep
54%setup -q -n %{_name}-%{srcvers}
55
56%build
57./configure --prefix=%{_prefix} --infodir=%{_infodir} --mandir=%{_mandir}
58make
59
60%install
61%makeinstall
62gzip -9qf $RPM_BUILD_ROOT%{_infodir}/autoconf.info* 2>/dev/null
63# RTEMS's standards.info comes from binutils
64rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
65# gzip -9qf $RPM_BUILD_ROOT%{_infodir}/standards.info* 2>/dev/null
66gzip -9qf $RPM_BUILD_ROOT%{_mandir}/man?/* 2>/dev/null
67
68%clean
69[ x"$RPM_BUILD_ROOT" = x"%{_defaultbuildroot}" ] ; \
70   rm -rf "$RPM_BUILD_ROOT"
71
72%post
73install-info  --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz
74#install-info  --info-dir=%{_infodir} %{_infodir}/standards.info.gz
75
76%preun
77if [ $1 = 0 ]; then
78  install-info --delete --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz
79#  install-info --delete --info-dir=%{_infodir} %{_infodir}/standards.info.gz
80fi   
81
82%files
83%defattr(-,root,root)
84%doc AUTHORS COPYING ChangeLog NEWS README THANKS
85%{_bindir}/*
86%doc %{_infodir}/autoconf.info*.gz
87#%doc %{_infodir}/standards.info*.gz
88%doc %{_mandir}/man?/*.gz
89%{_datadir}/autoconf
Note: See TracBrowser for help on using the repository browser.