source: rtems/contrib/crossrpms/rtems4.11/m32r/rtems-4.11-m32r-rtems4.11-gdb.spec @ d45c69a

4.115
Last change on this file since d45c69a was d45c69a, checked in by Ralf Corsepius <ralf.corsepius@…>, on 12/13/11 at 18:08:46

Regenerate.

  • Property mode set to 100644
File size: 8.2 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.11
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 7.3.91
49%define gdb_rpmvers %{expand:%(echo 7.3.91 | tr - _)}
50
51Name:           rtems-4.11-m32r-rtems4.11-gdb
52Summary:        Gdb for target m32r-rtems4.11
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        1%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%global build_sim --enable-sim
63
64# Whether to build against system readline
65# Default: yes
66%bcond_without system_readline
67
68# Whether to build python support
69%if "%{_build}" != "%{_host}"
70# Can't build python Cdn-X
71%bcond_with python
72%else
73%bcond_without python
74%endif
75%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
76
77
78# suse
79%if "%{?suse}" >= "10.3"
80BuildRequires: libexpat-devel
81%else
82# Fedora/CentOS/Cygwin/MinGW
83BuildRequires: %{_host_rpmprefix}expat-devel
84%endif
85
86%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
87BuildRequires:  %{_host_rpmprefix}ncurses-devel
88
89# Required for building the infos
90BuildRequires:  /sbin/install-info
91BuildRequires:  texinfo >= 4.2
92Requires:       rtems-4.11-gdb-common
93
94%if "%{gdb_version}" == "7.3.91"
95Source0:  ftp://sourceware.org/pub/gdb/snapshots/branch/gdb/gdb-7.3.91.tar.bz2
96Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.3.91-rtems4.11-20111213.diff
97%endif
98%if "%{gdb_version}" == "7.3.1"
99Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.3.1.tar.bz2
100Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.3.1-rtems4.11-20110905.diff
101%endif
102%if "%{gdb_version}" == "7.2"
103Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
104Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100907.diff
105%endif
106
107%description
108GDB for target m32r-rtems4.11
109%prep
110%setup -q -c -T -n %{name}-%{version}
111
112%setup -q -D -T -n %{name}-%{version} -a0
113cd gdb-%{gdb_version}
114%{?PATCH0:%patch0 -p1}
115cd ..
116
117# Force using a system-provided libreadline
118%{?with_system_readline:rm -f gdb-%{gdb_version}/readline/configure}
119%build
120  export PATH="%{_bindir}:${PATH}"
121  mkdir -p build
122  cd build
123%if "%{_build}" != "%{_host}"
124  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
125%endif
126  CFLAGS="$RPM_OPT_FLAGS" \
127  ../gdb-%{gdb_version}/configure \
128    --build=%_build --host=%_host \
129    --target=m32r-rtems4.11 \
130    --verbose --disable-nls \
131    --without-included-gettext \
132    --disable-win32-registry \
133    --disable-werror \
134    %{build_sim} \
135    %{?with_system_readline:--with-system-readline} \
136    --with-expat \
137    %{?with_python:--with-python}%{!?with_python:--without-python} \
138    --with-gdb-datadir=%{_datadir}/m32r-rtems4.11-gdb \
139    --prefix=%{_prefix} --bindir=%{_bindir} \
140    --includedir=%{_includedir} --libdir=%{_libdir} \
141    --mandir=%{_mandir} --infodir=%{_infodir}
142
143  make %{?_smp_mflags} all
144  make info
145  cd ..
146
147%install
148  export PATH="%{_bindir}:${PATH}"
149  rm -rf $RPM_BUILD_ROOT
150
151  cd build
152  make DESTDIR=$RPM_BUILD_ROOT install
153
154  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
155  touch $RPM_BUILD_ROOT%{_infodir}/dir
156
157# These come from other packages
158  rm -rf $RPM_BUILD_ROOT%{_infodir}/bfd*
159  rm -rf $RPM_BUILD_ROOT%{_infodir}/configure*
160  rm -rf $RPM_BUILD_ROOT%{_infodir}/standards*
161
162# We don't ship host files
163  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
164
165# host library, installed to a bogus directory
166  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libm32r-rtems4.11-sim.a
167
168# Bug in gdb-7.0, bogusly installs linux-only files
169  somethinguseful=0
170  for f in ${RPM_BUILD_ROOT}%{_datadir}/m32r-rtems4.11-gdb/syscalls/*.xml; do
171    case $f in
172    *linux.xml) rm -f $f;;
173    *.xml) somethinguseful=1;;
174    esac
175  done
176  if test $somethinguseful -eq 0; then
177    rm -rf "${RPM_BUILD_ROOT}%{_datadir}/m32r-rtems4.11-gdb/syscalls"
178  fi
179
180%if "{gdb_version}" >= "7.3"
181%if ! %{with python}
182# gdb-7.3 doesn't honor --without-python correctly
183  rm -rf ${RPM_BUILD_ROOT}%{_datadir}/m32r-rtems4.11-gdb/python
184%endif
185%endif
186
187%if "%{gdb_version}" == "7.3.91"
188# gdb-7.3.91, installs host files, we don't want
189  rm ${RPM_BUILD_ROOT}%{_includedir}/gdb/jit-reader.h
190%endif
191
192  cd ..
193
194# Extract %%__os_install_post into os_install_post~
195cat << \EOF > os_install_post~
196%__os_install_post
197EOF
198
199# Generate customized brp-*scripts
200cat os_install_post~ | while read a x y; do
201case $a in
202# Prevent brp-strip* from trying to handle foreign binaries
203*/brp-strip*)
204  b=$(basename $a)
205  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
206  chmod a+x $b
207  ;;
208# Fix up brp-compress to handle %%_prefix != /usr
209*/brp-compress*)
210  b=$(basename $a)
211  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
212  chmod a+x $b
213  ;;
214esac
215done
216
217sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
218  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
219< os_install_post~ > os_install_post
220%define __os_install_post . ./os_install_post
221
222%clean
223  rm -rf $RPM_BUILD_ROOT
224
225# ==============================================================
226# m32r-rtems4.11-gdb
227# ==============================================================
228# %package -n rtems-4.11-m32r-rtems4.11-gdb
229# Summary:      rtems gdb for m32r-rtems4.11
230# Group: Development/Tools
231# %if %build_infos
232# Requires: rtems-4.11-gdb-common
233# %endif
234
235%description -n rtems-4.11-m32r-rtems4.11-gdb
236GNU gdb targetting m32r-rtems4.11.
237
238%files -n rtems-4.11-m32r-rtems4.11-gdb
239%defattr(-,root,root)
240%dir %{_prefix}
241%dir %{_prefix}/share
242%{?with_python:%{_datadir}/m32r-rtems4.11-gdb}
243
244%dir %{_mandir}
245%dir %{_mandir}/man1
246%{_mandir}/man1/m32r-rtems4.11-*.1*
247
248%dir %{_bindir}
249%{_bindir}/m32r-rtems4.11-*
250
251# ==============================================================
252# rtems-4.11-gdb-common
253# ==============================================================
254%package -n rtems-4.11-gdb-common
255Summary:      Base package for RTEMS gdbs
256Group: Development/Tools
257Requires(post):         /sbin/install-info
258Requires(preun):        /sbin/install-info
259%{?_with_noarch_subpackages:BuildArch: noarch}
260
261%description -n rtems-4.11-gdb-common
262
263GDB files shared by all targets.
264
265%post -n rtems-4.11-gdb-common
266  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
267  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
268  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
269  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
270
271%preun -n rtems-4.11-gdb-common
272if [ $1 -eq 0 ]; then
273  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
274  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
275  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
276  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
277fi
278
279%files -n rtems-4.11-gdb-common
280%defattr(-,root,root)
281%dir %{_prefix}
282%dir %{_prefix}/share
283
284%dir %{_infodir}
285%ghost %{_infodir}/dir
286%{_infodir}/gdb.info*
287
288%{_infodir}/gdbint.info*
289%{_infodir}/stabs.info*
290%{_infodir}/annotate.info*
291
Note: See TracBrowser for help on using the repository browser.