source: rtems/contrib/crossrpms/rtems4.11/h8300/rtems-4.11-h8300-rtems4.11-gdb.spec @ 18c4308

4.115
Last change on this file since 18c4308 was 18c4308, checked in by Ralf Corsepius <ralf.corsepius@…>, on 09/03/10 at 05:48:42

Regenerate.

  • Property mode set to 100644
File size: 7.9 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.11
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 7.2
49%define gdb_rpmvers %{expand:%(echo 7.2 | tr - _)}
50
51Name:           rtems-4.11-h8300-rtems4.11-gdb
52Summary:        Gdb for target h8300-rtems4.11
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        1%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%define build_sim --enable-sim
63
64%ifos mingw mingw32
65# Mingw lacks functions required by the h8300 simulator
66%define build_sim --disable-sim
67%endif
68
69%if "%{gdb_version}" >= "6.6"
70# suse
71%if "%{?suse}" >= "10.3"
72BuildRequires: libexpat-devel
73%else
74# Fedora/CentOS/Cygwin/MinGW
75BuildRequires: %{_host_rpmprefix}expat-devel
76%endif
77%endif
78
79%if "%{gdb_version}" < "6.7"
80%if "%{_build}" != "%{_host}"
81BuildRequires:  %{_host_rpmprefix}termcap-devel
82%endif
83%bcond_with system_readline
84%else
85%bcond_without system_readline
86%endif
87%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
88BuildRequires:  %{_host_rpmprefix}ncurses-devel
89
90%if "%{gdb_version}" >= "6.8.50"
91%if "%{_build}" != "%{_host}"
92# Can't build python Cdn-X
93%bcond_with python
94%else
95%bcond_without python
96%endif
97%endif
98%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
99
100# Required for building the infos
101BuildRequires:  /sbin/install-info
102BuildRequires:  texinfo >= 4.2
103
104
105Requires:       rtems-4.11-gdb-common
106
107%if "%{gdb_version}" == "7.2"
108Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.2.tar.bz2
109Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.2-rtems4.11-20100903.diff
110%endif
111%if "%{gdb_version}" == "7.1"
112Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.1.tar.bz2
113Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.1-rtems4.11-20100812.diff
114%endif
115
116%description
117GDB for target h8300-rtems4.11
118%prep
119%setup -q -c -T -n %{name}-%{version}
120
121%setup -q -D -T -n %{name}-%{version} -a0
122cd gdb-%{gdb_version}
123%{?PATCH0:%patch0 -p1}
124cd ..
125
126# Force using a system-provided libreadline
127%{?with_system_readline:rm -f gdb-%{gdb_version}/readline/configure}
128%build
129  export PATH="%{_bindir}:${PATH}"
130  mkdir -p build
131  cd build
132%if "%{_build}" != "%{_host}"
133  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
134%endif
135  CFLAGS="$RPM_OPT_FLAGS" \
136  ../gdb-%{gdb_version}/configure \
137    --build=%_build --host=%_host \
138    --target=h8300-rtems4.11 \
139    --verbose --disable-nls \
140    --without-included-gettext \
141    --disable-win32-registry \
142    --disable-werror \
143    %{build_sim} \
144    %{?with_system_readline:--with-system-readline} \
145%if "%{gdb_version}" >= "6.6"
146    --with-expat \
147%endif
148%if "%{gdb_version}" >= "6.8.50"
149%if %{with python}
150    --with-python \
151%else
152    --without-python \
153%endif
154%endif
155    --prefix=%{_prefix} --bindir=%{_bindir} \
156    --includedir=%{_includedir} --libdir=%{_libdir} \
157    --mandir=%{_mandir} --infodir=%{_infodir}
158
159  make %{?_smp_mflags} all
160  make info
161  cd ..
162
163%install
164  export PATH="%{_bindir}:${PATH}"
165  rm -rf $RPM_BUILD_ROOT
166
167  cd build
168  make DESTDIR=$RPM_BUILD_ROOT install
169
170  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
171  touch $RPM_BUILD_ROOT%{_infodir}/dir
172
173# These come from other packages
174  rm -rf $RPM_BUILD_ROOT%{_infodir}/bfd*
175  rm -rf $RPM_BUILD_ROOT%{_infodir}/configure*
176  rm -rf $RPM_BUILD_ROOT%{_infodir}/standards*
177
178# We don't ship host files
179  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
180
181# host library, installed to a bogus directory
182  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libh8300-rtems4.11-sim.a
183
184%if "%{gdb_version}" >= "7.0"
185# Bug in gdb-7.0, bogusly installs linux-only files
186  somethinguseful=0
187  for f in ${RPM_BUILD_ROOT}%{_datadir}/gdb/syscalls/*.xml; do
188    case $f in
189    *linux.xml) rm -f $f;;
190    *.xml) somethinguseful=1;;
191    esac
192  done
193  if test $somethinguseful -eq 0; then
194    rm -rf "${RPM_BUILD_ROOT}%{_datadir}/gdb/syscalls"
195  fi
196%endif
197
198  cd ..
199
200# Extract %%__os_install_post into os_install_post~
201cat << \EOF > os_install_post~
202%__os_install_post
203EOF
204
205# Generate customized brp-*scripts
206cat os_install_post~ | while read a x y; do
207case $a in
208# Prevent brp-strip* from trying to handle foreign binaries
209*/brp-strip*)
210  b=$(basename $a)
211  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
212  chmod a+x $b
213  ;;
214# Fix up brp-compress to handle %%_prefix != /usr
215*/brp-compress*)
216  b=$(basename $a)
217  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
218  chmod a+x $b
219  ;;
220esac
221done
222
223sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
224  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
225< os_install_post~ > os_install_post
226%define __os_install_post . ./os_install_post
227
228%clean
229  rm -rf $RPM_BUILD_ROOT
230
231# ==============================================================
232# h8300-rtems4.11-gdb
233# ==============================================================
234# %package -n rtems-4.11-h8300-rtems4.11-gdb
235# Summary:      rtems gdb for h8300-rtems4.11
236# Group: Development/Tools
237# %if %build_infos
238# Requires: rtems-4.11-gdb-common
239# %endif
240
241%description -n rtems-4.11-h8300-rtems4.11-gdb
242GNU gdb targetting h8300-rtems4.11.
243
244%files -n rtems-4.11-h8300-rtems4.11-gdb
245%defattr(-,root,root)
246%dir %{_prefix}
247%dir %{_prefix}/share
248
249%dir %{_mandir}
250%dir %{_mandir}/man1
251%{_mandir}/man1/h8300-rtems4.11-*.1*
252
253%dir %{_bindir}
254%{_bindir}/h8300-rtems4.11-*
255
256# ==============================================================
257# rtems-4.11-gdb-common
258# ==============================================================
259%package -n rtems-4.11-gdb-common
260Summary:      Base package for RTEMS gdbs
261Group: Development/Tools
262Requires(post):         /sbin/install-info
263Requires(preun):        /sbin/install-info
264%{?_with_noarch_subpackages:BuildArch: noarch}
265
266%description -n rtems-4.11-gdb-common
267
268GDB files shared by all targets.
269
270%post -n rtems-4.11-gdb-common
271  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
272  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
273  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
274  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
275
276%preun -n rtems-4.11-gdb-common
277if [ $1 -eq 0 ]; then
278  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
279  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
280  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
281  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
282fi
283
284%files -n rtems-4.11-gdb-common
285%defattr(-,root,root)
286%dir %{_prefix}
287%dir %{_prefix}/share
288
289%dir %{_infodir}
290%ghost %{_infodir}/dir
291%{_infodir}/gdb.info*
292
293%{_infodir}/gdbint.info*
294%{_infodir}/stabs.info*
295%{_infodir}/annotate.info*
296
Note: See TracBrowser for help on using the repository browser.