source: rtems/contrib/crossrpms/rtems4.11/bfin/rtems-4.11-bfin-rtems4.11-gdb.spec @ 4f7d002

4.115
Last change on this file since 4f7d002 was 4f7d002, checked in by Ralf Corsepius <ralf.corsepius@…>, on 09/05/11 at 15:59:19

Regenerate.

  • Property mode set to 100644
File size: 7.9 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.11
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 7.3.1
49%define gdb_rpmvers %{expand:%(echo 7.3.1 | tr - _)}
50
51Name:           rtems-4.11-bfin-rtems4.11-gdb
52Summary:        Gdb for target bfin-rtems4.11
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        1%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%global build_sim --enable-sim
63
64# Whether to build against system readline
65# Default: yes
66%bcond_without system_readline
67
68# Whether to build python support
69%if "%{_build}" != "%{_host}"
70# Can't build python Cdn-X
71%bcond_with python
72%else
73%bcond_without python
74%endif
75%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
76
77
78# suse
79%if "%{?suse}" >= "10.3"
80BuildRequires: libexpat-devel
81%else
82# Fedora/CentOS/Cygwin/MinGW
83BuildRequires: %{_host_rpmprefix}expat-devel
84%endif
85
86%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
87BuildRequires:  %{_host_rpmprefix}ncurses-devel
88
89# Required for building the infos
90BuildRequires:  /sbin/install-info
91BuildRequires:  texinfo >= 4.2
92Requires:       rtems-4.11-gdb-common
93
94BuildRequires:  rtems-4.11-bfin-rtems4.11-binutils
95BuildRequires:  texinfo
96
97# The bfin simulator silently tries to conditionally build an SDL based GUI,
98# but fails to link correctly
99# Force not building the GUI.
100%{!?suse:BuildConflicts: SDL-devel}
101%{?suse:BuildConflicts: libSDL-devel}
102
103%if "%{gdb_version}" == "7.3.1"
104Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.3.1.tar.bz2
105Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.3.1-rtems4.11-20110905.diff
106%endif
107
108%description
109GDB for target bfin-rtems4.11
110%prep
111%setup -q -c -T -n %{name}-%{version}
112
113%setup -q -D -T -n %{name}-%{version} -a0
114cd gdb-%{gdb_version}
115%{?PATCH0:%patch0 -p1}
116cd ..
117
118# Force using a system-provided libreadline
119%{?with_system_readline:rm -f gdb-%{gdb_version}/readline/configure}
120%build
121  export PATH="%{_bindir}:${PATH}"
122  mkdir -p build
123  cd build
124%if "%{_build}" != "%{_host}"
125  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
126%endif
127  CFLAGS="$RPM_OPT_FLAGS" \
128  ../gdb-%{gdb_version}/configure \
129    --build=%_build --host=%_host \
130    --target=bfin-rtems4.11 \
131    --verbose --disable-nls \
132    --without-included-gettext \
133    --disable-win32-registry \
134    --disable-werror \
135    %{build_sim} \
136    %{?with_system_readline:--with-system-readline} \
137    --with-expat \
138    %{?with_python:--with-python}%{!?with_python:--without-python} \
139    --with-gdb-datadir=%{_datadir}/bfin-rtems4.11-gdb \
140    --prefix=%{_prefix} --bindir=%{_bindir} \
141    --includedir=%{_includedir} --libdir=%{_libdir} \
142    --mandir=%{_mandir} --infodir=%{_infodir}
143
144  make %{?_smp_mflags} all
145  make info
146  cd ..
147
148%install
149  export PATH="%{_bindir}:${PATH}"
150  rm -rf $RPM_BUILD_ROOT
151
152  cd build
153  make DESTDIR=$RPM_BUILD_ROOT install
154
155  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
156  touch $RPM_BUILD_ROOT%{_infodir}/dir
157
158# These come from other packages
159  rm -rf $RPM_BUILD_ROOT%{_infodir}/bfd*
160  rm -rf $RPM_BUILD_ROOT%{_infodir}/configure*
161  rm -rf $RPM_BUILD_ROOT%{_infodir}/standards*
162
163# We don't ship host files
164  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
165
166# host library, installed to a bogus directory
167  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libbfin-rtems4.11-sim.a
168
169# Bug in gdb-7.0, bogusly installs linux-only files
170  somethinguseful=0
171  for f in ${RPM_BUILD_ROOT}%{_datadir}/bfin-rtems4.11-gdb/syscalls/*.xml; do
172    case $f in
173    *linux.xml) rm -f $f;;
174    *.xml) somethinguseful=1;;
175    esac
176  done
177  if test $somethinguseful -eq 0; then
178    rm -rf "${RPM_BUILD_ROOT}%{_datadir}/bfin-rtems4.11-gdb/syscalls"
179  fi
180
181%if "{gdb_version}" >= "7.3"
182%if ! %{with python}
183# gdb-7.3 doesn't honor --without-python correctly
184  rm -rf ${RPM_BUILD_ROOT}%{_datadir}/bfin-rtems4.11-gdb/python
185%endif
186%endif
187  cd ..
188
189# Extract %%__os_install_post into os_install_post~
190cat << \EOF > os_install_post~
191%__os_install_post
192EOF
193
194# Generate customized brp-*scripts
195cat os_install_post~ | while read a x y; do
196case $a in
197# Prevent brp-strip* from trying to handle foreign binaries
198*/brp-strip*)
199  b=$(basename $a)
200  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
201  chmod a+x $b
202  ;;
203# Fix up brp-compress to handle %%_prefix != /usr
204*/brp-compress*)
205  b=$(basename $a)
206  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
207  chmod a+x $b
208  ;;
209esac
210done
211
212sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
213  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
214< os_install_post~ > os_install_post
215%define __os_install_post . ./os_install_post
216
217%clean
218  rm -rf $RPM_BUILD_ROOT
219
220# ==============================================================
221# bfin-rtems4.11-gdb
222# ==============================================================
223# %package -n rtems-4.11-bfin-rtems4.11-gdb
224# Summary:      rtems gdb for bfin-rtems4.11
225# Group: Development/Tools
226# %if %build_infos
227# Requires: rtems-4.11-gdb-common
228# %endif
229
230%description -n rtems-4.11-bfin-rtems4.11-gdb
231GNU gdb targetting bfin-rtems4.11.
232
233%files -n rtems-4.11-bfin-rtems4.11-gdb
234%defattr(-,root,root)
235%dir %{_prefix}
236%dir %{_prefix}/share
237%{?with_python:%{_datadir}/bfin-rtems4.11-gdb}
238
239%dir %{_mandir}
240%dir %{_mandir}/man1
241%{_mandir}/man1/bfin-rtems4.11-*.1*
242
243%dir %{_bindir}
244%{_bindir}/bfin-rtems4.11-*
245
246# ==============================================================
247# rtems-4.11-gdb-common
248# ==============================================================
249%package -n rtems-4.11-gdb-common
250Summary:      Base package for RTEMS gdbs
251Group: Development/Tools
252Requires(post):         /sbin/install-info
253Requires(preun):        /sbin/install-info
254%{?_with_noarch_subpackages:BuildArch: noarch}
255
256%description -n rtems-4.11-gdb-common
257
258GDB files shared by all targets.
259
260%post -n rtems-4.11-gdb-common
261  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
262  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
263  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
264  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
265
266%preun -n rtems-4.11-gdb-common
267if [ $1 -eq 0 ]; then
268  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
269  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
270  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
271  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
272fi
273
274%files -n rtems-4.11-gdb-common
275%defattr(-,root,root)
276%dir %{_prefix}
277%dir %{_prefix}/share
278
279%dir %{_infodir}
280%ghost %{_infodir}/dir
281%{_infodir}/gdb.info*
282
283%{_infodir}/gdbint.info*
284%{_infodir}/stabs.info*
285%{_infodir}/annotate.info*
286
Note: See TracBrowser for help on using the repository browser.