source: rtems/contrib/crossrpms/rtems4.11/avr/rtems-4.11-avr-rtems4.11-gdb.spec @ 9f86f4a9

4.115
Last change on this file since 9f86f4a9 was 9f86f4a9, checked in by Ralf Corsepius <ralf.corsepius@…>, on 08/12/10 at 14:09:54

Regenerate.

  • Property mode set to 100644
File size: 7.6 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.11
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 7.1
49%define gdb_rpmvers %{expand:%(echo 7.1 | tr - _)}
50
51Name:           rtems-4.11-avr-rtems4.11-gdb
52Summary:        Gdb for target avr-rtems4.11
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        4%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%define build_sim --enable-sim
63
64
65%if "%{gdb_version}" >= "6.6"
66# suse
67%if "%{?suse}" >= "10.3"
68BuildRequires: libexpat-devel
69%else
70# Fedora/CentOS/Cygwin/MinGW
71BuildRequires: %{_host_rpmprefix}expat-devel
72%endif
73%endif
74
75%if "%{gdb_version}" < "6.7"
76%if "%{_build}" != "%{_host}"
77BuildRequires:  %{_host_rpmprefix}termcap-devel
78%endif
79%bcond_with system_readline
80%else
81%bcond_without system_readline
82%endif
83%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
84BuildRequires:  %{_host_rpmprefix}ncurses-devel
85
86%if "%{gdb_version}" >= "6.8.50"
87%if "%{_build}" != "%{_host}"
88# Can't build python Cdn-X
89%bcond_with python
90%else
91%bcond_without python
92%endif
93%endif
94%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
95
96# Required for building the infos
97BuildRequires:  /sbin/install-info
98BuildRequires:  texinfo >= 4.2
99
100
101Requires:       rtems-4.11-gdb-common
102
103%if "%{gdb_version}" == "7.1"
104Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-7.1.tar.bz2
105Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gdb-7.1-rtems4.11-20100812.diff
106%endif
107
108%description
109GDB for target avr-rtems4.11
110%prep
111%setup -q -c -T -n %{name}-%{version}
112
113%setup -q -D -T -n %{name}-%{version} -a0
114cd gdb-%{gdb_version}
115%{?PATCH0:%patch0 -p1}
116cd ..
117
118# Force using a system-provided libreadline
119%{?with_system_readline:rm -f gdb-%{gdb_version}/readline/configure}
120%build
121  export PATH="%{_bindir}:${PATH}"
122  mkdir -p build
123  cd build
124%if "%{_build}" != "%{_host}"
125  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
126%endif
127  CFLAGS="$RPM_OPT_FLAGS" \
128  ../gdb-%{gdb_version}/configure \
129    --build=%_build --host=%_host \
130    --target=avr-rtems4.11 \
131    --verbose --disable-nls \
132    --without-included-gettext \
133    --disable-win32-registry \
134    --disable-werror \
135    %{build_sim} \
136    %{?with_system_readline:--with-system-readline} \
137%if "%{gdb_version}" >= "6.6"
138    --with-expat \
139%endif
140%if "%{gdb_version}" >= "6.8.50"
141%if %{with python}
142    --with-python \
143%else
144    --without-python \
145%endif
146%endif
147    --prefix=%{_prefix} --bindir=%{_bindir} \
148    --includedir=%{_includedir} --libdir=%{_libdir} \
149    --mandir=%{_mandir} --infodir=%{_infodir}
150
151  make %{?_smp_mflags} all
152  make info
153  cd ..
154
155%install
156  export PATH="%{_bindir}:${PATH}"
157  rm -rf $RPM_BUILD_ROOT
158
159  cd build
160  make DESTDIR=$RPM_BUILD_ROOT install
161
162  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
163  touch $RPM_BUILD_ROOT%{_infodir}/dir
164
165# These come from other packages
166  rm -rf $RPM_BUILD_ROOT%{_infodir}/bfd*
167  rm -rf $RPM_BUILD_ROOT%{_infodir}/configure*
168  rm -rf $RPM_BUILD_ROOT%{_infodir}/standards*
169
170# We don't ship host files
171  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
172
173# host library, installed to a bogus directory
174  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libavr-rtems4.11-sim.a
175
176%if "%{gdb_version}" >= "7.0"
177# Bug in gdb-7.0, bogusly installs linux-only files
178  somethinguseful=0
179  for f in ${RPM_BUILD_ROOT}%{_datadir}/gdb/syscalls/*.xml; do
180    case $f in
181    *linux.xml) rm -f $f;;
182    *.xml) somethinguseful=1;;
183    esac
184  done
185  if test $somethinguseful -eq 0; then
186    rm -rf "${RPM_BUILD_ROOT}%{_datadir}/gdb/syscalls"
187  fi
188%endif
189
190  cd ..
191
192# Extract %%__os_install_post into os_install_post~
193cat << \EOF > os_install_post~
194%__os_install_post
195EOF
196
197# Generate customized brp-*scripts
198cat os_install_post~ | while read a x y; do
199case $a in
200# Prevent brp-strip* from trying to handle foreign binaries
201*/brp-strip*)
202  b=$(basename $a)
203  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
204  chmod a+x $b
205  ;;
206# Fix up brp-compress to handle %%_prefix != /usr
207*/brp-compress*)
208  b=$(basename $a)
209  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
210  chmod a+x $b
211  ;;
212esac
213done
214
215sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
216  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
217< os_install_post~ > os_install_post
218%define __os_install_post . ./os_install_post
219
220%clean
221  rm -rf $RPM_BUILD_ROOT
222
223# ==============================================================
224# avr-rtems4.11-gdb
225# ==============================================================
226# %package -n rtems-4.11-avr-rtems4.11-gdb
227# Summary:      rtems gdb for avr-rtems4.11
228# Group: Development/Tools
229# %if %build_infos
230# Requires: rtems-4.11-gdb-common
231# %endif
232
233%description -n rtems-4.11-avr-rtems4.11-gdb
234GNU gdb targetting avr-rtems4.11.
235
236%files -n rtems-4.11-avr-rtems4.11-gdb
237%defattr(-,root,root)
238%dir %{_prefix}
239%dir %{_prefix}/share
240
241%dir %{_mandir}
242%dir %{_mandir}/man1
243%{_mandir}/man1/avr-rtems4.11-*.1*
244
245%dir %{_bindir}
246%{_bindir}/avr-rtems4.11-*
247
248# ==============================================================
249# rtems-4.11-gdb-common
250# ==============================================================
251%package -n rtems-4.11-gdb-common
252Summary:      Base package for RTEMS gdbs
253Group: Development/Tools
254Requires(post):         /sbin/install-info
255Requires(preun):        /sbin/install-info
256%{?_with_noarch_subpackages:BuildArch: noarch}
257
258%description -n rtems-4.11-gdb-common
259
260GDB files shared by all targets.
261
262%post -n rtems-4.11-gdb-common
263  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
264  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
265  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
266  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
267
268%preun -n rtems-4.11-gdb-common
269if [ $1 -eq 0 ]; then
270  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
271  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
272  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
273  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
274fi
275
276%files -n rtems-4.11-gdb-common
277%defattr(-,root,root)
278%dir %{_prefix}
279%dir %{_prefix}/share
280
281%dir %{_infodir}
282%ghost %{_infodir}/dir
283%{_infodir}/gdb.info*
284
285%{_infodir}/gdbint.info*
286%{_infodir}/stabs.info*
287%{_infodir}/annotate.info*
288
Note: See TracBrowser for help on using the repository browser.