source: rtems/contrib/crossrpms/rtems4.10/m32c/rtems-4.10-m32c-rtems4.10-gdb.spec @ 6f8d49b4

4.104.115
Last change on this file since 6f8d49b4 was 6f8d49b4, checked in by Ralf Corsepius <ralf.corsepius@…>, on 02/25/10 at 05:52:05

Regenerate.

  • Property mode set to 100644
File size: 8.5 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.10
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 7.0.90
49%define gdb_rpmvers %{expand:%(echo 7.0.90 | tr - _)}
50
51Name:           rtems-4.10-m32c-rtems4.10-gdb
52Summary:        Gdb for target m32c-rtems4.10
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        2%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%define build_sim --enable-sim
63%if "%{_build}" != "%{_host}"
64# psim doesn't support Cdn-X
65%if "m32c-rtems4.10" == "powerpc-rtems4.10"
66%define build_sim --disable-sim
67%endif
68%endif
69
70%ifos mingw mingw32
71# Mingw lacks functions required by the simulator
72%if "m32c-rtems4.10" == "sparc-rtems4.10"
73%define build_sim --disable-sim
74%endif
75%if "m32c-rtems4.10" == "h8300-rtems4.10"
76%define build_sim --disable-sim
77%endif
78%if "%{gdb_version}" >= "6.8.50"
79%if "m32c-rtems4.10" == "m32c-rtems4.10"
80%define build_sim --disable-sim
81%endif
82%endif
83%if "m32c-rtems4.10" == "lm32-rtems4.10"
84%define build_sim --disable-sim
85%endif
86%if "m32c-rtems4.10" == "mipstx39-rtems4.10"
87%define build_sim --disable-sim
88%endif
89%endif
90
91%if "%{gdb_version}" >= "6.6"
92# suse
93%if "%{?suse}" >= "10.3"
94BuildRequires: libexpat-devel
95%else
96# Fedora/CentOS/Cygwin/MinGW
97BuildRequires: %{_host_rpmprefix}expat-devel
98%endif
99%endif
100
101%if "%{gdb_version}" < "6.7"
102%if "%{_build}" != "%{_host}"
103BuildRequires:  %{_host_rpmprefix}termcap-devel
104%endif
105%bcond_with system_readline
106%else
107%bcond_without system_readline
108%endif
109%{?with_system_readline:BuildRequires: %{_host_rpmprefix}readline-devel}
110BuildRequires:  %{_host_rpmprefix}ncurses-devel
111
112%if "%{gdb_version}" >= "6.8.50"
113%if "%{_build}" != "%{_host}"
114# Can't build python Cdn-X
115%bcond_with python
116%else
117%bcond_without python
118%endif
119%endif
120%{?with_python:BuildRequires: %{_host_rpmprefix}python-devel}
121
122# Required for building the infos
123BuildRequires:  /sbin/install-info
124BuildRequires:  texinfo >= 4.2
125
126
127Requires:       rtems-4.10-gdb-common
128
129%if "%{gdb_version}" == "7.0.90"
130Source0: ftp://sourceware.org/pub/gdb/snapshots/branch/gdb-7.0.90.tar.bz2
131Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-7.0.90-rtems4.10-20100225.diff
132%endif
133
134%if "%{gdb_version}" == "7.0.1"
135Source0: ftp://ftp.gnu.org/gnu/gdb/gdb-%{gdb_version}.tar.bz2
136Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-%{gdb_version}-rtems4.10-20091222.diff
137%endif
138
139%description
140GDB for target m32c-rtems4.10
141%prep
142%setup -q -c -T -n %{name}-%{version}
143
144%setup -q -D -T -n %{name}-%{version} -a0
145cd gdb-%{gdb_version}
146%{?PATCH0:%patch0 -p1}
147cd ..
148
149# Force using a system-provided libreadline
150%{?with_system_readline:rm -f gdb-%{gdb_version}/readline/configure}
151%build
152  export PATH="%{_bindir}:${PATH}"
153  mkdir -p build
154  cd build
155%if "%{_build}" != "%{_host}"
156  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
157%endif
158  CFLAGS="$RPM_OPT_FLAGS" \
159  ../gdb-%{gdb_version}/configure \
160    --build=%_build --host=%_host \
161    --target=m32c-rtems4.10 \
162    --verbose --disable-nls \
163    --without-included-gettext \
164    --disable-win32-registry \
165    --disable-werror \
166    %{build_sim} \
167    %{?with_system_readline:--with-system-readline} \
168%if "%{gdb_version}" >= "6.6"
169    --with-expat \
170%endif
171%if "%{gdb_version}" >= "6.8.50"
172%if %{with python}
173    --with-python \
174%else
175    --without-python \
176%endif
177%endif
178    --prefix=%{_prefix} --bindir=%{_bindir} \
179    --includedir=%{_includedir} --libdir=%{_libdir} \
180    --mandir=%{_mandir} --infodir=%{_infodir}
181
182  make %{?_smp_mflags} all
183  make info
184  cd ..
185
186%install
187  export PATH="%{_bindir}:${PATH}"
188  rm -rf $RPM_BUILD_ROOT
189
190  cd build
191  make DESTDIR=$RPM_BUILD_ROOT install
192
193  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
194  touch $RPM_BUILD_ROOT%{_infodir}/dir
195
196# These come from other packages
197  rm -rf $RPM_BUILD_ROOT%{_infodir}/bfd*
198  rm -rf $RPM_BUILD_ROOT%{_infodir}/configure*
199  rm -rf $RPM_BUILD_ROOT%{_infodir}/standards*
200
201# We don't ship host files
202  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
203
204# host library, installed to a bogus directory
205  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libm32c-rtems4.10-sim.a
206
207%if "%{gdb_version}" >= "7.0"
208# Bug in gdb-7.0, bogusly installs linux-only files
209  somethinguseful=0
210  for f in ${RPM_BUILD_ROOT}%{_datadir}/gdb/syscalls/*.xml; do
211    case $f in
212    *linux.xml) rm -f $f;;
213    *.xml) somethinguseful=1;;
214    esac
215  done
216  if test $somethinguseful -eq 0; then
217    rm -rf "${RPM_BUILD_ROOT}%{_datadir}/gdb/syscalls"
218  fi
219%endif
220
221  cd ..
222
223# Extract %%__os_install_post into os_install_post~
224cat << \EOF > os_install_post~
225%__os_install_post
226EOF
227
228# Generate customized brp-*scripts
229cat os_install_post~ | while read a x y; do
230case $a in
231# Prevent brp-strip* from trying to handle foreign binaries
232*/brp-strip*)
233  b=$(basename $a)
234  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
235  chmod a+x $b
236  ;;
237# Fix up brp-compress to handle %%_prefix != /usr
238*/brp-compress*)
239  b=$(basename $a)
240  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
241  chmod a+x $b
242  ;;
243esac
244done
245
246sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
247  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
248< os_install_post~ > os_install_post
249%define __os_install_post . ./os_install_post
250
251%clean
252  rm -rf $RPM_BUILD_ROOT
253
254# ==============================================================
255# m32c-rtems4.10-gdb
256# ==============================================================
257# %package -n rtems-4.10-m32c-rtems4.10-gdb
258# Summary:      rtems gdb for m32c-rtems4.10
259# Group: Development/Tools
260# %if %build_infos
261# Requires: rtems-4.10-gdb-common
262# %endif
263
264%description -n rtems-4.10-m32c-rtems4.10-gdb
265GNU gdb targetting m32c-rtems4.10.
266
267%files -n rtems-4.10-m32c-rtems4.10-gdb
268%defattr(-,root,root)
269%dir %{_prefix}
270%dir %{_prefix}/share
271
272%dir %{_mandir}
273%dir %{_mandir}/man1
274%{_mandir}/man1/m32c-rtems4.10-*.1*
275
276%dir %{_bindir}
277%{_bindir}/m32c-rtems4.10-*
278
279# ==============================================================
280# rtems-4.10-gdb-common
281# ==============================================================
282%package -n rtems-4.10-gdb-common
283Summary:      Base package for RTEMS gdbs
284Group: Development/Tools
285Requires(post):         /sbin/install-info
286Requires(preun):        /sbin/install-info
287%{?_with_noarch_subpackages:BuildArch: noarch}
288
289%description -n rtems-4.10-gdb-common
290
291GDB files shared by all targets.
292
293%post -n rtems-4.10-gdb-common
294  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
295  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
296  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
297  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
298
299%preun -n rtems-4.10-gdb-common
300if [ $1 -eq 0 ]; then
301  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
302  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
303  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
304  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
305fi
306
307%files -n rtems-4.10-gdb-common
308%defattr(-,root,root)
309%dir %{_prefix}
310%dir %{_prefix}/share
311
312%dir %{_infodir}
313%ghost %{_infodir}/dir
314%{_infodir}/gdb.info*
315
316%{_infodir}/gdbint.info*
317%{_infodir}/stabs.info*
318%{_infodir}/annotate.info*
319
Note: See TracBrowser for help on using the repository browser.