source: rtems/contrib/crossrpms/rtems4.10/m32c/rtems-4.10-m32c-rtems4.10-gdb.spec @ 5ca8bf3b

4.104.115
Last change on this file since 5ca8bf3b was 5ca8bf3b, checked in by Ralf Corsepius <ralf.corsepius@…>, on 06/29/09 at 16:55:24

Update to gdb-6.8.50.20090629

  • Property mode set to 100644
File size: 6.2 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.10
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix rtems-4.10-%{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 6.8.50.20090629
49%define gdb_rpmvers %{expand:%(echo 6.8.50.20090629 | tr - _)}
50
51Name:           rtems-4.10-m32c-rtems4.10-gdb
52Summary:        Gdb for target m32c-rtems4.10
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        1%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%define build_sim --enable-sim
63%if "%{_build}" != "%{_host}"
64# psim doesn't support Cdn-X
65%if "m32c-rtems4.10" == "powerpc-rtems4.10"
66%define build_sim --disable-sim
67%endif
68%endif
69
70%ifos mingw mingw32
71# Mingw lacks functions required by the simulator
72%if "m32c-rtems4.10" == "sparc-rtems4.10"
73%define build_sim --disable-sim
74%endif
75%if "m32c-rtems4.10" == "h8300-rtems4.10"
76%define build_sim --disable-sim
77%endif
78%if "%{gdb_version}" >= "6.8.50"
79%if "m32c-rtems4.10" == "m32c-rtems4.10"
80%define build_sim --disable-sim
81%endif
82%endif
83%if "m32c-rtems4.10" == "lm32-rtems4.10"
84%define build_sim --disable-sim
85%endif
86%if "m32c-rtems4.10" == "mipstx39-rtems4.10"
87%define build_sim --disable-sim
88%endif
89%endif
90
91%if "%{gdb_version}" >= "6.6"
92# suse
93%if "%{?suse}" >= "10.3"
94BuildRequires: libexpat-devel
95%else
96# Fedora/CentOS/Cygwin/MinGW
97BuildRequires: %{_host_rpmprefix}expat-devel
98%endif
99%endif
100
101%if "%{gdb_version}" < "6.7"
102%if "%{_build}" != "%{_host}"
103BuildRequires:  %{_host_rpmprefix}termcap-devel
104%endif
105%endif
106BuildRequires:  %{_host_rpmprefix}readline-devel
107BuildRequires:  %{_host_rpmprefix}ncurses-devel
108
109
110
111# A copy of a gdb development snapshot having been retrieved from
112# ftp://sources.redhat.com/pub/gdb/snapshots/current/gdb-%{gdb_version}.tar.bz2
113Source0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-%{gdb_version}.tar.bz2
114
115# rtems-4.10 patches
116# + lm32-sim/gdb http://sourceware.org/ml/gdb-patches/2008-12/msg00373.html
117# + misc small fixes to lm32-sim/gdb
118# + avr simulator
119Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-6.8.50.20090629-rtems4.10-20090629.diff
120
121%description
122GDB for target m32c-rtems4.10
123%prep
124%setup -q -c -T -n %{name}-%{version}
125
126%setup -q -D -T -n %{name}-%{version} -a0
127cd gdb-%{gdb_version}
128%{?PATCH0:%patch0 -p1}
129cd ..
130
131%if "%{gdb_version}" >= "6.7"
132# Force using a system-provided libreadline
133rm -f gdb-%{gdb_version}/readline/configure
134%endif
135%build
136  export PATH="%{_bindir}:${PATH}"
137  mkdir -p build
138  cd build
139%if "%{_build}" != "%{_host}"
140  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
141%endif
142  CFLAGS="$RPM_OPT_FLAGS" \
143  ../gdb-%{gdb_version}/configure \
144    --build=%_build --host=%_host \
145    --target=m32c-rtems4.10 \
146    --verbose --disable-nls \
147    --without-included-gettext \
148    --disable-win32-registry \
149    --disable-werror \
150    %{build_sim} \
151%if "%{gdb_version}" >= "6.7"
152    --with-system-readline \
153%endif
154%if "%{gdb_version}" >= "6.6"
155    --with-expat \
156%endif
157%if "%{gdb_version}" >= "6.8.50"
158    --without-python \
159%endif
160    --prefix=%{_prefix} --bindir=%{_bindir} \
161    --includedir=%{_includedir} --libdir=%{_libdir} \
162    --mandir=%{_mandir} --infodir=%{_infodir}
163
164  make %{?_smp_mflags} all
165  cd ..
166
167%install
168  export PATH="%{_bindir}:${PATH}"
169  rm -rf $RPM_BUILD_ROOT
170
171  cd build
172  make DESTDIR=$RPM_BUILD_ROOT install
173
174# Conflict with a native gdb's infos
175  rm -rf $RPM_BUILD_ROOT%{_infodir}
176
177# We don't ship host files
178  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
179
180# host library, installed to a bogus directory
181  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libm32c-rtems4.10-sim.a
182
183  cd ..
184
185# Extract %%__os_install_post into os_install_post~
186cat << \EOF > os_install_post~
187%__os_install_post
188EOF
189
190# Generate customized brp-*scripts
191cat os_install_post~ | while read a x y; do
192case $a in
193# Prevent brp-strip* from trying to handle foreign binaries
194*/brp-strip*)
195  b=$(basename $a)
196  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
197  chmod a+x $b
198  ;;
199# Fix up brp-compress to handle %%_prefix != /usr
200*/brp-compress*)
201  b=$(basename $a)
202  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
203  chmod a+x $b
204  ;;
205esac
206done
207
208sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
209  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
210< os_install_post~ > os_install_post
211%define __os_install_post . ./os_install_post
212
213%clean
214  rm -rf $RPM_BUILD_ROOT
215
216# ==============================================================
217# m32c-rtems4.10-gdb
218# ==============================================================
219# %package -n rtems-4.10-m32c-rtems4.10-gdb
220# Summary:      rtems gdb for m32c-rtems4.10
221# Group: Development/Tools
222# %if %build_infos
223# Requires: rtems-4.10-gdb-common
224# %endif
225
226%description -n rtems-4.10-m32c-rtems4.10-gdb
227GNU gdb targetting m32c-rtems4.10.
228
229%files -n rtems-4.10-m32c-rtems4.10-gdb
230%defattr(-,root,root)
231%dir %{_mandir}
232%dir %{_mandir}/man1
233%{_mandir}/man1/m32c-rtems4.10-*.1*
234
235%dir %{_bindir}
236%{_bindir}/m32c-rtems4.10-*
237
Note: See TracBrowser for help on using the repository browser.