source: rtems/contrib/crossrpms/rtems4.10/m32c/rtems-4.10-m32c-rtems4.10-gdb.spec @ 88ab8f3

4.104.115
Last change on this file since 88ab8f3 was 88ab8f3, checked in by Ralf Corsepius <ralf.corsepius@…>, on 02/24/09 at 09:10:23

Regenerate, fix spec file.

  • Property mode set to 100644
File size: 7.2 KB
RevLine 
[b38ae26b]1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
[54726239]6%define _prefix                 /opt/rtems-4.10
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
[b38ae26b]21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
[3b35bcc5]24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
[b38ae26b]26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
[3b35bcc5]32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
[b38ae26b]40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix rtems-4.10-%{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 6.8
49%define gdb_rpmvers %{expand:%(echo 6.8 | tr - _)}
50
51Name:           rtems-4.10-m32c-rtems4.10-gdb
52Summary:        Gdb for target m32c-rtems4.10
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
[88ab8f3]55Release:        9%{?dist}
[b38ae26b]56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
[3b35bcc5]62%define build_sim --enable-sim
[147257d4]63%if "%{_build}" != "%{_host}"
[3b35bcc5]64# psim doesn't support Cdn-X
[147257d4]65%if "m32c-rtems4.10" == "powerpc-rtems4.10"
[3b35bcc5]66%define build_sim --disable-sim
67%endif
[147257d4]68%endif
69
[3b35bcc5]70%ifos mingw mingw32
71# Mingw lacks functions required by the simulator
72%if "m32c-rtems4.10" == "sparc-rtems4.10"
73%define build_sim --disable-sim
74%endif
75%if "m32c-rtems4.10" == "h8300-rtems4.10"
76%define build_sim --disable-sim
77%endif
[147257d4]78%if "m32c-rtems4.10" == "mipstx39-rtems4.10"
79%define build_sim --disable-sim
80%endif
[3b35bcc5]81%endif
82
[b38ae26b]83%if "%{gdb_version}" >= "6.6"
84# suse
[88ab8f3]85%if "%{?suse}" >= "10.3"
[b38ae26b]86BuildRequires: libexpat-devel
87%else
[147257d4]88# Fedora/CentOS/Cygwin/MinGW
[b38ae26b]89BuildRequires: %{_host_rpmprefix}expat-devel
90%endif
91%endif
92
93%if "%{gdb_version}" < "6.7"
94%if "%{_build}" != "%{_host}"
95BuildRequires:  %{_host_rpmprefix}termcap-devel
96%endif
97%endif
98BuildRequires:  %{_host_rpmprefix}readline-devel
99BuildRequires:  %{_host_rpmprefix}ncurses-devel
100
101# Required for building the infos
102BuildRequires:  /sbin/install-info
103BuildRequires:  texinfo >= 4.2
104
105
106Requires:       rtems-4.10-gdb-common
107
108Source0: ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
[3b35bcc5]109Patch0:  ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-6.8-rtems4.10-20090122.diff
[b38ae26b]110
111%description
112GDB for target m32c-rtems4.10
113%prep
114%setup -q -c -T -n %{name}-%{version}
115
116%setup -q -D -T -n %{name}-%{version} -a0
117cd gdb-%{gdb_version}
118%{?PATCH0:%patch0 -p1}
119cd ..
120
121%if "%{gdb_version}" >= "6.7"
122# Force using a system-provided libreadline
123rm -f gdb-%{gdb_version}/readline/configure
124%endif
125%build
126  export PATH="%{_bindir}:${PATH}"
127  mkdir -p build
128  cd build
129%if "%{_build}" != "%{_host}"
130  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
131%endif
132  CFLAGS="$RPM_OPT_FLAGS" \
133  ../gdb-%{gdb_version}/configure \
134    --build=%_build --host=%_host \
135    --target=m32c-rtems4.10 \
136    --verbose --disable-nls \
137    --without-included-gettext \
138    --disable-win32-registry \
139    --disable-werror \
[3b35bcc5]140    %{build_sim} \
[b38ae26b]141%if "%{gdb_version}" >= "6.7"
142    --with-system-readline \
143%endif
144%if "%{gdb_version}" >= "6.6"
145    --with-expat \
[88ab8f3]146%endif
147%if "%{gdb_version}" >= "6.8.50"
148    --without-python \
[b38ae26b]149%endif
150    --prefix=%{_prefix} --bindir=%{_bindir} \
151    --includedir=%{_includedir} --libdir=%{_libdir} \
152    --mandir=%{_mandir} --infodir=%{_infodir}
153
154  make %{?_smp_mflags} all
155  make info
156  cd ..
157
158%install
159  export PATH="%{_bindir}:${PATH}"
160  rm -rf $RPM_BUILD_ROOT
161
162  cd build
163  make DESTDIR=$RPM_BUILD_ROOT install
164
165  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
166  touch $RPM_BUILD_ROOT%{_infodir}/dir
167
168# These come from other packages
169  rm -rf $RPM_BUILD_ROOT%{_infodir}/bfd*
170  rm -rf $RPM_BUILD_ROOT%{_infodir}/configure*
171  rm -rf $RPM_BUILD_ROOT%{_infodir}/standards*
172
173# We don't ship host files
174  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
175
176# host library, installed to a bogus directory
177  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libm32c-rtems4.10-sim.a
178
179  cd ..
180
181# Extract %%__os_install_post into os_install_post~
182cat << \EOF > os_install_post~
183%__os_install_post
184EOF
185
186# Generate customized brp-*scripts
187cat os_install_post~ | while read a x y; do
188case $a in
189# Prevent brp-strip* from trying to handle foreign binaries
190*/brp-strip*)
191  b=$(basename $a)
192  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
193  chmod a+x $b
194  ;;
195# Fix up brp-compress to handle %%_prefix != /usr
196*/brp-compress*)
197  b=$(basename $a)
198  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
199  chmod a+x $b
200  ;;
201esac
202done
203
204sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
205  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
206< os_install_post~ > os_install_post
207%define __os_install_post . ./os_install_post
208
209%clean
210  rm -rf $RPM_BUILD_ROOT
211
212# ==============================================================
213# m32c-rtems4.10-gdb
214# ==============================================================
215# %package -n rtems-4.10-m32c-rtems4.10-gdb
216# Summary:      rtems gdb for m32c-rtems4.10
217# Group: Development/Tools
218# %if %build_infos
219# Requires: rtems-4.10-gdb-common
220# %endif
221
222%description -n rtems-4.10-m32c-rtems4.10-gdb
223GNU gdb targetting m32c-rtems4.10.
224
225%files -n rtems-4.10-m32c-rtems4.10-gdb
226%defattr(-,root,root)
227%dir %{_mandir}
228%dir %{_mandir}/man1
229%{_mandir}/man1/m32c-rtems4.10-*.1*
230
231%dir %{_bindir}
232%{_bindir}/m32c-rtems4.10-*
233
234# ==============================================================
235# rtems-4.10-gdb-common
236# ==============================================================
237%package -n rtems-4.10-gdb-common
238Summary:      Base package for RTEMS gdbs
239Group: Development/Tools
240Requires(post):         /sbin/install-info
241Requires(preun):        /sbin/install-info
242
243%description -n rtems-4.10-gdb-common
244
245GDB files shared by all targets.
246
247%post -n rtems-4.10-gdb-common
248  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
249  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
250  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
251  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
252
253%preun -n rtems-4.10-gdb-common
254if [ $1 -eq 0 ]; then
255  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
256  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
257  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
258  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
259fi
260
261%files -n rtems-4.10-gdb-common
262%defattr(-,root,root)
263%dir %{_infodir}
264%ghost %{_infodir}/dir
265%{_infodir}/gdb.info*
266
267%{_infodir}/gdbint.info*
268%{_infodir}/stabs.info*
269%{_infodir}/annotate.info*
270
Note: See TracBrowser for help on using the repository browser.