source: rtems/contrib/crossrpms/rtems4.10/lm32/rtems-4.10-lm32-rtems4.10-gdb.spec @ beb5d47

4.104.115
Last change on this file since beb5d47 was beb5d47, checked in by Ralf Corsepius <ralf.corsepius@…>, on 02/25/09 at 06:13:06

Regenerate.

  • Property mode set to 100644
File size: 5.9 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.10
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix rtems-4.10-%{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 6.8.50.20090224
49%define gdb_rpmvers %{expand:%(echo 6.8.50.20090224 | tr - _)}
50
51Name:           rtems-4.10-lm32-rtems4.10-gdb
52Summary:        Gdb for target lm32-rtems4.10
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        2%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%define build_sim --enable-sim
63%if "%{_build}" != "%{_host}"
64# psim doesn't support Cdn-X
65%if "lm32-rtems4.10" == "powerpc-rtems4.10"
66%define build_sim --disable-sim
67%endif
68%endif
69
70%ifos mingw mingw32
71# Mingw lacks functions required by the simulator
72%if "lm32-rtems4.10" == "sparc-rtems4.10"
73%define build_sim --disable-sim
74%endif
75%if "lm32-rtems4.10" == "h8300-rtems4.10"
76%define build_sim --disable-sim
77%endif
78%if "lm32-rtems4.10" == "mipstx39-rtems4.10"
79%define build_sim --disable-sim
80%endif
81%endif
82
83%if "%{gdb_version}" >= "6.6"
84# suse
85%if "%{?suse}" >= "10.3"
86BuildRequires: libexpat-devel
87%else
88# Fedora/CentOS/Cygwin/MinGW
89BuildRequires: %{_host_rpmprefix}expat-devel
90%endif
91%endif
92
93%if "%{gdb_version}" < "6.7"
94%if "%{_build}" != "%{_host}"
95BuildRequires:  %{_host_rpmprefix}termcap-devel
96%endif
97%endif
98BuildRequires:  %{_host_rpmprefix}readline-devel
99BuildRequires:  %{_host_rpmprefix}ncurses-devel
100
101
102
103# A copy of a gdb development snapshot having been retrieved from
104# ftp://sources.redhat.com/pub/gdb/snapshots/gdb-%{gdb_version}.tar.bz2
105Source0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-%{gdb_version}.tar.bz2
106
107# rtems-4.10 patches
108# + lm32-sim/gdb http://sourceware.org/ml/gdb-patches/2008-12/msg00373.html
109# + misc small fixes to lm32-sim/gdb
110Patch0: ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-%{gdb_version}-rtems4.10-20090225.diff
111
112%description
113GDB for target lm32-rtems4.10
114%prep
115%setup -q -c -T -n %{name}-%{version}
116
117%setup -q -D -T -n %{name}-%{version} -a0
118cd gdb-%{gdb_version}
119%{?PATCH0:%patch0 -p1}
120cd ..
121
122%if "%{gdb_version}" >= "6.7"
123# Force using a system-provided libreadline
124rm -f gdb-%{gdb_version}/readline/configure
125%endif
126%build
127  export PATH="%{_bindir}:${PATH}"
128  mkdir -p build
129  cd build
130%if "%{_build}" != "%{_host}"
131  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
132%endif
133  CFLAGS="$RPM_OPT_FLAGS" \
134  ../gdb-%{gdb_version}/configure \
135    --build=%_build --host=%_host \
136    --target=lm32-rtems4.10 \
137    --verbose --disable-nls \
138    --without-included-gettext \
139    --disable-win32-registry \
140    --disable-werror \
141    %{build_sim} \
142%if "%{gdb_version}" >= "6.7"
143    --with-system-readline \
144%endif
145%if "%{gdb_version}" >= "6.6"
146    --with-expat \
147%endif
148%if "%{gdb_version}" >= "6.8.50"
149    --without-python \
150%endif
151    --prefix=%{_prefix} --bindir=%{_bindir} \
152    --includedir=%{_includedir} --libdir=%{_libdir} \
153    --mandir=%{_mandir} --infodir=%{_infodir}
154
155  make %{?_smp_mflags} all
156  cd ..
157
158%install
159  export PATH="%{_bindir}:${PATH}"
160  rm -rf $RPM_BUILD_ROOT
161
162  cd build
163  make DESTDIR=$RPM_BUILD_ROOT install
164
165# Conflict with a native gdb's infos
166  rm -rf $RPM_BUILD_ROOT%{_infodir}
167
168# We don't ship host files
169  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
170
171# host library, installed to a bogus directory
172  rm -f ${RPM_BUILD_ROOT}%{_libdir}/liblm32-rtems4.10-sim.a
173
174  cd ..
175
176# Extract %%__os_install_post into os_install_post~
177cat << \EOF > os_install_post~
178%__os_install_post
179EOF
180
181# Generate customized brp-*scripts
182cat os_install_post~ | while read a x y; do
183case $a in
184# Prevent brp-strip* from trying to handle foreign binaries
185*/brp-strip*)
186  b=$(basename $a)
187  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
188  chmod a+x $b
189  ;;
190# Fix up brp-compress to handle %%_prefix != /usr
191*/brp-compress*)
192  b=$(basename $a)
193  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
194  chmod a+x $b
195  ;;
196esac
197done
198
199sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
200  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
201< os_install_post~ > os_install_post
202%define __os_install_post . ./os_install_post
203
204%clean
205  rm -rf $RPM_BUILD_ROOT
206
207# ==============================================================
208# lm32-rtems4.10-gdb
209# ==============================================================
210# %package -n rtems-4.10-lm32-rtems4.10-gdb
211# Summary:      rtems gdb for lm32-rtems4.10
212# Group: Development/Tools
213# %if %build_infos
214# Requires: rtems-4.10-gdb-common
215# %endif
216
217%description -n rtems-4.10-lm32-rtems4.10-gdb
218GNU gdb targetting lm32-rtems4.10.
219
220%files -n rtems-4.10-lm32-rtems4.10-gdb
221%defattr(-,root,root)
222%dir %{_mandir}
223%dir %{_mandir}/man1
224%{_mandir}/man1/lm32-rtems4.10-*.1*
225
226%dir %{_bindir}
227%{_bindir}/lm32-rtems4.10-*
228
Note: See TracBrowser for help on using the repository browser.