source: rtems/contrib/crossrpms/rtems4.10/bfin/rtems-4.10-bfin-rtems4.10-gdb.spec @ 6d3f0321

4.104.115
Last change on this file since 6d3f0321 was 6d3f0321, checked in by Ralf Corsepius <ralf.corsepius@…>, on 07/18/09 at 04:02:03

Regenerate.

  • Property mode set to 100644
File size: 7.5 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.10
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define gdb_version 6.5
49%define gdb_rpmvers %{expand:%(echo 6.5 | tr - _)}
50
51Name:           rtems-4.10-bfin-rtems4.10-gdb
52Summary:        Gdb for target bfin-rtems4.10
53Group:          Development/Tools
54Version:        %{gdb_rpmvers}
55Release:        7%{?dist}
56License:        GPL/LGPL
57URL:            http://sources.redhat.com/gdb
58BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
59
60BuildRequires:  %{_host_rpmprefix}gcc
61
62%define build_sim --enable-sim
63%if "%{_build}" != "%{_host}"
64# psim doesn't support Cdn-X
65%if "bfin-rtems4.10" == "powerpc-rtems4.10"
66%define build_sim --disable-sim
67%endif
68%endif
69
70%ifos mingw mingw32
71# Mingw lacks functions required by the simulator
72%if "bfin-rtems4.10" == "sparc-rtems4.10"
73%define build_sim --disable-sim
74%endif
75%if "bfin-rtems4.10" == "h8300-rtems4.10"
76%define build_sim --disable-sim
77%endif
78%if "%{gdb_version}" >= "6.8.50"
79%if "bfin-rtems4.10" == "m32c-rtems4.10"
80%define build_sim --disable-sim
81%endif
82%endif
83%if "bfin-rtems4.10" == "lm32-rtems4.10"
84%define build_sim --disable-sim
85%endif
86%if "bfin-rtems4.10" == "mipstx39-rtems4.10"
87%define build_sim --disable-sim
88%endif
89%endif
90
91%if "%{gdb_version}" >= "6.6"
92# suse
93%if "%{?suse}" >= "10.3"
94BuildRequires: libexpat-devel
95%else
96# Fedora/CentOS/Cygwin/MinGW
97BuildRequires: %{_host_rpmprefix}expat-devel
98%endif
99%endif
100
101%if "%{gdb_version}" < "6.7"
102%if "%{_build}" != "%{_host}"
103BuildRequires:  %{_host_rpmprefix}termcap-devel
104%endif
105%endif
106BuildRequires:  %{_host_rpmprefix}readline-devel
107BuildRequires:  %{_host_rpmprefix}ncurses-devel
108
109# Required for building the infos
110BuildRequires:  /sbin/install-info
111BuildRequires:  texinfo >= 4.2
112
113
114Requires:       rtems-4.10-gdb-common
115
116Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/gdb-%{gdb_version}.tar.bz2
117%{?_without_sources:NoSource:   0}
118Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.10/gdb-6.5-bfinrtems-20090122.diff
119
120%description
121GDB for target bfin-rtems4.10
122%prep
123%setup -q -c -T -n %{name}-%{version}
124
125%setup -q -D -T -n %{name}-%{version} -a0
126cd gdb-%{gdb_version}
127%{?PATCH0:%patch0 -p1}
128cd ..
129
130%if "%{gdb_version}" >= "6.7"
131# Force using a system-provided libreadline
132rm -f gdb-%{gdb_version}/readline/configure
133%endif
134%build
135  export PATH="%{_bindir}:${PATH}"
136  mkdir -p build
137  cd build
138%if "%{_build}" != "%{_host}"
139  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
140%endif
141  CFLAGS="$RPM_OPT_FLAGS" \
142  ../gdb-%{gdb_version}/configure \
143    --build=%_build --host=%_host \
144    --target=bfin-rtems4.10 \
145    --verbose --disable-nls \
146    --without-included-gettext \
147    --disable-win32-registry \
148    --disable-werror \
149    %{build_sim} \
150%if "%{gdb_version}" >= "6.7"
151    --with-system-readline \
152%endif
153%if "%{gdb_version}" >= "6.6"
154    --with-expat \
155%endif
156%if "%{gdb_version}" >= "6.8.50"
157    --without-python \
158%endif
159    --prefix=%{_prefix} --bindir=%{_bindir} \
160    --includedir=%{_includedir} --libdir=%{_libdir} \
161    --mandir=%{_mandir} --infodir=%{_infodir}
162
163  make %{?_smp_mflags} all
164  make info
165  cd ..
166
167%install
168  export PATH="%{_bindir}:${PATH}"
169  rm -rf $RPM_BUILD_ROOT
170
171  cd build
172  make DESTDIR=$RPM_BUILD_ROOT install
173
174  rm -f $RPM_BUILD_ROOT%{_infodir}/dir
175  touch $RPM_BUILD_ROOT%{_infodir}/dir
176
177# These come from other packages
178  rm -rf $RPM_BUILD_ROOT%{_infodir}/bfd*
179  rm -rf $RPM_BUILD_ROOT%{_infodir}/configure*
180  rm -rf $RPM_BUILD_ROOT%{_infodir}/standards*
181
182# We don't ship host files
183  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
184
185# host library, installed to a bogus directory
186  rm -f ${RPM_BUILD_ROOT}%{_libdir}/libbfin-rtems4.10-sim.a
187
188  cd ..
189
190# Extract %%__os_install_post into os_install_post~
191cat << \EOF > os_install_post~
192%__os_install_post
193EOF
194
195# Generate customized brp-*scripts
196cat os_install_post~ | while read a x y; do
197case $a in
198# Prevent brp-strip* from trying to handle foreign binaries
199*/brp-strip*)
200  b=$(basename $a)
201  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
202  chmod a+x $b
203  ;;
204# Fix up brp-compress to handle %%_prefix != /usr
205*/brp-compress*)
206  b=$(basename $a)
207  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
208  chmod a+x $b
209  ;;
210esac
211done
212
213sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
214  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
215< os_install_post~ > os_install_post
216%define __os_install_post . ./os_install_post
217
218%clean
219  rm -rf $RPM_BUILD_ROOT
220
221# ==============================================================
222# bfin-rtems4.10-gdb
223# ==============================================================
224# %package -n rtems-4.10-bfin-rtems4.10-gdb
225# Summary:      rtems gdb for bfin-rtems4.10
226# Group: Development/Tools
227# %if %build_infos
228# Requires: rtems-4.10-gdb-common
229# %endif
230
231%description -n rtems-4.10-bfin-rtems4.10-gdb
232GNU gdb targetting bfin-rtems4.10.
233
234%files -n rtems-4.10-bfin-rtems4.10-gdb
235%defattr(-,root,root)
236%dir %{_mandir}
237%dir %{_mandir}/man1
238%{_mandir}/man1/bfin-rtems4.10-*.1*
239
240%dir %{_bindir}
241%{_bindir}/bfin-rtems4.10-*
242
243# ==============================================================
244# rtems-4.10-gdb-common
245# ==============================================================
246%package -n rtems-4.10-gdb-common
247Summary:      Base package for RTEMS gdbs
248Group: Development/Tools
249Requires(post):         /sbin/install-info
250Requires(preun):        /sbin/install-info
251
252%description -n rtems-4.10-gdb-common
253
254GDB files shared by all targets.
255
256%post -n rtems-4.10-gdb-common
257  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
258  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
259  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
260  /sbin/install-info --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
261
262%preun -n rtems-4.10-gdb-common
263if [ $1 -eq 0 ]; then
264  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdb.info.gz || :
265  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/gdbint.info.gz || :
266  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/stabs.info.gz || :
267  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/annotate.info.gz || :
268fi
269
270%files -n rtems-4.10-gdb-common
271%defattr(-,root,root)
272%dir %{_infodir}
273%ghost %{_infodir}/dir
274%{_infodir}/gdb.info*
275
276%{_infodir}/gdbint.info*
277%{_infodir}/stabs.info*
278%{_infodir}/annotate.info*
279
Note: See TracBrowser for help on using the repository browser.