source: rtems/contrib/crossrpms/netbsd5.0.2/amd64/amd64-pc-netbsdelf5.0.2-gcc.spec @ 8a2e9181

4.104.115
Last change on this file since 8a2e9181 was 8a2e9181, checked in by Ralf Corsepius <ralf.corsepius@…>, on 04/24/10 at 14:05:52

Regenerate.

  • Property mode set to 100644
File size: 22.4 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6
7%ifos cygwin cygwin32 mingw mingw32
8%define _exeext .exe
9%define debug_package           %{nil}
10%define _libdir                 %{_exec_prefix}/lib
11%else
12%define _exeext %{nil}
13%endif
14
15%ifos cygwin cygwin32
16%define optflags -O3 -pipe -march=i486 -funroll-loops
17%endif
18
19%ifos mingw mingw32
20%if %{defined _mingw32_cflags}
21%define optflags %{_mingw32_cflags}
22%else
23%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
24%endif
25%endif
26
27%if "%{_build}" != "%{_host}"
28%define _host_rpmprefix %{_host}-
29%else
30%define _host_rpmprefix %{nil}
31%endif
32
33
34%define gcc_pkgvers 4.5.0
35%define gcc_version 4.5.0
36%define gcc_rpmvers %{expand:%(echo "4.5.0" | tr - _ )}
37
38
39Name:           amd64-pc-netbsdelf5.0.2-gcc
40Summary:        amd64-pc-netbsdelf5.0.2 gcc
41
42Group:          Development/Tools
43Version:        %{gcc_rpmvers}
44Release:        0.20100424.0%{?dist}
45License:        GPL
46URL:            http://gcc.gnu.org
47BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49%define _use_internal_dependency_generator 0
50
51BuildRequires:  %{_host_rpmprefix}gcc
52
53# FIXME: Disable lto for now, to avoid dependencies on libelf
54%bcond_with lto
55
56# FIXME: Disable python gdb scripts
57# ATM, no idea how to package them
58%bcond_with pygdb
59
60# FIXME: Disable GCC-plugin
61# Bug in gcc-4.5-20100318, doesn't build them on x86_84 hosts.
62%bcond_with plugin
63
64# versions of libraries, we conditionally bundle if necessary
65%global mpc_version     0.8.1
66%global mpfr_version    2.4.1
67%global gmp_version     4.3.2
68%global libelf_version  0.8.13
69
70# versions of libraries these distros are known to ship
71%if 0%{?fc13}
72%global mpc_provided 0.8.1
73%global mpfr_provided 2.4.1
74%global gmp_provided 4.3.1
75%endif
76
77%if 0%{?fc12}
78%global mpc_provided 0.8
79%global mpfr_provided 2.4.1
80%global gmp_provided 4.3.1
81%endif
82
83%if 0%{?fc11}
84%global mpc_provided %{nil}
85%global mpfr_provided 2.4.1
86%global gmp_provided 4.2.4
87%endif
88
89%if 0%{?el6}
90%global mpc_provided %{nil}
91# el6 beta ships mpfr but mpfr-devel is missing
92%global mpfr_provided %{nil}
93%global gmp_provided 4.3.1
94%endif
95
96%if 0%{?el5}
97%global mpc_provided %{nil}
98%global mpfr_provided %{nil}
99%global gmp_provided 4.1.4
100%endif
101
102%if 0%{?suse11_0}
103%global mpc_provided %{nil}
104%global mpfr_provided 2.3.1
105%global gmp_provided 4.2.2
106%endif
107
108%if 0%{?suse11_1}
109%global mpc_provided %{nil}
110%global mpfr_provided 2.3.2
111%global gmp_provided 4.2.3
112%endif
113
114%if 0%{?suse11_2}
115%global mpc_provided 0.7
116%global mpfr_provided 2.4.1
117%global gmp_provided 4.3.1
118%endif
119
120%if 0%{?cygwin}
121%global mpc_provided 0.8
122%global mpfr_provided 2.4.1
123%global gmp_provided 4.3.1
124%endif
125
126%if 0%{?mingw32}
127%global mpc_provided 0.8.1
128%global mpfr_provided 2.4.1
129%global gmp_provided 4.3.2
130%endif
131
132%if "%{gcc_version}" >= "4.2.0"
133%define gmp_required            4.1
134%define mpfr_required           2.2.1
135%endif
136
137%if "%{gcc_version}" >= "4.3.0"
138%define gmp_required            4.1
139%define mpfr_required           2.3.1
140%endif
141
142%if "%{gcc_version}" >= "4.3.3"
143%define cloog_required          0.15
144%endif
145
146%if "%{gcc_version}" >= "4.4.0"
147%define mpfr_required           2.3.2
148%endif
149
150%if "%{gcc_version}" >= "4.5.0"
151%define mpc_required            0.8
152%if %{with lto}
153%define libelf_required         0.8.12
154%endif
155%endif
156
157%if %{defined mpc_required}
158%if "%{mpc_provided}" >= "%{mpc_required}"
159%{?fedora:BuildRequires: libmpc-devel >= %{mpc_required}}
160%{?suse:BuildRequires: mpc-devel >= %{mpc_required}}
161%if "%{_build}" != "%{_host}"
162BuildRequires:  %{_host_rpmprefix}mpc-devel >= %{mpc_required}
163%endif
164%else
165%define _build_mpc 1
166%define gmp_required            4.2
167%endif
168%endif
169
170%if %{defined gmp_required}
171%if "%{gmp_provided}" >= "%{gmp_required}"
172BuildRequires: gmp-devel >= %{gmp_required}
173%if "%{_build}" != "%{_host}"
174BuildRequires:  %{_host_rpmprefix}gmp-devel >= %{gmp_required}
175%endif
176%else
177%define _build_gmp 1
178%endif
179%endif
180
181%if %{defined libelf_required}
182%if "%{libelf_provided}" >= "%{libelf_required}"
183BuildRequires: libelf-devel >= %{libelf_required}
184%if "%{_build}" != "%{_host}"
185BuildRequires:  %{_host_rpmprefix}libelf-devel >= %{libelf_required}
186%endif
187%else
188%define _build_libelf 1
189%endif
190%endif
191
192
193%if %{defined cloog_required}
194%{?fc11:BuildRequires: cloog-ppl-devel >= %cloog_required}
195%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
196%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
197# el6 ships cloog-ppl, but cloog-ppl-devel is missing
198%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
199%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
200%endif
201
202
203%if %{defined mpfr_required}
204%if "%{mpfr_provided}" >= "%{mpfr_required}"
205BuildRequires: mpfr-devel >= %{mpfr_required}
206%if "%{_build}" != "%{_host}"
207BuildRequires:  %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
208%endif
209%else
210%define _build_mpfr 1
211%endif
212%endif
213
214%if "%{_build}" != "%{_host}"
215BuildRequires:  amd64-pc-netbsdelf5.0.2-gcc = %{gcc_rpmvers}
216%endif
217
218%if "%{gcc_version}" >= "4.2.0"
219BuildRequires:  flex bison
220%endif
221
222
223BuildRequires:  texinfo >= 4.2
224BuildRequires:  amd64-pc-netbsdelf5.0.2-binutils
225BuildRequires:  amd64-pc-netbsdelf5.0.2-sys-root
226
227Requires:       amd64-pc-netbsdelf5.0.2-binutils
228Requires:       amd64-pc-netbsdelf5.0.2-sys-root
229Requires:       amd64-pc-netbsdelf5.0.2-gcc-libgcc = %{gcc_rpmvers}-%{release}
230
231%if "%{gcc_version}" >= "4.5.0"
232BuildRequires:  zlib-devel
233%if "%{_build}" != "%{_host}"
234BuildRequires:  %{_host_rpmprefix}zlib-devel
235%endif
236%else
237%endif
238
239%global _gcclibdir %{_prefix}/lib
240
241Source0:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-core-%{gcc_pkgvers}.tar.bz2
242%if "%{gcc_version}" == "4.5.0"
243Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gcc-core-4.5.0-rtems4.11-20100419.diff
244%endif
245%{?_without_sources:NoSource:   0}
246
247Source1:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-g++-%{gcc_pkgvers}.tar.bz2
248%{?_without_sources:NoSource:   1}
249
250Source2:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-fortran-%{gcc_pkgvers}.tar.bz2
251%{?_without_sources:NoSource:   2}
252
253Source5:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-objc-%{gcc_pkgvers}.tar.bz2
254%{?_without_sources:NoSource:   5}
255
256%if 0%{?_build_mpfr}
257Source60:    http://www.mpfr.org/mpfr-current/mpfr-%{mpfr_version}.tar.bz2
258%endif
259
260%if 0%{?_build_mpc}
261Source61:    http://www.multiprecision.org/mpc/download/mpc-%{mpc_version}.tar.gz
262%endif
263
264%if 0%{?_build_gmp}
265Source62:    ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
266%endif
267
268%if 0%{?_build_libelf}
269Source63:    http://www.mr511.de/software/libelf-%{libelf_version}.tar.gz
270%endif
271
272%description
273Cross gcc for amd64-pc-netbsdelf5.0.2.
274
275%prep
276%setup -c -T -n %{name}-%{version}
277
278%setup -q -T -D -n %{name}-%{version} -a0
279cd gcc-%{gcc_pkgvers}
280%{?PATCH0:%patch0 -p1}
281cd ..
282
283%setup -q -T -D -n %{name}-%{version} -a1
284cd gcc-%{gcc_pkgvers}
285%{?PATCH1:%patch1 -p1}
286cd ..
287
288%setup -q -T -D -n %{name}-%{version} -a2
289%{?PATCH2:%patch2 -p0}
290
291
292
293%setup -q -T -D -n %{name}-%{version} -a5
294%{?PATCH5:%patch5 -p0}
295
296
297%if 0%{?_build_mpfr}
298%setup -q -T -D -n %{name}-%{version} -a60
299%{?PATCH60:%patch60 -p1}
300  # Build mpfr one-tree style
301  ln -s ../mpfr-%{mpfr_version} gcc-%{gcc_pkgvers}/mpfr
302%endif
303
304%if 0%{?_build_mpc}
305%setup -q -T -D -n %{name}-%{version} -a61
306%{?PATCH61:%patch61 -p1}
307  # Build mpc one-tree style
308  ln -s ../mpc-%{mpc_version} gcc-%{gcc_pkgvers}/mpc
309%endif
310
311%if 0%{?_build_gmp}
312%setup -q -T -D -n %{name}-%{version} -a62
313%{?PATCH62:%patch62 -p1}
314  # Build gmp one-tree style
315  ln -s ../gmp-%{gmp_version} gcc-%{gcc_pkgvers}/gmp
316%endif
317
318%if 0%{?_build_libelf}
319%setup -q -T -D -n %{name}-%{version} -a63
320%{?PATCH63:%patch63 -p1}
321  # Build libelf one-tree style
322  ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
323%endif
324
325
326  # Fix timestamps
327  cd gcc-%{gcc_pkgvers}
328  contrib/gcc_update --touch
329  cd ..
330%build
331  mkdir -p build
332
333  cd build
334
335  languages="c"
336  languages="$languages,c++"
337  languages="$languages,fortran"
338  languages="$languages,objc"
339%if "%{_build}" != "%{_host}"
340  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
341  CC="%{_host}-gcc ${RPM_OPT_FLAGS}" \
342%else
343# gcc is not ready to be compiled with -std=gnu99
344  CC=$(echo "%{__cc} ${RPM_OPT_FLAGS}" | sed -e 's,-std=gnu99 ,,') \
345%endif
346  ../gcc-%{gcc_pkgvers}/configure \
347    --prefix=%{_prefix} \
348    --bindir=%{_bindir} \
349    --exec_prefix=%{_exec_prefix} \
350    --includedir=%{_includedir} \
351    --libdir=%{_gcclibdir} \
352    --libexecdir=%{_libexecdir} \
353    --mandir=%{_mandir} \
354    --infodir=%{_infodir} \
355    --datadir=%{_datadir} \
356    --build=%_build --host=%_host \
357    --target=amd64-pc-netbsdelf5.0.2 \
358    --disable-libstdcxx-pch \
359    --with-gnu-as --with-gnu-ld --verbose \
360    --with-system-zlib \
361    --disable-nls --without-included-gettext \
362    --disable-win32-registry \
363    --enable-version-specific-runtime-libs \
364    --enable-threads \
365    --with-sysroot=%{_exec_prefix}/amd64-pc-netbsdelf5.0.2/sys-root \
366    %{?with_lto:--enable-lto}%{!?with_lto:--disable-lto} \
367    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
368    --enable-languages="$languages" $optargs
369
370%if "%_host" != "%_build"
371  # Bug in gcc-3.2.1:
372  # Somehow, gcc doesn't get syslimits.h right for Cdn-Xs
373  mkdir -p gcc/include
374  cp ../gcc-%{gcc_pkgvers}/gcc/gsyslimits.h gcc/include/syslimits.h
375%endif
376
377  make %{?_smp_mflags} all
378  cd ..
379
380%install
381  rm -rf $RPM_BUILD_ROOT
382
383  cd build
384
385  make DESTDIR=$RPM_BUILD_ROOT install
386  cd ..
387
388
389%if "%{gcc_version}" <= "4.1.2"
390# Misplaced header file
391  if test -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h; then
392    mv $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h \
393      $RPM_BUILD_ROOT%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include/
394  fi
395%endif
396
397  # host library
398%if "%{gcc_version}" >= "4.2.0"
399  # libiberty doesn't honor --libdir, but always installs to a
400  # magically guessed _libdir
401  rm -f  ${RPM_BUILD_ROOT}%{_libdir}/libiberty.a
402%else
403  # libiberty installs to --libdir=...
404  rm -f ${RPM_BUILD_ROOT}%{_gcclibdir}/libiberty.a
405%endif
406
407  # We use the version from binutils
408  rm -f $RPM_BUILD_ROOT%{_bindir}/amd64-pc-netbsdelf5.0.2-c++filt%{_exeext}
409
410
411# Conflict with a native GCC's infos
412  rm -rf $RPM_BUILD_ROOT%{_infodir}
413
414# Conflict with a native GCC's man pages
415  rm -rf $RPM_BUILD_ROOT%{_mandir}/man7
416
417  # Bug in gcc-3.4.0pre
418  rm -f $RPM_BUILD_ROOT%{_bindir}/amd64-pc-netbsdelf5.0.2-amd64-pc-netbsdelf5.0.2-gcjh%{_exeext}
419
420  # Bug in gcc-3.3.x/gcc-3.4.x: Despite we don't need fixincludes, it installs
421  # the fixinclude-install-tools
422  rm -rf ${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/install-tools
423  rm -rf ${RPM_BUILD_ROOT}%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/install-tools
424
425  # Bug in gcc > 4.1.0: Installs an unused, empty directory
426  if test -d ${RPM_BUILD_ROOT}%{_prefix}/amd64-pc-netbsdelf5.0.2/include/bits; then
427    rmdir ${RPM_BUILD_ROOT}%{_prefix}/amd64-pc-netbsdelf5.0.2/include/bits
428  fi
429
430  # gcc >= 4.5.0: installs weird libstdc++ python bindings.
431%if ! %{with pygdb}
432  if test -d ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python; then
433    rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python/libstdcxx
434  fi
435%endif
436
437  # Collect multilib subdirectories
438  multilibs=`build/gcc/xgcc -Bbuild/gcc/ --print-multi-lib | sed -e 's,;.*$,,'`
439
440
441  rm -f dirs ;
442  echo "%defattr(-,root,root,-)" >> dirs
443  TGTDIR="%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}"
444  for i in $multilibs; do
445    case $i in
446    \.) ;; # ignore, handled elsewhere
447    *)  echo "%dir ${TGTDIR}/$i" >> dirs
448      ;;
449    esac
450  done
451
452  # Collect files to go into different packages
453  cp dirs build/files.gcc
454  cp dirs build/files.gfortran
455  cp dirs build/files.objc
456  cp dirs build/files.gcj
457  cp dirs build/files.g++
458
459  TGTDIR="%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}"
460  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
461  for i in $f; do
462    case $i in
463    *lib*.la) rm ${RPM_BUILD_ROOT}/$i ;; # ignore: gcc produces bogus libtool libs
464    *f771) ;;
465    *f951) ;;
466    *cc1) ;;
467    *cc1obj) ;;
468    *cc1plus) ;; # ignore: explicitly put into rpm elsewhere
469    *collect2) ;;
470    *libobjc*) echo "$i" >> build/files.objc ;;
471    *include/objc*) ;;
472    *include/g++*);;
473    *include/c++*);;
474    *include-fixed/*);;
475    *finclude/*);;
476    *adainclude*);;
477    *adalib*);;
478    *gnat1);;
479    *jc1) ;;
480    *jvgenmain) ;;
481    */libgfortran*.*) echo "$i" >> build/files.gfortran ;;
482    %{!?with_pygdb:*/libstdc++*gdb.py*) rm ${RPM_BUILD_ROOT}/$i ;;} # ignore for now
483    %{?with_pygdb:*/libstdc++*gdb.py*) >> build/files.g++ ;;}
484    */libstdc++.*) echo "$i" >> build/files.g++ ;;
485    */libsupc++.*) echo "$i" >> build/files.g++ ;;
486    *) echo "$i" >> build/files.gcc ;;
487    esac
488  done
489
490  TGTDIR="%{_exec_prefix}/amd64-pc-netbsdelf5.0.2/lib"
491  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
492  for i in $f; do
493    case $i in
494    *lib*.la) rm ${RPM_BUILD_ROOT}/$i;; # ignore - gcc produces bogus libtool libs
495    *libiberty.a) rm ${RPM_BUILD_ROOT}/$i ;; # ignore - GPL'ed
496# all other files belong to newlib
497    *) echo "$i" >> build/files.newlib ;;
498    esac
499  done
500# Extract %%__os_install_post into os_install_post~
501cat << \EOF > os_install_post~
502%__os_install_post
503EOF
504
505# Generate customized brp-*scripts
506cat os_install_post~ | while read a x y; do
507case $a in
508# Prevent brp-strip* from trying to handle foreign binaries
509*/brp-strip*)
510  b=$(basename $a)
511  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
512  chmod a+x $b
513  ;;
514esac
515done
516
517sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
518< os_install_post~ > os_install_post
519%define __os_install_post . ./os_install_post
520
521
522cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
523#!/bin/sh
524grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/amd64-pc-netbsdelf5.0.2/(lib|include|sys-root)' \
525  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/'} | %__find_provides
526EOF
527chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
528%define __find_provides %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
529
530cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
531#!/bin/sh
532grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/amd64-pc-netbsdelf5.0.2/(lib|include|sys-root)' \
533  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/'} | %__find_requires
534EOF
535chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
536%define __find_requires %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
537
538%ifnarch noarch
539# Extract %%__debug_install_post into debug_install_post~
540cat << \EOF > debug_install_post~
541%__debug_install_post
542EOF
543
544# Generate customized debug_install_post script
545cat debug_install_post~ | while read a x y; do
546case $a in
547# Prevent find-debuginfo.sh* from trying to handle foreign binaries
548*/find-debuginfo.sh)
549  b=$(basename $a)
550  sed -e 's,find "$RPM_BUILD_ROOT" !,find "$RPM_BUILD_ROOT"%_bindir "$RPM_BUILD_ROOT"%_libexecdir !,' $a > $b
551  chmod a+x $b
552  ;;
553esac
554done
555
556sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
557< debug_install_post~ > debug_install_post
558%define __debug_install_post . ./debug_install_post
559
560%endif
561
562%clean
563  rm -rf $RPM_BUILD_ROOT
564
565# ==============================================================
566# amd64-pc-netbsdelf5.0.2-gcc
567# ==============================================================
568# %package -n amd64-pc-netbsdelf5.0.2-gcc
569# Summary:        GNU cc compiler for amd64-pc-netbsdelf5.0.2
570# Group:          Development/Tools
571# Version:        %{gcc_rpmvers}
572# Requires:       amd64-pc-netbsdelf5.0.2-binutils
573# License:      GPL
574
575# %if %build_infos
576# Requires:      gcc-common
577# %endif
578
579%description -n amd64-pc-netbsdelf5.0.2-gcc
580GNU cc compiler for amd64-pc-netbsdelf5.0.2.
581
582# ==============================================================
583# amd64-pc-netbsdelf5.0.2-gcc-libgcc
584# ==============================================================
585%package -n amd64-pc-netbsdelf5.0.2-gcc-libgcc
586Summary:        libgcc for amd64-pc-netbsdelf5.0.2-gcc
587Group:          Development/Tools
588Version:        %{gcc_rpmvers}
589%{?_with_noarch_subpackages:BuildArch: noarch}
590License:        GPL
591
592%description -n amd64-pc-netbsdelf5.0.2-gcc-libgcc
593libgcc amd64-pc-netbsdelf5.0.2-gcc.
594
595
596%files -n amd64-pc-netbsdelf5.0.2-gcc
597%defattr(-,root,root)
598
599%{_mandir}/man1/amd64-pc-netbsdelf5.0.2-gcc.1*
600%{_mandir}/man1/amd64-pc-netbsdelf5.0.2-cpp.1*
601%{_mandir}/man1/amd64-pc-netbsdelf5.0.2-gcov.1*
602
603%{_bindir}/amd64-pc-netbsdelf5.0.2-cpp%{_exeext}
604%{_bindir}/amd64-pc-netbsdelf5.0.2-gcc%{_exeext}
605%{_bindir}/amd64-pc-netbsdelf5.0.2-gcc-%{gcc_version}%{_exeext}
606%{_bindir}/amd64-pc-netbsdelf5.0.2-gcov%{_exeext}
607%{_bindir}/amd64-pc-netbsdelf5.0.2-gccbug
608
609%dir %{_libexecdir}/gcc
610%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2
611%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
612%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/cc1%{_exeext}
613%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/collect2%{_exeext}
614%if "%{gcc_version}" >= "4.5.0"
615%{?with_lto:%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/lto%{_exeext}}
616%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/lto-wrapper%{_exeext}
617%endif
618
619%files -n amd64-pc-netbsdelf5.0.2-gcc-libgcc -f build/files.gcc
620%defattr(-,root,root)
621%dir %{_gcclibdir}/gcc
622%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2
623%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
624%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include
625
626%if "%{gcc_version}" > "4.0.3"
627%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include/ssp
628%endif
629
630%if "%{gcc_version}" >= "4.3.0"
631%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include-fixed
632%endif
633
634# ==============================================================
635# amd64-pc-netbsdelf5.0.2-gcc-c++
636# ==============================================================
637%package -n amd64-pc-netbsdelf5.0.2-gcc-c++
638Summary:        GCC c++ compiler for amd64-pc-netbsdelf5.0.2
639Group:          Development/Tools
640Version:        %{gcc_rpmvers}
641License:        GPL
642Requires:       amd64-pc-netbsdelf5.0.2-gcc-libstdc++ = %{gcc_rpmvers}-%{release}
643
644%if "%{_build}" != "%{_host}"
645BuildRequires:  amd64-pc-netbsdelf5.0.2-gcc-c++ = %{gcc_rpmvers}
646%endif
647
648Requires:       amd64-pc-netbsdelf5.0.2-gcc = %{gcc_rpmvers}-%{release}
649
650%description -n amd64-pc-netbsdelf5.0.2-gcc-c++
651GCC c++ compiler for amd64-pc-netbsdelf5.0.2.
652
653
654%package -n amd64-pc-netbsdelf5.0.2-gcc-libstdc++
655Summary:        libstdc++ for amd64-pc-netbsdelf5.0.2
656Group:          Development/Tools
657Version:        %{gcc_rpmvers}
658%{?_with_noarch_subpackages:BuildArch: noarch}
659License:        GPL
660
661%description -n amd64-pc-netbsdelf5.0.2-gcc-libstdc++
662%{summary}
663
664
665%files -n amd64-pc-netbsdelf5.0.2-gcc-c++
666%defattr(-,root,root)
667
668%{_mandir}/man1/amd64-pc-netbsdelf5.0.2-g++.1*
669
670%{_bindir}/amd64-pc-netbsdelf5.0.2-c++%{_exeext}
671%{_bindir}/amd64-pc-netbsdelf5.0.2-g++%{_exeext}
672
673%dir %{_libexecdir}/gcc
674%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2
675%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
676%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/cc1plus%{_exeext}
677
678
679%files -n amd64-pc-netbsdelf5.0.2-gcc-libstdc++ -f build/files.g++
680%defattr(-,root,root)
681%dir %{_gcclibdir}/gcc
682%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2
683%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
684%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include
685%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include/c++
686
687# ==============================================================
688# amd64-pc-netbsdelf5.0.2-gcc-gfortran
689# ==============================================================
690%package -n amd64-pc-netbsdelf5.0.2-gcc-gfortran
691Summary:        Fortran 95 support for amd64-pc-netbsdelf5.0.2-gcc
692Group:          Development/Tools
693Version:        %{gcc_rpmvers}
694License:        GPL
695
696Requires:       amd64-pc-netbsdelf5.0.2-gcc = %{gcc_rpmvers}-%{release}
697Requires:       amd64-pc-netbsdelf5.0.2-gcc-libgfortran = %{gcc_rpmvers}-%{release}
698
699%description -n amd64-pc-netbsdelf5.0.2-gcc-gfortran
700GCC fortran compiler for amd64-pc-netbsdelf5.0.2.
701
702%files -n amd64-pc-netbsdelf5.0.2-gcc-gfortran
703%defattr(-,root,root)
704%{_bindir}/amd64-pc-netbsdelf5.0.2-gfortran%{_exeext}
705
706%{_mandir}/man1/amd64-pc-netbsdelf5.0.2-gfortran.1*
707
708%dir %{_libexecdir}/gcc
709%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2
710%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
711%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/f951%{_exeext}
712
713# ==============================================================
714# amd64-pc-netbsdelf5.0.2-gcc-libgfortran
715# ==============================================================
716%package -n amd64-pc-netbsdelf5.0.2-gcc-libgfortran
717Summary:        Fortran 95 support libraries for amd64-pc-netbsdelf5.0.2-gcc
718Group:          Development/Tools
719Version:        %{gcc_rpmvers}
720%{?_with_noarch_subpackages:BuildArch: noarch}
721License:        GPL
722
723%description -n amd64-pc-netbsdelf5.0.2-gcc-libgfortran
724%{summary}
725
726%files -n amd64-pc-netbsdelf5.0.2-gcc-libgfortran -f build/files.gfortran
727%defattr(-,root,root)
728%dir %{_gcclibdir}/gcc
729%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2
730%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
731%if "%{gcc_version}" >= "4.2.0"
732%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/finclude
733%endif
734
735# ==============================================================
736# amd64-pc-netbsdelf5.0.2-gcc-objc
737# ==============================================================
738%package -n amd64-pc-netbsdelf5.0.2-gcc-objc
739Summary:        Objective C support for amd64-pc-netbsdelf5.0.2-gcc
740Group:          Development/Tools
741Version:        %{gcc_rpmvers}
742License:        GPL
743
744Requires:       amd64-pc-netbsdelf5.0.2-gcc = %{gcc_rpmvers}-%{release}
745Requires:       amd64-pc-netbsdelf5.0.2-gcc-libobjc = %{gcc_rpmvers}-%{release}
746
747%description -n amd64-pc-netbsdelf5.0.2-gcc-objc
748GCC objc compiler for amd64-pc-netbsdelf5.0.2.
749
750%files -n amd64-pc-netbsdelf5.0.2-gcc-objc
751%defattr(-,root,root)
752%dir %{_libexecdir}/gcc
753%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2
754%dir %{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
755%{_libexecdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/cc1obj%{_exeext}
756
757# ==============================================================
758# amd64-pc-netbsdelf5.0.2-gcc-libobjc
759# ==============================================================
760%package -n amd64-pc-netbsdelf5.0.2-gcc-libobjc
761Summary:        Objective C support for amd64-pc-netbsdelf5.0.2-gcc
762Group:          Development/Tools
763Version:        %{gcc_rpmvers}
764%{?_with_noarch_subpackages:BuildArch: noarch}
765License:        GPL
766
767%description -n amd64-pc-netbsdelf5.0.2-gcc-libobjc
768Support libraries for GCC's objc compiler for amd64-pc-netbsdelf5.0.2.
769
770%files -n amd64-pc-netbsdelf5.0.2-gcc-libobjc -f build/files.objc
771%defattr(-,root,root)
772%dir %{_gcclibdir}/gcc
773%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2
774%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}
775%dir %{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include
776%{_gcclibdir}/gcc/amd64-pc-netbsdelf5.0.2/%{gcc_version}/include/objc
777
Note: See TracBrowser for help on using the repository browser.