source: rtems/contrib/crossrpms/freebsd8.2/x86_64/amd64-pc-freebsd8.2-gcc.spec @ 96a0c2ae

4.115
Last change on this file since 96a0c2ae was 96a0c2ae, checked in by Ralf Corsepius <ralf.corsepius@…>, on 08/01/11 at 04:58:28

Regenerate

  • Property mode set to 100644
File size: 22.7 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6
7%ifos cygwin cygwin32 mingw mingw32
8%define _exeext .exe
9%define debug_package           %{nil}
10%define _libdir                 %{_exec_prefix}/lib
11%else
12%define _exeext %{nil}
13%endif
14
15%ifos cygwin cygwin32
16%define optflags -O3 -pipe -march=i486 -funroll-loops
17%endif
18
19%ifos mingw mingw32
20%if %{defined _mingw32_cflags}
21%define optflags %{_mingw32_cflags}
22%else
23%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
24%endif
25%endif
26
27%if "%{_build}" != "%{_host}"
28%define _host_rpmprefix %{_host}-
29%else
30%define _host_rpmprefix %{nil}
31%endif
32
33
34%define gcc_pkgvers 4.5.2
35%define gcc_version 4.5.2
36%define gcc_rpmvers %{expand:%(echo "4.5.2" | tr - _ )}
37
38
39Name:           amd64-pc-freebsd8.2-gcc
40Summary:        amd64-pc-freebsd8.2 gcc
41
42Group:          Development/Tools
43Version:        %{gcc_rpmvers}
44Release:        0.20110731.0%{?dist}
45License:        GPL
46URL:            http://gcc.gnu.org
47BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49%define _use_internal_dependency_generator 0
50
51BuildRequires:  %{_host_rpmprefix}gcc
52
53# FIXME: Disable lto for now, to avoid dependencies on libelf
54%bcond_with lto
55
56# FIXME: Disable python gdb scripts
57# ATM, no idea how to package them
58%bcond_with pygdb
59
60# FIXME: Disable GCC-plugin
61# Bug in gcc-4.5-20100318, doesn't build them on x86_84 hosts.
62%bcond_with plugin
63
64# EXPERIMENTAL: Use gcc's stdint.h instead of newlib's
65# Should be applicable to gcc >= 4.5.0
66%bcond_with gcc_stdint
67
68# EXPERIMENTAL: Enable newlib's iconv
69%bcond_without iconv
70
71# versions of libraries, we conditionally bundle if necessary
72%global mpc_version     0.8.1
73%global mpfr_version    2.4.2
74%global gmp_version     4.3.2
75%global libelf_version  0.8.13
76
77# versions of libraries these distros are known to ship
78%if 0%{?fc16}
79%global mpc_provided 0.8.3
80%global mpfr_provided 3.0.0
81%global gmp_provided 4.3.2
82%endif
83
84%if 0%{?fc15}
85%global mpc_provided 0.8.3
86%global mpfr_provided 3.0.0
87%global gmp_provided 4.3.2
88%endif
89
90%if 0%{?fc14}
91%global mpc_provided 0.8.1
92%global mpfr_provided 2.4.2
93%global gmp_provided 4.3.1
94%endif
95
96%if 0%{?el6}
97%global mpc_provided %{nil}
98%global mpfr_provided 2.4.1
99%global gmp_provided 4.3.1
100%endif
101
102%if 0%{?el5}
103%global mpc_provided %{nil}
104%global mpfr_provided %{nil}
105%global gmp_provided 4.1.4
106%endif
107
108%if 0%{?suse11_3}
109%global mpc_provided 0.8.1
110%global mpfr_provided 2.4.2
111%global gmp_provided 4.3.2
112%endif
113
114%if 0%{?suse11_4}
115%global mpc_provided 0.8.2
116%global mpfr_provided 3.0.0
117%global gmp_provided 5.0.1
118%endif
119
120%if 0%{?cygwin}
121%global mpc_provided 0.8
122%global mpfr_provided 2.4.1
123%global gmp_provided 4.3.1
124%endif
125
126%if 0%{?mingw32}
127%global mpc_provided 0.8.1
128%global mpfr_provided 2.4.1
129%global gmp_provided 4.3.2
130%endif
131
132%if "%{gcc_version}" >= "4.2.0"
133%define gmp_required            4.1
134%define mpfr_required           2.2.1
135%endif
136
137%if "%{gcc_version}" >= "4.3.0"
138%define gmp_required            4.1
139%define mpfr_required           2.3.1
140%endif
141
142%if "%{gcc_version}" >= "4.3.3"
143%define cloog_required          0.15
144%endif
145
146%if "%{gcc_version}" >= "4.4.0"
147%define mpfr_required           2.3.2
148%endif
149
150%if "%{gcc_version}" >= "4.5.0"
151%define mpc_required            0.8
152%if %{with lto}
153%define libelf_required         0.8.12
154%endif
155%endif
156
157%if %{defined mpc_required}
158%if "%{mpc_provided}" >= "%{mpc_required}"
159%{?fedora:BuildRequires: libmpc-devel >= %{mpc_required}}
160%{?suse:BuildRequires: mpc-devel >= %{mpc_required}}
161%if "%{_build}" != "%{_host}"
162BuildRequires:  %{_host_rpmprefix}mpc-devel >= %{mpc_required}
163%endif
164%else
165%define _build_mpc 1
166%define gmp_required            4.2
167%endif
168%endif
169
170%if %{defined gmp_required}
171%if "%{gmp_provided}" >= "%{gmp_required}"
172BuildRequires: gmp-devel >= %{gmp_required}
173%if "%{_build}" != "%{_host}"
174BuildRequires:  %{_host_rpmprefix}gmp-devel >= %{gmp_required}
175%endif
176%else
177%define _build_gmp 1
178%endif
179%endif
180
181%if %{defined libelf_required}
182%if "%{libelf_provided}" >= "%{libelf_required}"
183BuildRequires: libelf-devel >= %{libelf_required}
184%if "%{_build}" != "%{_host}"
185BuildRequires:  %{_host_rpmprefix}libelf-devel >= %{libelf_required}
186%endif
187%else
188%define _build_libelf 1
189%endif
190%endif
191
192
193%if %{defined cloog_required}
194%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
195%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
196%{?fc16:BuildRequires: cloog-ppl-devel >= %cloog_required}
197%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
198%{?suse11_4:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
199%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
200%endif
201
202
203%if %{defined mpfr_required}
204%if "%{mpfr_provided}" >= "%{mpfr_required}"
205BuildRequires: mpfr-devel >= %{mpfr_required}
206%if "%{_build}" != "%{_host}"
207BuildRequires:  %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
208%endif
209%else
210%define _build_mpfr 1
211%endif
212%endif
213
214%if "%{_build}" != "%{_host}"
215BuildRequires:  amd64-pc-freebsd8.2-gcc = %{gcc_rpmvers}
216%endif
217
218%if "%{gcc_version}" >= "4.2.0"
219BuildRequires:  flex bison
220%endif
221
222
223BuildRequires:  texinfo >= 4.2
224BuildRequires:  amd64-pc-freebsd8.2-binutils
225BuildRequires:  amd64-pc-freebsd8.2-sys-root
226
227Requires:       amd64-pc-freebsd8.2-binutils
228Requires:       amd64-pc-freebsd8.2-sys-root
229Requires:       amd64-pc-freebsd8.2-gcc-libgcc = %{gcc_rpmvers}-%{release}
230
231%if "%{gcc_version}" >= "4.5.0"
232BuildRequires:  zlib-devel
233%if "%{_build}" != "%{_host}"
234BuildRequires:  %{_host_rpmprefix}zlib-devel
235%endif
236%else
237%endif
238
239%global _gcclibdir %{_prefix}/lib
240
241Source0:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-core-%{gcc_pkgvers}.tar.bz2
242%if "%{gcc_version}" == "4.5.0"
243Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gcc-core-4.5.0-rtems4.11-20100609.diff
244%endif
245%if "%{gcc_version}" == "4.5.2"
246Patch0:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gcc-core-4.5.2-rtems4.11-20110220.diff
247%endif
248%{?_without_sources:NoSource:   0}
249
250Source1:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-g++-%{gcc_pkgvers}.tar.bz2
251%if "%{gcc_version}" == "4.5.2"
252Patch1:         ftp://ftp.rtems.org/pub/rtems/SOURCES/4.11/gcc-g++-4.5.2-rtems4.11-20110131.diff
253%endif
254%{?_without_sources:NoSource:   1}
255
256Source2:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-fortran-%{gcc_pkgvers}.tar.bz2
257%{?_without_sources:NoSource:   2}
258
259Source5:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-objc-%{gcc_pkgvers}.tar.bz2
260%{?_without_sources:NoSource:   5}
261
262%if 0%{?_build_mpfr}
263Source60:    http://www.mpfr.org/mpfr-%{mpfr_version}/mpfr-%{mpfr_version}.tar.bz2
264%endif
265
266%if 0%{?_build_mpc}
267Source61:    http://www.multiprecision.org/mpc/download/mpc-%{mpc_version}.tar.gz
268%endif
269
270%if 0%{?_build_gmp}
271Source62:    ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
272%endif
273
274%if 0%{?_build_libelf}
275Source63:    http://www.mr511.de/software/libelf-%{libelf_version}.tar.gz
276%endif
277
278%description
279Cross gcc for amd64-pc-freebsd8.2.
280
281%prep
282%setup -c -T -n %{name}-%{version}
283
284%setup -q -T -D -n %{name}-%{version} -a0
285cd gcc-%{gcc_pkgvers}
286%{?PATCH0:%patch0 -p1}
287cd ..
288
289%setup -q -T -D -n %{name}-%{version} -a1
290cd gcc-%{gcc_pkgvers}
291%{?PATCH1:%patch1 -p1}
292cd ..
293
294%setup -q -T -D -n %{name}-%{version} -a2
295%{?PATCH2:%patch2 -p0}
296
297
298
299%setup -q -T -D -n %{name}-%{version} -a5
300%{?PATCH5:%patch5 -p0}
301
302%if %{with gcc_stdint}
303sed -i -e '/thread_file=.*rtems/,/use_gcc_stdint=wrap/ { s/use_gcc_stdint=wrap/use_gcc_stdint=provide/}' gcc-%{gcc_pkgvers}/gcc/config.gcc
304%endif
305
306
307%if 0%{?_build_mpfr}
308%setup -q -T -D -n %{name}-%{version} -a60
309%{?PATCH60:%patch60 -p1}
310  # Build mpfr one-tree style
311  ln -s ../mpfr-%{mpfr_version} gcc-%{gcc_pkgvers}/mpfr
312%endif
313
314%if 0%{?_build_mpc}
315%setup -q -T -D -n %{name}-%{version} -a61
316%{?PATCH61:%patch61 -p1}
317  # Build mpc one-tree style
318  ln -s ../mpc-%{mpc_version} gcc-%{gcc_pkgvers}/mpc
319%endif
320
321%if 0%{?_build_gmp}
322%setup -q -T -D -n %{name}-%{version} -a62
323%{?PATCH62:%patch62 -p1}
324  # Build gmp one-tree style
325  ln -s ../gmp-%{gmp_version} gcc-%{gcc_pkgvers}/gmp
326%endif
327
328%if 0%{?_build_libelf}
329%setup -q -T -D -n %{name}-%{version} -a63
330%{?PATCH63:%patch63 -p1}
331  # Build libelf one-tree style
332  ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
333%endif
334
335
336  # Fix timestamps
337  cd gcc-%{gcc_pkgvers}
338  contrib/gcc_update --touch
339  cd ..
340%build
341  mkdir -p build
342
343  cd build
344
345  languages="c"
346  languages="$languages,c++"
347  languages="$languages,fortran"
348  languages="$languages,objc"
349%if "%{_build}" != "%{_host}"
350  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
351  CC="%{_host}-gcc ${RPM_OPT_FLAGS}" \
352%else
353# gcc is not ready to be compiled with -std=gnu99
354  CC=$(echo "%{__cc} ${RPM_OPT_FLAGS}" | sed -e 's,-std=gnu99 ,,') \
355%endif
356  ../gcc-%{gcc_pkgvers}/configure \
357    --prefix=%{_prefix} \
358    --bindir=%{_bindir} \
359    --exec_prefix=%{_exec_prefix} \
360    --includedir=%{_includedir} \
361    --libdir=%{_gcclibdir} \
362    --libexecdir=%{_libexecdir} \
363    --mandir=%{_mandir} \
364    --infodir=%{_infodir} \
365    --datadir=%{_datadir} \
366    --build=%_build --host=%_host \
367    --target=amd64-pc-freebsd8.2 \
368    --disable-libstdcxx-pch \
369    --with-gnu-as --with-gnu-ld --verbose \
370    --with-system-zlib \
371    --disable-nls --without-included-gettext \
372    --disable-win32-registry \
373    --enable-version-specific-runtime-libs \
374    --enable-threads \
375    --with-sysroot=%{_exec_prefix}/amd64-pc-freebsd8.2/sys-root \
376    %{?with_lto:--enable-lto}%{!?with_lto:--disable-lto} \
377    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
378    --enable-languages="$languages"
379
380%if "%_host" != "%_build"
381  # Bug in gcc-3.2.1:
382  # Somehow, gcc doesn't get syslimits.h right for Cdn-Xs
383  mkdir -p gcc/include
384  cp ../gcc-%{gcc_pkgvers}/gcc/gsyslimits.h gcc/include/syslimits.h
385%endif
386
387  make %{?_smp_mflags} all
388  cd ..
389
390%install
391  rm -rf $RPM_BUILD_ROOT
392
393  cd build
394
395  make DESTDIR=$RPM_BUILD_ROOT install
396  cd ..
397
398
399%if "%{gcc_version}" <= "4.1.2"
400# Misplaced header file
401  if test -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h; then
402    mv $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h \
403      $RPM_BUILD_ROOT%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include/
404  fi
405%endif
406
407  # host library
408%if "%{gcc_version}" >= "4.2.0"
409  # libiberty doesn't honor --libdir, but always installs to a
410  # magically guessed _libdir
411  rm -f  ${RPM_BUILD_ROOT}%{_libdir}/libiberty.a
412%else
413  # libiberty installs to --libdir=...
414  rm -f ${RPM_BUILD_ROOT}%{_gcclibdir}/libiberty.a
415%endif
416
417  # We use the version from binutils
418  rm -f $RPM_BUILD_ROOT%{_bindir}/amd64-pc-freebsd8.2-c++filt%{_exeext}
419
420
421# Conflict with a native GCC's infos
422  rm -rf $RPM_BUILD_ROOT%{_infodir}
423
424# Conflict with a native GCC's man pages
425  rm -rf $RPM_BUILD_ROOT%{_mandir}/man7
426
427  # We don't want libffi's man-pages
428  rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*ffi*
429
430  # Bug in gcc-3.4.0pre
431  rm -f $RPM_BUILD_ROOT%{_bindir}/amd64-pc-freebsd8.2-amd64-pc-freebsd8.2-gcjh%{_exeext}
432
433  # Bug in gcc-3.3.x/gcc-3.4.x: Despite we don't need fixincludes, it installs
434  # the fixinclude-install-tools
435  rm -rf ${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/install-tools
436  rm -rf ${RPM_BUILD_ROOT}%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/install-tools
437
438  # Bug in gcc > 4.1.0: Installs an unused, empty directory
439  if test -d ${RPM_BUILD_ROOT}%{_prefix}/amd64-pc-freebsd8.2/include/bits; then
440    rmdir ${RPM_BUILD_ROOT}%{_prefix}/amd64-pc-freebsd8.2/include/bits
441  fi
442
443%if ! %{with pygdb}
444  # gcc >= 4.5.0: installs weird libstdc++ python bindings.
445  if test -d ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python; then
446    rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python/libstdcxx
447  fi
448
449%endif
450  # Collect multilib subdirectories
451  multilibs=`build/gcc/xgcc -Bbuild/gcc/ --print-multi-lib | sed -e 's,;.*$,,'`
452
453
454  rm -f dirs ;
455  echo "%defattr(-,root,root,-)" >> dirs
456  TGTDIR="%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}"
457  for i in $multilibs; do
458    case $i in
459    \.) ;; # ignore, handled elsewhere
460    *)  echo "%dir ${TGTDIR}/$i" >> dirs
461      ;;
462    esac
463  done
464
465  # Collect files to go into different packages
466  cp dirs build/files.gcc
467  cp dirs build/files.gfortran
468  cp dirs build/files.objc
469  cp dirs build/files.gcj
470  cp dirs build/files.g++
471  cp dirs build/files.go
472
473  TGTDIR="%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}"
474  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
475  for i in $f; do
476    case $i in
477    *lib*.la) rm ${RPM_BUILD_ROOT}/$i ;; # ignore: gcc produces bogus libtool libs
478    *f771) ;;
479    *f951) ;;
480    *cc1) ;;
481    *cc1obj) ;;
482    *cc1plus) ;; # ignore: explicitly put into rpm elsewhere
483    *collect2) ;;
484    *libobjc*) echo "$i" >> build/files.objc ;;
485    *go1) ;; # ignore: explicitly put into rpm elsewhere
486    *include/objc*) ;;
487    *include/g++*);;
488    *include/c++*);;
489    *include-fixed/*);;
490    *finclude/*);;
491    */go/*) ;; # ignore : explicitly put into rpm elsewhere
492    *adainclude*);;
493    *adalib*);;
494    *gnat1);;
495    *jc1) ;;
496    *jvgenmain) ;;
497    */libgfortran*.*) echo "$i" >> build/files.gfortran ;;
498    */libgo*.a) echo "$i" >> build/files.go ;;
499    %{!?with_pygdb:*/libstdc++*gdb.py*) rm ${RPM_BUILD_ROOT}/$i ;;} # ignore for now
500    %{?with_pygdb:*/libstdc++*gdb.py*) >> build/files.g++ ;;}
501    */libstdc++.*) echo "$i" >> build/files.g++ ;;
502    */libsupc++.*) echo "$i" >> build/files.g++ ;;
503    *) echo "$i" >> build/files.gcc ;;
504    esac
505  done
506
507  TGTDIR="%{_exec_prefix}/amd64-pc-freebsd8.2/lib"
508  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
509  for i in $f; do
510    case $i in
511    *lib*.la) rm ${RPM_BUILD_ROOT}/$i;; # ignore - gcc produces bogus libtool libs
512    *libiberty.a) rm ${RPM_BUILD_ROOT}/$i ;; # ignore - GPL'ed
513# all other files belong to newlib
514    *) echo "$i" >> build/files.newlib ;;
515    esac
516  done
517# Extract %%__os_install_post into os_install_post~
518cat << \EOF > os_install_post~
519%__os_install_post
520EOF
521
522# Generate customized brp-*scripts
523cat os_install_post~ | while read a x y; do
524case $a in
525# Prevent brp-strip* from trying to handle foreign binaries
526*/brp-strip*)
527  b=$(basename $a)
528  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
529  chmod a+x $b
530  ;;
531esac
532done
533
534sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
535< os_install_post~ > os_install_post
536%define __os_install_post . ./os_install_post
537
538
539cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
540#!/bin/sh
541grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/amd64-pc-freebsd8.2/(lib|include|sys-root)' \
542  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/'} | %__find_provides
543EOF
544chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
545%define __find_provides %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
546
547cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
548#!/bin/sh
549grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/amd64-pc-freebsd8.2/(lib|include|sys-root)' \
550  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/'} | %__find_requires
551EOF
552chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
553%define __find_requires %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
554
555%ifnarch noarch
556# Extract %%__debug_install_post into debug_install_post~
557cat << \EOF > debug_install_post~
558%__debug_install_post
559EOF
560
561# Generate customized debug_install_post script
562cat debug_install_post~ | while read a x y; do
563case $a in
564# Prevent find-debuginfo.sh* from trying to handle foreign binaries
565*/find-debuginfo.sh)
566  b=$(basename $a)
567  sed -e 's,find "$RPM_BUILD_ROOT" !,find "$RPM_BUILD_ROOT"%_bindir "$RPM_BUILD_ROOT"%_libexecdir !,' $a > $b
568  chmod a+x $b
569  ;;
570esac
571done
572
573sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
574< debug_install_post~ > debug_install_post
575%define __debug_install_post . ./debug_install_post
576
577%endif
578
579%clean
580  rm -rf $RPM_BUILD_ROOT
581
582# ==============================================================
583# amd64-pc-freebsd8.2-gcc
584# ==============================================================
585# %package -n amd64-pc-freebsd8.2-gcc
586# Summary:        GNU cc compiler for amd64-pc-freebsd8.2
587# Group:          Development/Tools
588# Version:        %{gcc_rpmvers}
589# Requires:       amd64-pc-freebsd8.2-binutils
590# License:      GPL
591
592# %if %build_infos
593# Requires:      gcc-common
594# %endif
595
596%description -n amd64-pc-freebsd8.2-gcc
597GNU cc compiler for amd64-pc-freebsd8.2.
598
599# ==============================================================
600# amd64-pc-freebsd8.2-gcc-libgcc
601# ==============================================================
602%package -n amd64-pc-freebsd8.2-gcc-libgcc
603Summary:        libgcc for amd64-pc-freebsd8.2-gcc
604Group:          Development/Tools
605Version:        %{gcc_rpmvers}
606%{?_with_noarch_subpackages:BuildArch: noarch}
607License:        GPL
608
609%description -n amd64-pc-freebsd8.2-gcc-libgcc
610libgcc amd64-pc-freebsd8.2-gcc.
611
612
613%files -n amd64-pc-freebsd8.2-gcc
614%defattr(-,root,root)
615
616%{_mandir}/man1/amd64-pc-freebsd8.2-gcc.1*
617%{_mandir}/man1/amd64-pc-freebsd8.2-cpp.1*
618%{_mandir}/man1/amd64-pc-freebsd8.2-gcov.1*
619
620%{_bindir}/amd64-pc-freebsd8.2-cpp%{_exeext}
621%{_bindir}/amd64-pc-freebsd8.2-gcc%{_exeext}
622%{_bindir}/amd64-pc-freebsd8.2-gcc-%{gcc_version}%{_exeext}
623%{_bindir}/amd64-pc-freebsd8.2-gcov%{_exeext}
624%if "%{gcc_version}" < "4.6.0"
625%{_bindir}/amd64-pc-freebsd8.2-gccbug
626%endif
627
628%dir %{_libexecdir}/gcc
629%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2
630%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
631%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/cc1%{_exeext}
632%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/collect2%{_exeext}
633%if "%{gcc_version}" >= "4.5.0"
634%{?with_lto:%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/lto%{_exeext}}
635%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/lto-wrapper%{_exeext}
636%endif
637
638%files -n amd64-pc-freebsd8.2-gcc-libgcc -f build/files.gcc
639%defattr(-,root,root)
640%dir %{_gcclibdir}/gcc
641%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2
642%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
643%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include
644
645%if "%{gcc_version}" > "4.0.3"
646%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include/ssp
647%endif
648
649%if "%{gcc_version}" >= "4.3.0"
650%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include-fixed
651%endif
652
653# ==============================================================
654# amd64-pc-freebsd8.2-gcc-c++
655# ==============================================================
656%package -n amd64-pc-freebsd8.2-gcc-c++
657Summary:        GCC c++ compiler for amd64-pc-freebsd8.2
658Group:          Development/Tools
659Version:        %{gcc_rpmvers}
660License:        GPL
661Requires:       amd64-pc-freebsd8.2-gcc-libstdc++ = %{gcc_rpmvers}-%{release}
662
663%if "%{_build}" != "%{_host}"
664BuildRequires:  amd64-pc-freebsd8.2-gcc-c++ = %{gcc_rpmvers}
665%endif
666
667Requires:       amd64-pc-freebsd8.2-gcc = %{gcc_rpmvers}-%{release}
668
669%description -n amd64-pc-freebsd8.2-gcc-c++
670GCC c++ compiler for amd64-pc-freebsd8.2.
671
672
673%package -n amd64-pc-freebsd8.2-gcc-libstdc++
674Summary:        libstdc++ for amd64-pc-freebsd8.2
675Group:          Development/Tools
676Version:        %{gcc_rpmvers}
677%{?_with_noarch_subpackages:BuildArch: noarch}
678License:        GPL
679
680%description -n amd64-pc-freebsd8.2-gcc-libstdc++
681%{summary}
682
683
684%files -n amd64-pc-freebsd8.2-gcc-c++
685%defattr(-,root,root)
686
687%{_mandir}/man1/amd64-pc-freebsd8.2-g++.1*
688
689%{_bindir}/amd64-pc-freebsd8.2-c++%{_exeext}
690%{_bindir}/amd64-pc-freebsd8.2-g++%{_exeext}
691
692%dir %{_libexecdir}/gcc
693%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2
694%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
695%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/cc1plus%{_exeext}
696
697
698%files -n amd64-pc-freebsd8.2-gcc-libstdc++ -f build/files.g++
699%defattr(-,root,root)
700%dir %{_gcclibdir}/gcc
701%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2
702%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
703%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include
704%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include/c++
705
706# ==============================================================
707# amd64-pc-freebsd8.2-gcc-gfortran
708# ==============================================================
709%package -n amd64-pc-freebsd8.2-gcc-gfortran
710Summary:        Fortran 95 support for amd64-pc-freebsd8.2-gcc
711Group:          Development/Tools
712Version:        %{gcc_rpmvers}
713License:        GPL
714
715Requires:       amd64-pc-freebsd8.2-gcc = %{gcc_rpmvers}-%{release}
716Requires:       amd64-pc-freebsd8.2-gcc-libgfortran = %{gcc_rpmvers}-%{release}
717
718%description -n amd64-pc-freebsd8.2-gcc-gfortran
719GCC fortran compiler for amd64-pc-freebsd8.2.
720
721%files -n amd64-pc-freebsd8.2-gcc-gfortran
722%defattr(-,root,root)
723%{_bindir}/amd64-pc-freebsd8.2-gfortran%{_exeext}
724
725%{_mandir}/man1/amd64-pc-freebsd8.2-gfortran.1*
726
727%dir %{_libexecdir}/gcc
728%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2
729%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
730%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/f951%{_exeext}
731
732# ==============================================================
733# amd64-pc-freebsd8.2-gcc-libgfortran
734# ==============================================================
735%package -n amd64-pc-freebsd8.2-gcc-libgfortran
736Summary:        Fortran 95 support libraries for amd64-pc-freebsd8.2-gcc
737Group:          Development/Tools
738Version:        %{gcc_rpmvers}
739%{?_with_noarch_subpackages:BuildArch: noarch}
740License:        GPL
741
742%description -n amd64-pc-freebsd8.2-gcc-libgfortran
743%{summary}
744
745%files -n amd64-pc-freebsd8.2-gcc-libgfortran -f build/files.gfortran
746%defattr(-,root,root)
747%dir %{_gcclibdir}/gcc
748%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2
749%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
750%if "%{gcc_version}" >= "4.2.0"
751%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/finclude
752%endif
753
754# ==============================================================
755# amd64-pc-freebsd8.2-gcc-objc
756# ==============================================================
757%package -n amd64-pc-freebsd8.2-gcc-objc
758Summary:        Objective C support for amd64-pc-freebsd8.2-gcc
759Group:          Development/Tools
760Version:        %{gcc_rpmvers}
761License:        GPL
762
763Requires:       amd64-pc-freebsd8.2-gcc = %{gcc_rpmvers}-%{release}
764Requires:       amd64-pc-freebsd8.2-gcc-libobjc = %{gcc_rpmvers}-%{release}
765
766%description -n amd64-pc-freebsd8.2-gcc-objc
767GCC objc compiler for amd64-pc-freebsd8.2.
768
769%files -n amd64-pc-freebsd8.2-gcc-objc
770%defattr(-,root,root)
771%dir %{_libexecdir}/gcc
772%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2
773%dir %{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
774%{_libexecdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/cc1obj%{_exeext}
775
776# ==============================================================
777# amd64-pc-freebsd8.2-gcc-libobjc
778# ==============================================================
779%package -n amd64-pc-freebsd8.2-gcc-libobjc
780Summary:        Objective C support for amd64-pc-freebsd8.2-gcc
781Group:          Development/Tools
782Version:        %{gcc_rpmvers}
783%{?_with_noarch_subpackages:BuildArch: noarch}
784License:        GPL
785
786%description -n amd64-pc-freebsd8.2-gcc-libobjc
787Support libraries for GCC's objc compiler for amd64-pc-freebsd8.2.
788
789%files -n amd64-pc-freebsd8.2-gcc-libobjc -f build/files.objc
790%defattr(-,root,root)
791%dir %{_gcclibdir}/gcc
792%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2
793%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}
794%dir %{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include
795%{_gcclibdir}/gcc/amd64-pc-freebsd8.2/%{gcc_version}/include/objc
796
Note: See TracBrowser for help on using the repository browser.