source: rtems/contrib/crossrpms/freebsd8.2/i586/i586-pc-freebsd8.2-gcc.spec @ c7eec17f

4.115
Last change on this file since c7eec17f was c7eec17f, checked in by Ralf Corsepius <ralf.corsepius@…>, on 02/27/11 at 22:01:39

New.

  • Property mode set to 100644
File size: 21.9 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6
7%ifos cygwin cygwin32 mingw mingw32
8%define _exeext .exe
9%define debug_package           %{nil}
10%define _libdir                 %{_exec_prefix}/lib
11%else
12%define _exeext %{nil}
13%endif
14
15%ifos cygwin cygwin32
16%define optflags -O3 -pipe -march=i486 -funroll-loops
17%endif
18
19%ifos mingw mingw32
20%if %{defined _mingw32_cflags}
21%define optflags %{_mingw32_cflags}
22%else
23%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
24%endif
25%endif
26
27%if "%{_build}" != "%{_host}"
28%define _host_rpmprefix %{_host}-
29%else
30%define _host_rpmprefix %{nil}
31%endif
32
33
34%define gcc_pkgvers 4.5.0
35%define gcc_version 4.5.0
36%define gcc_rpmvers %{expand:%(echo "4.5.0" | tr - _ )}
37
38
39Name:           i586-pc-freebsd8.2-gcc
40Summary:        i586-pc-freebsd8.2 gcc
41
42Group:          Development/Tools
43Version:        %{gcc_rpmvers}
44Release:        0.20110227.0%{?dist}
45License:        GPL
46URL:            http://gcc.gnu.org
47BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49%define _use_internal_dependency_generator 0
50
51BuildRequires:  %{_host_rpmprefix}gcc
52
53# FIXME: Disable lto for now, to avoid dependencies on libelf
54%bcond_with lto
55
56# FIXME: Disable python gdb scripts
57# ATM, no idea how to package them
58%bcond_with pygdb
59
60# FIXME: Disable GCC-plugin
61# Bug in gcc-4.5-20100318, doesn't build them on x86_84 hosts.
62%bcond_with plugin
63
64# EXPERIMENTAL: Use gcc's stdint.h instead of newlib's
65# Should be applicable to gcc >= 4.5.0
66%bcond_with gcc_stdint
67
68# versions of libraries, we conditionally bundle if necessary
69%global mpc_version     0.8.1
70%global mpfr_version    2.4.2
71%global gmp_version     4.3.2
72%global libelf_version  0.8.13
73
74# versions of libraries these distros are known to ship
75%if 0%{?fc15}
76%global mpc_provided 0.8.3
77%global mpfr_provided 3.0.0
78%global gmp_provided 4.3.2
79%endif
80
81%if 0%{?fc14}
82%global mpc_provided 0.8.1
83%global mpfr_provided 2.4.2
84%global gmp_provided 4.3.1
85%endif
86
87%if 0%{?fc13}
88%global mpc_provided 0.8.1
89%global mpfr_provided 2.4.2
90%global gmp_provided 4.3.1
91%endif
92
93%if 0%{?el6}
94%global mpc_provided %{nil}
95%global mpfr_provided 2.4.1
96%global gmp_provided 4.3.1
97%endif
98
99%if 0%{?el5}
100%global mpc_provided %{nil}
101%global mpfr_provided %{nil}
102%global gmp_provided 4.1.4
103%endif
104
105%if 0%{?suse11_2}
106%global mpc_provided 0.7
107%global mpfr_provided 2.4.1
108%global gmp_provided 4.3.1
109%endif
110
111%if 0%{?suse11_3}
112%global mpc_provided 0.8.1
113%global mpfr_provided 2.4.2
114%global gmp_provided 4.3.2
115%endif
116
117%if 0%{?cygwin}
118%global mpc_provided 0.8
119%global mpfr_provided 2.4.1
120%global gmp_provided 4.3.1
121%endif
122
123%if 0%{?mingw32}
124%global mpc_provided 0.8.1
125%global mpfr_provided 2.4.1
126%global gmp_provided 4.3.2
127%endif
128
129%if "%{gcc_version}" >= "4.2.0"
130%define gmp_required            4.1
131%define mpfr_required           2.2.1
132%endif
133
134%if "%{gcc_version}" >= "4.3.0"
135%define gmp_required            4.1
136%define mpfr_required           2.3.1
137%endif
138
139%if "%{gcc_version}" >= "4.3.3"
140%define cloog_required          0.15
141%endif
142
143%if "%{gcc_version}" >= "4.4.0"
144%define mpfr_required           2.3.2
145%endif
146
147%if "%{gcc_version}" >= "4.5.0"
148%define mpc_required            0.8
149%if %{with lto}
150%define libelf_required         0.8.12
151%endif
152%endif
153
154%if %{defined mpc_required}
155%if "%{mpc_provided}" >= "%{mpc_required}"
156%{?fedora:BuildRequires: libmpc-devel >= %{mpc_required}}
157%{?suse:BuildRequires: mpc-devel >= %{mpc_required}}
158%if "%{_build}" != "%{_host}"
159BuildRequires:  %{_host_rpmprefix}mpc-devel >= %{mpc_required}
160%endif
161%else
162%define _build_mpc 1
163%define gmp_required            4.2
164%endif
165%endif
166
167%if %{defined gmp_required}
168%if "%{gmp_provided}" >= "%{gmp_required}"
169BuildRequires: gmp-devel >= %{gmp_required}
170%if "%{_build}" != "%{_host}"
171BuildRequires:  %{_host_rpmprefix}gmp-devel >= %{gmp_required}
172%endif
173%else
174%define _build_gmp 1
175%endif
176%endif
177
178%if %{defined libelf_required}
179%if "%{libelf_provided}" >= "%{libelf_required}"
180BuildRequires: libelf-devel >= %{libelf_required}
181%if "%{_build}" != "%{_host}"
182BuildRequires:  %{_host_rpmprefix}libelf-devel >= %{libelf_required}
183%endif
184%else
185%define _build_libelf 1
186%endif
187%endif
188
189
190%if %{defined cloog_required}
191%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
192%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
193%{?fc15:BuildRequires: cloog-ppl-devel >= %cloog_required}
194%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
195%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
196%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
197%endif
198
199
200%if %{defined mpfr_required}
201%if "%{mpfr_provided}" >= "%{mpfr_required}"
202BuildRequires: mpfr-devel >= %{mpfr_required}
203%if "%{_build}" != "%{_host}"
204BuildRequires:  %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
205%endif
206%else
207%define _build_mpfr 1
208%endif
209%endif
210
211%if "%{_build}" != "%{_host}"
212BuildRequires:  i586-pc-freebsd8.2-gcc = %{gcc_rpmvers}
213%endif
214
215%if "%{gcc_version}" >= "4.2.0"
216BuildRequires:  flex bison
217%endif
218
219
220BuildRequires:  texinfo >= 4.2
221BuildRequires:  i586-pc-freebsd8.2-binutils
222BuildRequires:  i586-pc-freebsd8.2-sys-root
223
224Requires:       i586-pc-freebsd8.2-binutils
225Requires:       i586-pc-freebsd8.2-sys-root
226Requires:       i586-pc-freebsd8.2-gcc-libgcc = %{gcc_rpmvers}-%{release}
227
228%if "%{gcc_version}" >= "4.5.0"
229BuildRequires:  zlib-devel
230%if "%{_build}" != "%{_host}"
231BuildRequires:  %{_host_rpmprefix}zlib-devel
232%endif
233%else
234%endif
235
236%global _gcclibdir %{_prefix}/lib
237
238Source0:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-core-%{gcc_pkgvers}.tar.bz2
239%{?_without_sources:NoSource:   0}
240
241Source1:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-g++-%{gcc_pkgvers}.tar.bz2
242%{?_without_sources:NoSource:   1}
243
244Source2:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-fortran-%{gcc_pkgvers}.tar.bz2
245%{?_without_sources:NoSource:   2}
246
247Source5:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-objc-%{gcc_pkgvers}.tar.bz2
248%{?_without_sources:NoSource:   5}
249
250%if 0%{?_build_mpfr}
251Source60:    http://www.mpfr.org/mpfr-%{mpfr_version}/mpfr-%{mpfr_version}.tar.bz2
252%endif
253
254%if 0%{?_build_mpc}
255Source61:    http://www.multiprecision.org/mpc/download/mpc-%{mpc_version}.tar.gz
256%endif
257
258%if 0%{?_build_gmp}
259Source62:    ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
260%endif
261
262%if 0%{?_build_libelf}
263Source63:    http://www.mr511.de/software/libelf-%{libelf_version}.tar.gz
264%endif
265
266%description
267Cross gcc for i586-pc-freebsd8.2.
268
269%prep
270%setup -c -T -n %{name}-%{version}
271
272%setup -q -T -D -n %{name}-%{version} -a0
273cd gcc-%{gcc_pkgvers}
274%{?PATCH0:%patch0 -p1}
275cd ..
276
277%setup -q -T -D -n %{name}-%{version} -a1
278cd gcc-%{gcc_pkgvers}
279%{?PATCH1:%patch1 -p1}
280cd ..
281
282%setup -q -T -D -n %{name}-%{version} -a2
283%{?PATCH2:%patch2 -p0}
284
285
286
287%setup -q -T -D -n %{name}-%{version} -a5
288%{?PATCH5:%patch5 -p0}
289
290%if %{with gcc_stdint}
291sed -i -e '/thread_file=.*rtems/,/use_gcc_stdint=wrap/ { s/use_gcc_stdint=wrap/use_gcc_stdint=provide/}' gcc-%{gcc_pkgvers}/gcc/config.gcc
292%endif
293
294
295%if 0%{?_build_mpfr}
296%setup -q -T -D -n %{name}-%{version} -a60
297%{?PATCH60:%patch60 -p1}
298  # Build mpfr one-tree style
299  ln -s ../mpfr-%{mpfr_version} gcc-%{gcc_pkgvers}/mpfr
300%endif
301
302%if 0%{?_build_mpc}
303%setup -q -T -D -n %{name}-%{version} -a61
304%{?PATCH61:%patch61 -p1}
305  # Build mpc one-tree style
306  ln -s ../mpc-%{mpc_version} gcc-%{gcc_pkgvers}/mpc
307%endif
308
309%if 0%{?_build_gmp}
310%setup -q -T -D -n %{name}-%{version} -a62
311%{?PATCH62:%patch62 -p1}
312  # Build gmp one-tree style
313  ln -s ../gmp-%{gmp_version} gcc-%{gcc_pkgvers}/gmp
314%endif
315
316%if 0%{?_build_libelf}
317%setup -q -T -D -n %{name}-%{version} -a63
318%{?PATCH63:%patch63 -p1}
319  # Build libelf one-tree style
320  ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
321%endif
322
323
324  # Fix timestamps
325  cd gcc-%{gcc_pkgvers}
326  contrib/gcc_update --touch
327  cd ..
328%build
329  mkdir -p build
330
331  cd build
332
333  languages="c"
334  languages="$languages,c++"
335  case i586-pc-freebsd8.2 in
336  *-rtems4.11) optargs="$optargs --enable-libstdcxx-time";;
337  esac
338  languages="$languages,fortran"
339  languages="$languages,objc"
340%if "%{_build}" != "%{_host}"
341  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
342  CC="%{_host}-gcc ${RPM_OPT_FLAGS}" \
343%else
344# gcc is not ready to be compiled with -std=gnu99
345  CC=$(echo "%{__cc} ${RPM_OPT_FLAGS}" | sed -e 's,-std=gnu99 ,,') \
346%endif
347  ../gcc-%{gcc_pkgvers}/configure \
348    --prefix=%{_prefix} \
349    --bindir=%{_bindir} \
350    --exec_prefix=%{_exec_prefix} \
351    --includedir=%{_includedir} \
352    --libdir=%{_gcclibdir} \
353    --libexecdir=%{_libexecdir} \
354    --mandir=%{_mandir} \
355    --infodir=%{_infodir} \
356    --datadir=%{_datadir} \
357    --build=%_build --host=%_host \
358    --target=i586-pc-freebsd8.2 \
359    --disable-libstdcxx-pch \
360    --with-gnu-as --with-gnu-ld --verbose \
361    --with-system-zlib \
362    --disable-nls --without-included-gettext \
363    --disable-win32-registry \
364    --enable-version-specific-runtime-libs \
365    --enable-threads \
366    --with-sysroot=%{_exec_prefix}/i586-pc-freebsd8.2/sys-root \
367    %{?with_lto:--enable-lto}%{!?with_lto:--disable-lto} \
368    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
369    --enable-languages="$languages" $optargs
370
371%if "%_host" != "%_build"
372  # Bug in gcc-3.2.1:
373  # Somehow, gcc doesn't get syslimits.h right for Cdn-Xs
374  mkdir -p gcc/include
375  cp ../gcc-%{gcc_pkgvers}/gcc/gsyslimits.h gcc/include/syslimits.h
376%endif
377
378  make %{?_smp_mflags} all
379  cd ..
380
381%install
382  rm -rf $RPM_BUILD_ROOT
383
384  cd build
385
386  make DESTDIR=$RPM_BUILD_ROOT install
387  cd ..
388
389
390%if "%{gcc_version}" <= "4.1.2"
391# Misplaced header file
392  if test -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h; then
393    mv $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h \
394      $RPM_BUILD_ROOT%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include/
395  fi
396%endif
397
398  # host library
399%if "%{gcc_version}" >= "4.2.0"
400  # libiberty doesn't honor --libdir, but always installs to a
401  # magically guessed _libdir
402  rm -f  ${RPM_BUILD_ROOT}%{_libdir}/libiberty.a
403%else
404  # libiberty installs to --libdir=...
405  rm -f ${RPM_BUILD_ROOT}%{_gcclibdir}/libiberty.a
406%endif
407
408  # We use the version from binutils
409  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd8.2-c++filt%{_exeext}
410
411
412# Conflict with a native GCC's infos
413  rm -rf $RPM_BUILD_ROOT%{_infodir}
414
415# Conflict with a native GCC's man pages
416  rm -rf $RPM_BUILD_ROOT%{_mandir}/man7
417
418  # Bug in gcc-3.4.0pre
419  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd8.2-i586-pc-freebsd8.2-gcjh%{_exeext}
420
421  # Bug in gcc-3.3.x/gcc-3.4.x: Despite we don't need fixincludes, it installs
422  # the fixinclude-install-tools
423  rm -rf ${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/install-tools
424  rm -rf ${RPM_BUILD_ROOT}%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/install-tools
425
426  # Bug in gcc > 4.1.0: Installs an unused, empty directory
427  if test -d ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd8.2/include/bits; then
428    rmdir ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd8.2/include/bits
429  fi
430
431  # gcc >= 4.5.0: installs weird libstdc++ python bindings.
432%if ! %{with pygdb}
433  if test -d ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python; then
434    rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python/libstdcxx
435  fi
436%endif
437
438  # Collect multilib subdirectories
439  multilibs=`build/gcc/xgcc -Bbuild/gcc/ --print-multi-lib | sed -e 's,;.*$,,'`
440
441
442  rm -f dirs ;
443  echo "%defattr(-,root,root,-)" >> dirs
444  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}"
445  for i in $multilibs; do
446    case $i in
447    \.) ;; # ignore, handled elsewhere
448    *)  echo "%dir ${TGTDIR}/$i" >> dirs
449      ;;
450    esac
451  done
452
453  # Collect files to go into different packages
454  cp dirs build/files.gcc
455  cp dirs build/files.gfortran
456  cp dirs build/files.objc
457  cp dirs build/files.gcj
458  cp dirs build/files.g++
459
460  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}"
461  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
462  for i in $f; do
463    case $i in
464    *lib*.la) rm ${RPM_BUILD_ROOT}/$i ;; # ignore: gcc produces bogus libtool libs
465    *f771) ;;
466    *f951) ;;
467    *cc1) ;;
468    *cc1obj) ;;
469    *cc1plus) ;; # ignore: explicitly put into rpm elsewhere
470    *collect2) ;;
471    *libobjc*) echo "$i" >> build/files.objc ;;
472    *include/objc*) ;;
473    *include/g++*);;
474    *include/c++*);;
475    *include-fixed/*);;
476    *finclude/*);;
477    *adainclude*);;
478    *adalib*);;
479    *gnat1);;
480    *jc1) ;;
481    *jvgenmain) ;;
482    */libgfortran*.*) echo "$i" >> build/files.gfortran ;;
483    %{!?with_pygdb:*/libstdc++*gdb.py*) rm ${RPM_BUILD_ROOT}/$i ;;} # ignore for now
484    %{?with_pygdb:*/libstdc++*gdb.py*) >> build/files.g++ ;;}
485    */libstdc++.*) echo "$i" >> build/files.g++ ;;
486    */libsupc++.*) echo "$i" >> build/files.g++ ;;
487    *) echo "$i" >> build/files.gcc ;;
488    esac
489  done
490
491  TGTDIR="%{_exec_prefix}/i586-pc-freebsd8.2/lib"
492  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
493  for i in $f; do
494    case $i in
495    *lib*.la) rm ${RPM_BUILD_ROOT}/$i;; # ignore - gcc produces bogus libtool libs
496    *libiberty.a) rm ${RPM_BUILD_ROOT}/$i ;; # ignore - GPL'ed
497# all other files belong to newlib
498    *) echo "$i" >> build/files.newlib ;;
499    esac
500  done
501# Extract %%__os_install_post into os_install_post~
502cat << \EOF > os_install_post~
503%__os_install_post
504EOF
505
506# Generate customized brp-*scripts
507cat os_install_post~ | while read a x y; do
508case $a in
509# Prevent brp-strip* from trying to handle foreign binaries
510*/brp-strip*)
511  b=$(basename $a)
512  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
513  chmod a+x $b
514  ;;
515esac
516done
517
518sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
519< os_install_post~ > os_install_post
520%define __os_install_post . ./os_install_post
521
522
523cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
524#!/bin/sh
525grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd8.2/(lib|include|sys-root)' \
526  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd8.2/'} | %__find_provides
527EOF
528chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
529%define __find_provides %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
530
531cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
532#!/bin/sh
533grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd8.2/(lib|include|sys-root)' \
534  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd8.2/'} | %__find_requires
535EOF
536chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
537%define __find_requires %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
538
539%ifnarch noarch
540# Extract %%__debug_install_post into debug_install_post~
541cat << \EOF > debug_install_post~
542%__debug_install_post
543EOF
544
545# Generate customized debug_install_post script
546cat debug_install_post~ | while read a x y; do
547case $a in
548# Prevent find-debuginfo.sh* from trying to handle foreign binaries
549*/find-debuginfo.sh)
550  b=$(basename $a)
551  sed -e 's,find "$RPM_BUILD_ROOT" !,find "$RPM_BUILD_ROOT"%_bindir "$RPM_BUILD_ROOT"%_libexecdir !,' $a > $b
552  chmod a+x $b
553  ;;
554esac
555done
556
557sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
558< debug_install_post~ > debug_install_post
559%define __debug_install_post . ./debug_install_post
560
561%endif
562
563%clean
564  rm -rf $RPM_BUILD_ROOT
565
566# ==============================================================
567# i586-pc-freebsd8.2-gcc
568# ==============================================================
569# %package -n i586-pc-freebsd8.2-gcc
570# Summary:        GNU cc compiler for i586-pc-freebsd8.2
571# Group:          Development/Tools
572# Version:        %{gcc_rpmvers}
573# Requires:       i586-pc-freebsd8.2-binutils
574# License:      GPL
575
576# %if %build_infos
577# Requires:      gcc-common
578# %endif
579
580%description -n i586-pc-freebsd8.2-gcc
581GNU cc compiler for i586-pc-freebsd8.2.
582
583# ==============================================================
584# i586-pc-freebsd8.2-gcc-libgcc
585# ==============================================================
586%package -n i586-pc-freebsd8.2-gcc-libgcc
587Summary:        libgcc for i586-pc-freebsd8.2-gcc
588Group:          Development/Tools
589Version:        %{gcc_rpmvers}
590%{?_with_noarch_subpackages:BuildArch: noarch}
591License:        GPL
592
593%description -n i586-pc-freebsd8.2-gcc-libgcc
594libgcc i586-pc-freebsd8.2-gcc.
595
596
597%files -n i586-pc-freebsd8.2-gcc
598%defattr(-,root,root)
599
600%{_mandir}/man1/i586-pc-freebsd8.2-gcc.1*
601%{_mandir}/man1/i586-pc-freebsd8.2-cpp.1*
602%{_mandir}/man1/i586-pc-freebsd8.2-gcov.1*
603
604%{_bindir}/i586-pc-freebsd8.2-cpp%{_exeext}
605%{_bindir}/i586-pc-freebsd8.2-gcc%{_exeext}
606%{_bindir}/i586-pc-freebsd8.2-gcc-%{gcc_version}%{_exeext}
607%{_bindir}/i586-pc-freebsd8.2-gcov%{_exeext}
608%{_bindir}/i586-pc-freebsd8.2-gccbug
609
610%dir %{_libexecdir}/gcc
611%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2
612%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
613%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/cc1%{_exeext}
614%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/collect2%{_exeext}
615%if "%{gcc_version}" >= "4.5.0"
616%{?with_lto:%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/lto%{_exeext}}
617%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/lto-wrapper%{_exeext}
618%endif
619
620%files -n i586-pc-freebsd8.2-gcc-libgcc -f build/files.gcc
621%defattr(-,root,root)
622%dir %{_gcclibdir}/gcc
623%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2
624%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
625%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include
626
627%if "%{gcc_version}" > "4.0.3"
628%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include/ssp
629%endif
630
631%if "%{gcc_version}" >= "4.3.0"
632%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include-fixed
633%endif
634
635# ==============================================================
636# i586-pc-freebsd8.2-gcc-c++
637# ==============================================================
638%package -n i586-pc-freebsd8.2-gcc-c++
639Summary:        GCC c++ compiler for i586-pc-freebsd8.2
640Group:          Development/Tools
641Version:        %{gcc_rpmvers}
642License:        GPL
643Requires:       i586-pc-freebsd8.2-gcc-libstdc++ = %{gcc_rpmvers}-%{release}
644
645%if "%{_build}" != "%{_host}"
646BuildRequires:  i586-pc-freebsd8.2-gcc-c++ = %{gcc_rpmvers}
647%endif
648
649Requires:       i586-pc-freebsd8.2-gcc = %{gcc_rpmvers}-%{release}
650
651%description -n i586-pc-freebsd8.2-gcc-c++
652GCC c++ compiler for i586-pc-freebsd8.2.
653
654
655%package -n i586-pc-freebsd8.2-gcc-libstdc++
656Summary:        libstdc++ for i586-pc-freebsd8.2
657Group:          Development/Tools
658Version:        %{gcc_rpmvers}
659%{?_with_noarch_subpackages:BuildArch: noarch}
660License:        GPL
661
662%description -n i586-pc-freebsd8.2-gcc-libstdc++
663%{summary}
664
665
666%files -n i586-pc-freebsd8.2-gcc-c++
667%defattr(-,root,root)
668
669%{_mandir}/man1/i586-pc-freebsd8.2-g++.1*
670
671%{_bindir}/i586-pc-freebsd8.2-c++%{_exeext}
672%{_bindir}/i586-pc-freebsd8.2-g++%{_exeext}
673
674%dir %{_libexecdir}/gcc
675%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2
676%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
677%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/cc1plus%{_exeext}
678
679
680%files -n i586-pc-freebsd8.2-gcc-libstdc++ -f build/files.g++
681%defattr(-,root,root)
682%dir %{_gcclibdir}/gcc
683%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2
684%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
685%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include
686%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include/c++
687
688# ==============================================================
689# i586-pc-freebsd8.2-gcc-gfortran
690# ==============================================================
691%package -n i586-pc-freebsd8.2-gcc-gfortran
692Summary:        Fortran 95 support for i586-pc-freebsd8.2-gcc
693Group:          Development/Tools
694Version:        %{gcc_rpmvers}
695License:        GPL
696
697Requires:       i586-pc-freebsd8.2-gcc = %{gcc_rpmvers}-%{release}
698Requires:       i586-pc-freebsd8.2-gcc-libgfortran = %{gcc_rpmvers}-%{release}
699
700%description -n i586-pc-freebsd8.2-gcc-gfortran
701GCC fortran compiler for i586-pc-freebsd8.2.
702
703%files -n i586-pc-freebsd8.2-gcc-gfortran
704%defattr(-,root,root)
705%{_bindir}/i586-pc-freebsd8.2-gfortran%{_exeext}
706
707%{_mandir}/man1/i586-pc-freebsd8.2-gfortran.1*
708
709%dir %{_libexecdir}/gcc
710%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2
711%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
712%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/f951%{_exeext}
713
714# ==============================================================
715# i586-pc-freebsd8.2-gcc-libgfortran
716# ==============================================================
717%package -n i586-pc-freebsd8.2-gcc-libgfortran
718Summary:        Fortran 95 support libraries for i586-pc-freebsd8.2-gcc
719Group:          Development/Tools
720Version:        %{gcc_rpmvers}
721%{?_with_noarch_subpackages:BuildArch: noarch}
722License:        GPL
723
724%description -n i586-pc-freebsd8.2-gcc-libgfortran
725%{summary}
726
727%files -n i586-pc-freebsd8.2-gcc-libgfortran -f build/files.gfortran
728%defattr(-,root,root)
729%dir %{_gcclibdir}/gcc
730%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2
731%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
732%if "%{gcc_version}" >= "4.2.0"
733%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/finclude
734%endif
735
736# ==============================================================
737# i586-pc-freebsd8.2-gcc-objc
738# ==============================================================
739%package -n i586-pc-freebsd8.2-gcc-objc
740Summary:        Objective C support for i586-pc-freebsd8.2-gcc
741Group:          Development/Tools
742Version:        %{gcc_rpmvers}
743License:        GPL
744
745Requires:       i586-pc-freebsd8.2-gcc = %{gcc_rpmvers}-%{release}
746Requires:       i586-pc-freebsd8.2-gcc-libobjc = %{gcc_rpmvers}-%{release}
747
748%description -n i586-pc-freebsd8.2-gcc-objc
749GCC objc compiler for i586-pc-freebsd8.2.
750
751%files -n i586-pc-freebsd8.2-gcc-objc
752%defattr(-,root,root)
753%dir %{_libexecdir}/gcc
754%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2
755%dir %{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
756%{_libexecdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/cc1obj%{_exeext}
757
758# ==============================================================
759# i586-pc-freebsd8.2-gcc-libobjc
760# ==============================================================
761%package -n i586-pc-freebsd8.2-gcc-libobjc
762Summary:        Objective C support for i586-pc-freebsd8.2-gcc
763Group:          Development/Tools
764Version:        %{gcc_rpmvers}
765%{?_with_noarch_subpackages:BuildArch: noarch}
766License:        GPL
767
768%description -n i586-pc-freebsd8.2-gcc-libobjc
769Support libraries for GCC's objc compiler for i586-pc-freebsd8.2.
770
771%files -n i586-pc-freebsd8.2-gcc-libobjc -f build/files.objc
772%defattr(-,root,root)
773%dir %{_gcclibdir}/gcc
774%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2
775%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}
776%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include
777%{_gcclibdir}/gcc/i586-pc-freebsd8.2/%{gcc_version}/include/objc
778
Note: See TracBrowser for help on using the repository browser.