source: rtems/contrib/crossrpms/freebsd8.0/i586/i586-pc-freebsd8.0-gcc.spec @ 5eea54b

4.104.115
Last change on this file since 5eea54b was 5eea54b, checked in by Ralf Corsepius <ralf.corsepius@…>, on 05/24/10 at 07:31:52

Regenerate.

  • Property mode set to 100644
File size: 21.7 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6
7%ifos cygwin cygwin32 mingw mingw32
8%define _exeext .exe
9%define debug_package           %{nil}
10%define _libdir                 %{_exec_prefix}/lib
11%else
12%define _exeext %{nil}
13%endif
14
15%ifos cygwin cygwin32
16%define optflags -O3 -pipe -march=i486 -funroll-loops
17%endif
18
19%ifos mingw mingw32
20%if %{defined _mingw32_cflags}
21%define optflags %{_mingw32_cflags}
22%else
23%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
24%endif
25%endif
26
27%if "%{_build}" != "%{_host}"
28%define _host_rpmprefix %{_host}-
29%else
30%define _host_rpmprefix %{nil}
31%endif
32
33
34%define gcc_pkgvers 4.5.0
35%define gcc_version 4.5.0
36%define gcc_rpmvers %{expand:%(echo "4.5.0" | tr - _ )}
37
38
39Name:           i586-pc-freebsd8.0-gcc
40Summary:        i586-pc-freebsd8.0 gcc
41
42Group:          Development/Tools
43Version:        %{gcc_rpmvers}
44Release:        0.20100427.0%{?dist}
45License:        GPL
46URL:            http://gcc.gnu.org
47BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49%define _use_internal_dependency_generator 0
50
51BuildRequires:  %{_host_rpmprefix}gcc
52
53# FIXME: Disable lto for now, to avoid dependencies on libelf
54%bcond_with lto
55
56# FIXME: Disable python gdb scripts
57# ATM, no idea how to package them
58%bcond_with pygdb
59
60# FIXME: Disable GCC-plugin
61# Bug in gcc-4.5-20100318, doesn't build them on x86_84 hosts.
62%bcond_with plugin
63
64# versions of libraries, we conditionally bundle if necessary
65%global mpc_version     0.8.1
66%global mpfr_version    2.4.2
67%global gmp_version     4.3.2
68%global libelf_version  0.8.13
69
70# versions of libraries these distros are known to ship
71%if 0%{?fc13}
72%global mpc_provided 0.8.1
73%global mpfr_provided 2.4.2
74%global gmp_provided 4.3.1
75%endif
76
77%if 0%{?fc12}
78%global mpc_provided 0.8
79%global mpfr_provided 2.4.1
80%global gmp_provided 4.3.1
81%endif
82
83%if 0%{?fc11}
84%global mpc_provided %{nil}
85%global mpfr_provided 2.4.1
86%global gmp_provided 4.2.4
87%endif
88
89%if 0%{?el6}
90%global mpc_provided %{nil}
91%global mpfr_provided 2.4.1
92%global gmp_provided 4.3.1
93%endif
94
95%if 0%{?el5}
96%global mpc_provided %{nil}
97%global mpfr_provided %{nil}
98%global gmp_provided 4.1.4
99%endif
100
101%if 0%{?suse11_0}
102%global mpc_provided %{nil}
103%global mpfr_provided 2.3.1
104%global gmp_provided 4.2.2
105%endif
106
107%if 0%{?suse11_1}
108%global mpc_provided %{nil}
109%global mpfr_provided 2.3.2
110%global gmp_provided 4.2.3
111%endif
112
113%if 0%{?suse11_2}
114%global mpc_provided 0.7
115%global mpfr_provided 2.4.1
116%global gmp_provided 4.3.1
117%endif
118
119%if 0%{?cygwin}
120%global mpc_provided 0.8
121%global mpfr_provided 2.4.1
122%global gmp_provided 4.3.1
123%endif
124
125%if 0%{?mingw32}
126%global mpc_provided 0.8.1
127%global mpfr_provided 2.4.1
128%global gmp_provided 4.3.2
129%endif
130
131%if "%{gcc_version}" >= "4.2.0"
132%define gmp_required            4.1
133%define mpfr_required           2.2.1
134%endif
135
136%if "%{gcc_version}" >= "4.3.0"
137%define gmp_required            4.1
138%define mpfr_required           2.3.1
139%endif
140
141%if "%{gcc_version}" >= "4.3.3"
142%define cloog_required          0.15
143%endif
144
145%if "%{gcc_version}" >= "4.4.0"
146%define mpfr_required           2.3.2
147%endif
148
149%if "%{gcc_version}" >= "4.5.0"
150%define mpc_required            0.8
151%if %{with lto}
152%define libelf_required         0.8.12
153%endif
154%endif
155
156%if %{defined mpc_required}
157%if "%{mpc_provided}" >= "%{mpc_required}"
158%{?fedora:BuildRequires: libmpc-devel >= %{mpc_required}}
159%{?suse:BuildRequires: mpc-devel >= %{mpc_required}}
160%if "%{_build}" != "%{_host}"
161BuildRequires:  %{_host_rpmprefix}mpc-devel >= %{mpc_required}
162%endif
163%else
164%define _build_mpc 1
165%define gmp_required            4.2
166%endif
167%endif
168
169%if %{defined gmp_required}
170%if "%{gmp_provided}" >= "%{gmp_required}"
171BuildRequires: gmp-devel >= %{gmp_required}
172%if "%{_build}" != "%{_host}"
173BuildRequires:  %{_host_rpmprefix}gmp-devel >= %{gmp_required}
174%endif
175%else
176%define _build_gmp 1
177%endif
178%endif
179
180%if %{defined libelf_required}
181%if "%{libelf_provided}" >= "%{libelf_required}"
182BuildRequires: libelf-devel >= %{libelf_required}
183%if "%{_build}" != "%{_host}"
184BuildRequires:  %{_host_rpmprefix}libelf-devel >= %{libelf_required}
185%endif
186%else
187%define _build_libelf 1
188%endif
189%endif
190
191
192%if %{defined cloog_required}
193%{?fc11:BuildRequires: cloog-ppl-devel >= %cloog_required}
194%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
195%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
196%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
197%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
198%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
199%endif
200
201
202%if %{defined mpfr_required}
203%if "%{mpfr_provided}" >= "%{mpfr_required}"
204BuildRequires: mpfr-devel >= %{mpfr_required}
205%if "%{_build}" != "%{_host}"
206BuildRequires:  %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
207%endif
208%else
209%define _build_mpfr 1
210%endif
211%endif
212
213%if "%{_build}" != "%{_host}"
214BuildRequires:  i586-pc-freebsd8.0-gcc = %{gcc_rpmvers}
215%endif
216
217%if "%{gcc_version}" >= "4.2.0"
218BuildRequires:  flex bison
219%endif
220
221
222BuildRequires:  texinfo >= 4.2
223BuildRequires:  i586-pc-freebsd8.0-binutils
224BuildRequires:  i586-pc-freebsd8.0-sys-root
225
226Requires:       i586-pc-freebsd8.0-binutils
227Requires:       i586-pc-freebsd8.0-sys-root
228Requires:       i586-pc-freebsd8.0-gcc-libgcc = %{gcc_rpmvers}-%{release}
229
230%if "%{gcc_version}" >= "4.5.0"
231BuildRequires:  zlib-devel
232%if "%{_build}" != "%{_host}"
233BuildRequires:  %{_host_rpmprefix}zlib-devel
234%endif
235%else
236%endif
237
238%global _gcclibdir %{_prefix}/lib
239
240Source0:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-core-%{gcc_pkgvers}.tar.bz2
241%{?_without_sources:NoSource:   0}
242
243Source1:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-g++-%{gcc_pkgvers}.tar.bz2
244%{?_without_sources:NoSource:   1}
245
246Source2:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-fortran-%{gcc_pkgvers}.tar.bz2
247%{?_without_sources:NoSource:   2}
248
249Source5:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-objc-%{gcc_pkgvers}.tar.bz2
250%{?_without_sources:NoSource:   5}
251
252%if 0%{?_build_mpfr}
253Source60:    http://www.mpfr.org/mpfr-current/mpfr-%{mpfr_version}.tar.bz2
254%endif
255
256%if 0%{?_build_mpc}
257Source61:    http://www.multiprecision.org/mpc/download/mpc-%{mpc_version}.tar.gz
258%endif
259
260%if 0%{?_build_gmp}
261Source62:    ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
262%endif
263
264%if 0%{?_build_libelf}
265Source63:    http://www.mr511.de/software/libelf-%{libelf_version}.tar.gz
266%endif
267
268%description
269Cross gcc for i586-pc-freebsd8.0.
270
271%prep
272%setup -c -T -n %{name}-%{version}
273
274%setup -q -T -D -n %{name}-%{version} -a0
275cd gcc-%{gcc_pkgvers}
276%{?PATCH0:%patch0 -p1}
277cd ..
278
279%setup -q -T -D -n %{name}-%{version} -a1
280cd gcc-%{gcc_pkgvers}
281%{?PATCH1:%patch1 -p1}
282cd ..
283
284%setup -q -T -D -n %{name}-%{version} -a2
285%{?PATCH2:%patch2 -p0}
286
287
288
289%setup -q -T -D -n %{name}-%{version} -a5
290%{?PATCH5:%patch5 -p0}
291
292
293%if 0%{?_build_mpfr}
294%setup -q -T -D -n %{name}-%{version} -a60
295%{?PATCH60:%patch60 -p1}
296  # Build mpfr one-tree style
297  ln -s ../mpfr-%{mpfr_version} gcc-%{gcc_pkgvers}/mpfr
298%endif
299
300%if 0%{?_build_mpc}
301%setup -q -T -D -n %{name}-%{version} -a61
302%{?PATCH61:%patch61 -p1}
303  # Build mpc one-tree style
304  ln -s ../mpc-%{mpc_version} gcc-%{gcc_pkgvers}/mpc
305%endif
306
307%if 0%{?_build_gmp}
308%setup -q -T -D -n %{name}-%{version} -a62
309%{?PATCH62:%patch62 -p1}
310  # Build gmp one-tree style
311  ln -s ../gmp-%{gmp_version} gcc-%{gcc_pkgvers}/gmp
312%endif
313
314%if 0%{?_build_libelf}
315%setup -q -T -D -n %{name}-%{version} -a63
316%{?PATCH63:%patch63 -p1}
317  # Build libelf one-tree style
318  ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
319%endif
320
321
322  # Fix timestamps
323  cd gcc-%{gcc_pkgvers}
324  contrib/gcc_update --touch
325  cd ..
326%build
327  mkdir -p build
328
329  cd build
330
331  languages="c"
332  languages="$languages,c++"
333  languages="$languages,fortran"
334  languages="$languages,objc"
335%if "%{_build}" != "%{_host}"
336  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
337  CC="%{_host}-gcc ${RPM_OPT_FLAGS}" \
338%else
339# gcc is not ready to be compiled with -std=gnu99
340  CC=$(echo "%{__cc} ${RPM_OPT_FLAGS}" | sed -e 's,-std=gnu99 ,,') \
341%endif
342  ../gcc-%{gcc_pkgvers}/configure \
343    --prefix=%{_prefix} \
344    --bindir=%{_bindir} \
345    --exec_prefix=%{_exec_prefix} \
346    --includedir=%{_includedir} \
347    --libdir=%{_gcclibdir} \
348    --libexecdir=%{_libexecdir} \
349    --mandir=%{_mandir} \
350    --infodir=%{_infodir} \
351    --datadir=%{_datadir} \
352    --build=%_build --host=%_host \
353    --target=i586-pc-freebsd8.0 \
354    --disable-libstdcxx-pch \
355    --with-gnu-as --with-gnu-ld --verbose \
356    --with-system-zlib \
357    --disable-nls --without-included-gettext \
358    --disable-win32-registry \
359    --enable-version-specific-runtime-libs \
360    --enable-threads \
361    --with-sysroot=%{_exec_prefix}/i586-pc-freebsd8.0/sys-root \
362    %{?with_lto:--enable-lto}%{!?with_lto:--disable-lto} \
363    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
364    --enable-languages="$languages" $optargs
365
366%if "%_host" != "%_build"
367  # Bug in gcc-3.2.1:
368  # Somehow, gcc doesn't get syslimits.h right for Cdn-Xs
369  mkdir -p gcc/include
370  cp ../gcc-%{gcc_pkgvers}/gcc/gsyslimits.h gcc/include/syslimits.h
371%endif
372
373  make %{?_smp_mflags} all
374  cd ..
375
376%install
377  rm -rf $RPM_BUILD_ROOT
378
379  cd build
380
381  make DESTDIR=$RPM_BUILD_ROOT install
382  cd ..
383
384
385%if "%{gcc_version}" <= "4.1.2"
386# Misplaced header file
387  if test -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h; then
388    mv $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h \
389      $RPM_BUILD_ROOT%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include/
390  fi
391%endif
392
393  # host library
394%if "%{gcc_version}" >= "4.2.0"
395  # libiberty doesn't honor --libdir, but always installs to a
396  # magically guessed _libdir
397  rm -f  ${RPM_BUILD_ROOT}%{_libdir}/libiberty.a
398%else
399  # libiberty installs to --libdir=...
400  rm -f ${RPM_BUILD_ROOT}%{_gcclibdir}/libiberty.a
401%endif
402
403  # We use the version from binutils
404  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd8.0-c++filt%{_exeext}
405
406
407# Conflict with a native GCC's infos
408  rm -rf $RPM_BUILD_ROOT%{_infodir}
409
410# Conflict with a native GCC's man pages
411  rm -rf $RPM_BUILD_ROOT%{_mandir}/man7
412
413  # Bug in gcc-3.4.0pre
414  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd8.0-i586-pc-freebsd8.0-gcjh%{_exeext}
415
416  # Bug in gcc-3.3.x/gcc-3.4.x: Despite we don't need fixincludes, it installs
417  # the fixinclude-install-tools
418  rm -rf ${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/install-tools
419  rm -rf ${RPM_BUILD_ROOT}%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/install-tools
420
421  # Bug in gcc > 4.1.0: Installs an unused, empty directory
422  if test -d ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd8.0/include/bits; then
423    rmdir ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd8.0/include/bits
424  fi
425
426  # gcc >= 4.5.0: installs weird libstdc++ python bindings.
427%if ! %{with pygdb}
428  if test -d ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python; then
429    rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python/libstdcxx
430  fi
431%endif
432
433  # Collect multilib subdirectories
434  multilibs=`build/gcc/xgcc -Bbuild/gcc/ --print-multi-lib | sed -e 's,;.*$,,'`
435
436
437  rm -f dirs ;
438  echo "%defattr(-,root,root,-)" >> dirs
439  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}"
440  for i in $multilibs; do
441    case $i in
442    \.) ;; # ignore, handled elsewhere
443    *)  echo "%dir ${TGTDIR}/$i" >> dirs
444      ;;
445    esac
446  done
447
448  # Collect files to go into different packages
449  cp dirs build/files.gcc
450  cp dirs build/files.gfortran
451  cp dirs build/files.objc
452  cp dirs build/files.gcj
453  cp dirs build/files.g++
454
455  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}"
456  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
457  for i in $f; do
458    case $i in
459    *lib*.la) rm ${RPM_BUILD_ROOT}/$i ;; # ignore: gcc produces bogus libtool libs
460    *f771) ;;
461    *f951) ;;
462    *cc1) ;;
463    *cc1obj) ;;
464    *cc1plus) ;; # ignore: explicitly put into rpm elsewhere
465    *collect2) ;;
466    *libobjc*) echo "$i" >> build/files.objc ;;
467    *include/objc*) ;;
468    *include/g++*);;
469    *include/c++*);;
470    *include-fixed/*);;
471    *finclude/*);;
472    *adainclude*);;
473    *adalib*);;
474    *gnat1);;
475    *jc1) ;;
476    *jvgenmain) ;;
477    */libgfortran*.*) echo "$i" >> build/files.gfortran ;;
478    %{!?with_pygdb:*/libstdc++*gdb.py*) rm ${RPM_BUILD_ROOT}/$i ;;} # ignore for now
479    %{?with_pygdb:*/libstdc++*gdb.py*) >> build/files.g++ ;;}
480    */libstdc++.*) echo "$i" >> build/files.g++ ;;
481    */libsupc++.*) echo "$i" >> build/files.g++ ;;
482    *) echo "$i" >> build/files.gcc ;;
483    esac
484  done
485
486  TGTDIR="%{_exec_prefix}/i586-pc-freebsd8.0/lib"
487  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
488  for i in $f; do
489    case $i in
490    *lib*.la) rm ${RPM_BUILD_ROOT}/$i;; # ignore - gcc produces bogus libtool libs
491    *libiberty.a) rm ${RPM_BUILD_ROOT}/$i ;; # ignore - GPL'ed
492# all other files belong to newlib
493    *) echo "$i" >> build/files.newlib ;;
494    esac
495  done
496# Extract %%__os_install_post into os_install_post~
497cat << \EOF > os_install_post~
498%__os_install_post
499EOF
500
501# Generate customized brp-*scripts
502cat os_install_post~ | while read a x y; do
503case $a in
504# Prevent brp-strip* from trying to handle foreign binaries
505*/brp-strip*)
506  b=$(basename $a)
507  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
508  chmod a+x $b
509  ;;
510esac
511done
512
513sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
514< os_install_post~ > os_install_post
515%define __os_install_post . ./os_install_post
516
517
518cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
519#!/bin/sh
520grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd8.0/(lib|include|sys-root)' \
521  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd8.0/'} | %__find_provides
522EOF
523chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
524%define __find_provides %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
525
526cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
527#!/bin/sh
528grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd8.0/(lib|include|sys-root)' \
529  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd8.0/'} | %__find_requires
530EOF
531chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
532%define __find_requires %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
533
534%ifnarch noarch
535# Extract %%__debug_install_post into debug_install_post~
536cat << \EOF > debug_install_post~
537%__debug_install_post
538EOF
539
540# Generate customized debug_install_post script
541cat debug_install_post~ | while read a x y; do
542case $a in
543# Prevent find-debuginfo.sh* from trying to handle foreign binaries
544*/find-debuginfo.sh)
545  b=$(basename $a)
546  sed -e 's,find "$RPM_BUILD_ROOT" !,find "$RPM_BUILD_ROOT"%_bindir "$RPM_BUILD_ROOT"%_libexecdir !,' $a > $b
547  chmod a+x $b
548  ;;
549esac
550done
551
552sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
553< debug_install_post~ > debug_install_post
554%define __debug_install_post . ./debug_install_post
555
556%endif
557
558%clean
559  rm -rf $RPM_BUILD_ROOT
560
561# ==============================================================
562# i586-pc-freebsd8.0-gcc
563# ==============================================================
564# %package -n i586-pc-freebsd8.0-gcc
565# Summary:        GNU cc compiler for i586-pc-freebsd8.0
566# Group:          Development/Tools
567# Version:        %{gcc_rpmvers}
568# Requires:       i586-pc-freebsd8.0-binutils
569# License:      GPL
570
571# %if %build_infos
572# Requires:      gcc-common
573# %endif
574
575%description -n i586-pc-freebsd8.0-gcc
576GNU cc compiler for i586-pc-freebsd8.0.
577
578# ==============================================================
579# i586-pc-freebsd8.0-gcc-libgcc
580# ==============================================================
581%package -n i586-pc-freebsd8.0-gcc-libgcc
582Summary:        libgcc for i586-pc-freebsd8.0-gcc
583Group:          Development/Tools
584Version:        %{gcc_rpmvers}
585%{?_with_noarch_subpackages:BuildArch: noarch}
586License:        GPL
587
588%description -n i586-pc-freebsd8.0-gcc-libgcc
589libgcc i586-pc-freebsd8.0-gcc.
590
591
592%files -n i586-pc-freebsd8.0-gcc
593%defattr(-,root,root)
594
595%{_mandir}/man1/i586-pc-freebsd8.0-gcc.1*
596%{_mandir}/man1/i586-pc-freebsd8.0-cpp.1*
597%{_mandir}/man1/i586-pc-freebsd8.0-gcov.1*
598
599%{_bindir}/i586-pc-freebsd8.0-cpp%{_exeext}
600%{_bindir}/i586-pc-freebsd8.0-gcc%{_exeext}
601%{_bindir}/i586-pc-freebsd8.0-gcc-%{gcc_version}%{_exeext}
602%{_bindir}/i586-pc-freebsd8.0-gcov%{_exeext}
603%{_bindir}/i586-pc-freebsd8.0-gccbug
604
605%dir %{_libexecdir}/gcc
606%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0
607%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
608%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/cc1%{_exeext}
609%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/collect2%{_exeext}
610%if "%{gcc_version}" >= "4.5.0"
611%{?with_lto:%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/lto%{_exeext}}
612%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/lto-wrapper%{_exeext}
613%endif
614
615%files -n i586-pc-freebsd8.0-gcc-libgcc -f build/files.gcc
616%defattr(-,root,root)
617%dir %{_gcclibdir}/gcc
618%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0
619%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
620%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include
621
622%if "%{gcc_version}" > "4.0.3"
623%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include/ssp
624%endif
625
626%if "%{gcc_version}" >= "4.3.0"
627%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include-fixed
628%endif
629
630# ==============================================================
631# i586-pc-freebsd8.0-gcc-c++
632# ==============================================================
633%package -n i586-pc-freebsd8.0-gcc-c++
634Summary:        GCC c++ compiler for i586-pc-freebsd8.0
635Group:          Development/Tools
636Version:        %{gcc_rpmvers}
637License:        GPL
638Requires:       i586-pc-freebsd8.0-gcc-libstdc++ = %{gcc_rpmvers}-%{release}
639
640%if "%{_build}" != "%{_host}"
641BuildRequires:  i586-pc-freebsd8.0-gcc-c++ = %{gcc_rpmvers}
642%endif
643
644Requires:       i586-pc-freebsd8.0-gcc = %{gcc_rpmvers}-%{release}
645
646%description -n i586-pc-freebsd8.0-gcc-c++
647GCC c++ compiler for i586-pc-freebsd8.0.
648
649
650%package -n i586-pc-freebsd8.0-gcc-libstdc++
651Summary:        libstdc++ for i586-pc-freebsd8.0
652Group:          Development/Tools
653Version:        %{gcc_rpmvers}
654%{?_with_noarch_subpackages:BuildArch: noarch}
655License:        GPL
656
657%description -n i586-pc-freebsd8.0-gcc-libstdc++
658%{summary}
659
660
661%files -n i586-pc-freebsd8.0-gcc-c++
662%defattr(-,root,root)
663
664%{_mandir}/man1/i586-pc-freebsd8.0-g++.1*
665
666%{_bindir}/i586-pc-freebsd8.0-c++%{_exeext}
667%{_bindir}/i586-pc-freebsd8.0-g++%{_exeext}
668
669%dir %{_libexecdir}/gcc
670%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0
671%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
672%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/cc1plus%{_exeext}
673
674
675%files -n i586-pc-freebsd8.0-gcc-libstdc++ -f build/files.g++
676%defattr(-,root,root)
677%dir %{_gcclibdir}/gcc
678%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0
679%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
680%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include
681%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include/c++
682
683# ==============================================================
684# i586-pc-freebsd8.0-gcc-gfortran
685# ==============================================================
686%package -n i586-pc-freebsd8.0-gcc-gfortran
687Summary:        Fortran 95 support for i586-pc-freebsd8.0-gcc
688Group:          Development/Tools
689Version:        %{gcc_rpmvers}
690License:        GPL
691
692Requires:       i586-pc-freebsd8.0-gcc = %{gcc_rpmvers}-%{release}
693Requires:       i586-pc-freebsd8.0-gcc-libgfortran = %{gcc_rpmvers}-%{release}
694
695%description -n i586-pc-freebsd8.0-gcc-gfortran
696GCC fortran compiler for i586-pc-freebsd8.0.
697
698%files -n i586-pc-freebsd8.0-gcc-gfortran
699%defattr(-,root,root)
700%{_bindir}/i586-pc-freebsd8.0-gfortran%{_exeext}
701
702%{_mandir}/man1/i586-pc-freebsd8.0-gfortran.1*
703
704%dir %{_libexecdir}/gcc
705%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0
706%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
707%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/f951%{_exeext}
708
709# ==============================================================
710# i586-pc-freebsd8.0-gcc-libgfortran
711# ==============================================================
712%package -n i586-pc-freebsd8.0-gcc-libgfortran
713Summary:        Fortran 95 support libraries for i586-pc-freebsd8.0-gcc
714Group:          Development/Tools
715Version:        %{gcc_rpmvers}
716%{?_with_noarch_subpackages:BuildArch: noarch}
717License:        GPL
718
719%description -n i586-pc-freebsd8.0-gcc-libgfortran
720%{summary}
721
722%files -n i586-pc-freebsd8.0-gcc-libgfortran -f build/files.gfortran
723%defattr(-,root,root)
724%dir %{_gcclibdir}/gcc
725%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0
726%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
727%if "%{gcc_version}" >= "4.2.0"
728%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/finclude
729%endif
730
731# ==============================================================
732# i586-pc-freebsd8.0-gcc-objc
733# ==============================================================
734%package -n i586-pc-freebsd8.0-gcc-objc
735Summary:        Objective C support for i586-pc-freebsd8.0-gcc
736Group:          Development/Tools
737Version:        %{gcc_rpmvers}
738License:        GPL
739
740Requires:       i586-pc-freebsd8.0-gcc = %{gcc_rpmvers}-%{release}
741Requires:       i586-pc-freebsd8.0-gcc-libobjc = %{gcc_rpmvers}-%{release}
742
743%description -n i586-pc-freebsd8.0-gcc-objc
744GCC objc compiler for i586-pc-freebsd8.0.
745
746%files -n i586-pc-freebsd8.0-gcc-objc
747%defattr(-,root,root)
748%dir %{_libexecdir}/gcc
749%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0
750%dir %{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
751%{_libexecdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/cc1obj%{_exeext}
752
753# ==============================================================
754# i586-pc-freebsd8.0-gcc-libobjc
755# ==============================================================
756%package -n i586-pc-freebsd8.0-gcc-libobjc
757Summary:        Objective C support for i586-pc-freebsd8.0-gcc
758Group:          Development/Tools
759Version:        %{gcc_rpmvers}
760%{?_with_noarch_subpackages:BuildArch: noarch}
761License:        GPL
762
763%description -n i586-pc-freebsd8.0-gcc-libobjc
764Support libraries for GCC's objc compiler for i586-pc-freebsd8.0.
765
766%files -n i586-pc-freebsd8.0-gcc-libobjc -f build/files.objc
767%defattr(-,root,root)
768%dir %{_gcclibdir}/gcc
769%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0
770%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}
771%dir %{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include
772%{_gcclibdir}/gcc/i586-pc-freebsd8.0/%{gcc_version}/include/objc
773
Note: See TracBrowser for help on using the repository browser.