source: rtems/contrib/crossrpms/freebsd7.2/i586/i586-pc-freebsd7.2-gcc.spec @ 062927e

4.104.115
Last change on this file since 062927e was 062927e, checked in by Ralf Corsepius <ralf.corsepius@…>, on 04/15/10 at 16:45:48

gcc-4.5.0

  • Property mode set to 100644
File size: 21.5 KB
RevLine 
[307cbcb5]1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6
7%ifos cygwin cygwin32 mingw mingw32
8%define _exeext .exe
9%define debug_package           %{nil}
10%define _libdir                 %{_exec_prefix}/lib
11%else
12%define _exeext %{nil}
13%endif
14
15%ifos cygwin cygwin32
16%define optflags -O3 -pipe -march=i486 -funroll-loops
17%endif
18
19%ifos mingw mingw32
20%if %{defined _mingw32_cflags}
21%define optflags %{_mingw32_cflags}
22%else
23%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
24%endif
25%endif
26
27%if "%{_build}" != "%{_host}"
28%define _host_rpmprefix %{_host}-
29%else
30%define _host_rpmprefix %{nil}
31%endif
32
33
[062927e]34%define gcc_pkgvers 4.5.0
35%define gcc_version 4.5.0
36%define gcc_rpmvers %{expand:%(echo "4.5.0" | tr - _ )}
[307cbcb5]37
38
39Name:           i586-pc-freebsd7.2-gcc
40Summary:        i586-pc-freebsd7.2 gcc
41
42Group:          Development/Tools
43Version:        %{gcc_rpmvers}
[062927e]44Release:        0.20100415.1%{?dist}
[307cbcb5]45License:        GPL
46URL:            http://gcc.gnu.org
47BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49%define _use_internal_dependency_generator 0
50
51BuildRequires:  %{_host_rpmprefix}gcc
52
[062927e]53# FIXME: Disable lto for now, to avoid dependencies on libelf
54%bcond_with lto
55
56# FIXME: Disamble python gdb scripts
57# ATM, no idea how to package them
58%bcond_with pygdb
59
60# FIXME: Disable GCC-plugin
61# Bug in gcc-4.5-20100318, doesn't build them on x86_84 hosts.
62%bcond_with plugin
63
64# versions of libraries, we conditionally bundle if necessary
65%global mpc_version     0.8.1
66%global mpfr_version    2.4.1
67%global gmp_version     4.3.2
68%global libelf_version  0.8.13
69
70# versions of libraries these distros are known to ship
71%if 0%{?fc13}
72%global mpc_provided 0.8.1
73%global mpfr_provided 2.4.1
74%global gmp_provided 4.3.1
[307cbcb5]75%endif
[062927e]76
77%if 0%{?fc12}
78%global mpc_provided 0.8
79%global mpfr_provided 2.4.1
80%global gmp_provided 4.3.1
[307cbcb5]81%endif
82
[062927e]83%if 0%{?fc11}
84%global mpc_provided %{nil}
85%global mpfr_provided 2.4.1
86%global gmp_provided 4.2.4
[307cbcb5]87%endif
[062927e]88
89%if 0%{?rhel5}
90%global mpc_provided %{nil}
91%global mpfr_provided %{nil}
92%global gmp_provided 4.1.4
[307cbcb5]93%endif
94
[062927e]95%if 0%{?suse11_0}
96%global mpc_provided %{nil}
97%global mpfr_provided 2.3.1
98%global gmp_provided 4.2.2
[e2b68fc1]99%endif
100
[062927e]101%if 0%{?suse11_1}
102%global mpc_provided %{nil}
103%global mpfr_provided 2.3.2
104%global gmp_provided 4.2.3
105%endif
106
107%if 0%{?suse11_2}
108%global mpc_provided 0.7
109%global mpfr_provided 2.4.1
110%global gmp_provided 4.3.1
111%endif
112
113%if 0%{?cygwin}
114%global mpc_provided 0.8
115%global mpfr_provided 2.4.1
116%global gmp_provided 4.3.1
117%endif
118
119%if 0%{?mingw32}
120%global mpc_provided 0.8.1
121%global mpfr_provided 2.4.1
122%global gmp_provided 4.3.2
[e2b68fc1]123%endif
[307cbcb5]124
125%if "%{gcc_version}" >= "4.2.0"
[062927e]126%define gmp_required            4.1
127%define mpfr_required           2.2.1
[307cbcb5]128%endif
[062927e]129
130%if "%{gcc_version}" >= "4.3.0"
131%define gmp_required            4.1
132%define mpfr_required           2.3.1
[307cbcb5]133%endif
[062927e]134
135%if "%{gcc_version}" >= "4.3.3"
136%define cloog_required          0.15
[307cbcb5]137%endif
138
[062927e]139%if "%{gcc_version}" >= "4.4.0"
140%define mpfr_required           2.3.2
141%endif
[307cbcb5]142
[062927e]143%if "%{gcc_version}" >= "4.5.0"
144%define mpc_required            0.8
145%if %{with lto}
146%define libelf_required         0.8.12
147%endif
148%endif
149
150%if %{defined mpc_required}
151%if "%{mpc_provided}" >= "%{mpc_required}"
152%{?fedora:BuildRequires: libmpc-devel >= %{mpc_required}}
153%{?suse:BuildRequires: mpc-devel >= %{mpc_required}}
154%if "%{_build}" != "%{_host}"
155BuildRequires:  %{_host_rpmprefix}mpc-devel >= %{mpc_required}
156%endif
157%else
158%define _build_mpc 1
159%endif
160%endif
161
162%if %{defined gmp_required}
163%if "%{gmp_provided}" >= "%{gmp_required}"
164BuildRequires: gmp-devel >= %{gmp_required}
165%if "%{_build}" != "%{_host}"
166BuildRequires:  %{_host_rpmprefix}gmp-devel >= %{gmp_required}
167%endif
[307cbcb5]168%else
[062927e]169%define _build_gmp 1
170%endif
171%endif
172
173%if %{defined libelf_required}
174%if "%{libelf_provided}" >= "%{libelf_required}"
175BuildRequires: libelf-devel >= %{libelf_required}
[307cbcb5]176%if "%{_build}" != "%{_host}"
[062927e]177BuildRequires:  %{_host_rpmprefix}libelf-devel >= %{libelf_required}
178%endif
[307cbcb5]179%else
[062927e]180%define _build_libelf 1
[307cbcb5]181%endif
182%endif
[062927e]183
184
185%if %{defined cloog_required}
186%{?fc11:BuildRequires: cloog-ppl-devel >= %cloog_required}
187%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
188%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
189%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
190%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
191%endif
192
193
194%if %{defined mpfr_required}
195%if "%{mpfr_provided}" >= "%{mpfr_required}"
196BuildRequires: mpfr-devel >= %{mpfr_required}
197%if "%{_build}" != "%{_host}"
198BuildRequires:  %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
199%endif
[307cbcb5]200%else
201%define _build_mpfr 1
202%endif
203%endif
204
205%if "%{_build}" != "%{_host}"
206BuildRequires:  i586-pc-freebsd7.2-gcc = %{gcc_rpmvers}
207%endif
208
209%if "%{gcc_version}" >= "4.2.0"
210BuildRequires:  flex bison
211%endif
212
213
214BuildRequires:  texinfo >= 4.2
215BuildRequires:  i586-pc-freebsd7.2-binutils
216BuildRequires:  i586-pc-freebsd7.2-sys-root
217
218Requires:       i586-pc-freebsd7.2-binutils
219Requires:       i586-pc-freebsd7.2-sys-root
[55e45f8d]220Requires:       i586-pc-freebsd7.2-gcc-libgcc = %{gcc_rpmvers}-%{release}
[307cbcb5]221
[062927e]222%if "%{gcc_version}" >= "4.5.0"
223BuildRequires:  zlib-devel
224%if "%{_build}" != "%{_host}"
225BuildRequires:  %{_host_rpmprefix}zlib-devel
226%endif
227%else
228%endif
[307cbcb5]229
[062927e]230%global _gcclibdir %{_prefix}/lib
[307cbcb5]231
232Source0:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-core-%{gcc_pkgvers}.tar.bz2
233%{?_without_sources:NoSource:   0}
234
235Source1:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-g++-%{gcc_pkgvers}.tar.bz2
236%{?_without_sources:NoSource:   1}
237
238Source2:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-fortran-%{gcc_pkgvers}.tar.bz2
239%{?_without_sources:NoSource:   2}
240
241Source5:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-objc-%{gcc_pkgvers}.tar.bz2
242%{?_without_sources:NoSource:   5}
243
[062927e]244%if 0%{?_build_mpfr}
[307cbcb5]245Source60:    http://www.mpfr.org/mpfr-current/mpfr-%{mpfr_version}.tar.bz2
246%endif
247
[062927e]248%if 0%{?_build_mpc}
249Source61:    http://www.multiprecision.org/mpc/download/mpc-%{mpc_version}.tar.gz
250%endif
251
252%if 0%{?_build_gmp}
253Source62:    ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
254%endif
255
256%if 0%{?_build_libelf}
257Source63:    http://www.mr511.de/software/libelf-%{libelf_version}.tar.gz
258%endif
259
[307cbcb5]260%description
261Cross gcc for i586-pc-freebsd7.2.
262
263%prep
264%setup -c -T -n %{name}-%{version}
265
266%setup -q -T -D -n %{name}-%{version} -a0
[062927e]267cd gcc-%{gcc_pkgvers}
268%{?PATCH0:%patch0 -p1}
269cd ..
[307cbcb5]270
271%setup -q -T -D -n %{name}-%{version} -a1
[062927e]272cd gcc-%{gcc_pkgvers}
273%{?PATCH1:%patch1 -p1}
274cd ..
[307cbcb5]275
276%setup -q -T -D -n %{name}-%{version} -a2
277%{?PATCH2:%patch2 -p0}
278
279
280
281%setup -q -T -D -n %{name}-%{version} -a5
282%{?PATCH5:%patch5 -p0}
283
284
285%if 0%{?_build_mpfr}
286%setup -q -T -D -n %{name}-%{version} -a60
287%{?PATCH60:%patch60 -p1}
288  # Build mpfr one-tree style
289  ln -s ../mpfr-%{mpfr_version} gcc-%{gcc_pkgvers}/mpfr
290%endif
291
[062927e]292%if 0%{?_build_mpc}
293%setup -q -T -D -n %{name}-%{version} -a61
294%{?PATCH61:%patch61 -p1}
295  # Build mpc one-tree style
296  ln -s ../mpc-%{mpc_version} gcc-%{gcc_pkgvers}/mpc
297%endif
298
299%if 0%{?_build_gmp}
300%setup -q -T -D -n %{name}-%{version} -a62
301%{?PATCH62:%patch62 -p1}
302  # Build gmp one-tree style
303  ln -s ../gmp-%{gmp_version} gcc-%{gcc_pkgvers}/gmp
304%endif
305
306%if 0%{?_build_libelf}
307%setup -q -T -D -n %{name}-%{version} -a63
308%{?PATCH63:%patch63 -p1}
309  # Build libelf one-tree style
310  ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
311%endif
312
[307cbcb5]313
314  # Fix timestamps
315  cd gcc-%{gcc_pkgvers}
316  contrib/gcc_update --touch
317  cd ..
318%build
319  mkdir -p build
320
321  cd build
322
323  languages="c"
324  languages="$languages,c++"
[79e55c5]325  languages="$languages,fortran"
[307cbcb5]326  languages="$languages,objc"
327%if "%{_build}" != "%{_host}"
328  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
329  CC="%{_host}-gcc ${RPM_OPT_FLAGS}" \
330%else
331# gcc is not ready to be compiled with -std=gnu99
332  CC=$(echo "%{__cc} ${RPM_OPT_FLAGS}" | sed -e 's,-std=gnu99 ,,') \
333%endif
334  ../gcc-%{gcc_pkgvers}/configure \
335    --prefix=%{_prefix} \
336    --bindir=%{_bindir} \
337    --exec_prefix=%{_exec_prefix} \
338    --includedir=%{_includedir} \
[79e55c5]339    --libdir=%{_gcclibdir} \
[307cbcb5]340    --libexecdir=%{_libexecdir} \
341    --mandir=%{_mandir} \
342    --infodir=%{_infodir} \
343    --datadir=%{_datadir} \
344    --build=%_build --host=%_host \
345    --target=i586-pc-freebsd7.2 \
346    --disable-libstdcxx-pch \
347    --with-gnu-as --with-gnu-ld --verbose \
348    --with-system-zlib \
349    --disable-nls --without-included-gettext \
350    --disable-win32-registry \
351    --enable-version-specific-runtime-libs \
352    --enable-threads \
353    --with-sysroot=%{_exec_prefix}/i586-pc-freebsd7.2/sys-root \
[062927e]354    %{?with_lto:--enable-lto}%{!?with_lto:--disable-lto} \
355    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
[307cbcb5]356    --enable-languages="$languages" $optargs
357
358%if "%_host" != "%_build"
359  # Bug in gcc-3.2.1:
360  # Somehow, gcc doesn't get syslimits.h right for Cdn-Xs
361  mkdir -p gcc/include
362  cp ../gcc-%{gcc_pkgvers}/gcc/gsyslimits.h gcc/include/syslimits.h
363%endif
364
365  make %{?_smp_mflags} all
366  cd ..
367
368%install
369  rm -rf $RPM_BUILD_ROOT
370
371  cd build
372
373  make DESTDIR=$RPM_BUILD_ROOT install
374  cd ..
375
376
377%if "%{gcc_version}" <= "4.1.2"
378# Misplaced header file
379  if test -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h; then
380    mv $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h \
[79e55c5]381      $RPM_BUILD_ROOT%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include/
[307cbcb5]382  fi
383%endif
384
385  # host library
[79e55c5]386%if "%{gcc_version}" >= "4.2.0"
387  # libiberty doesn't honor --libdir, but always installs to a
388  # magically guessed _libdir
[307cbcb5]389  rm -f  ${RPM_BUILD_ROOT}%{_libdir}/libiberty.a
[79e55c5]390%else
391  # libiberty installs to --libdir=...
392  rm -f ${RPM_BUILD_ROOT}%{_gcclibdir}/libiberty.a
393%endif
[307cbcb5]394
395  # We use the version from binutils
396  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd7.2-c++filt%{_exeext}
397
398
399# Conflict with a native GCC's infos
400  rm -rf $RPM_BUILD_ROOT%{_infodir}
401
402# Conflict with a native GCC's man pages
403  rm -rf $RPM_BUILD_ROOT%{_mandir}/man7
404
405  # Bug in gcc-3.4.0pre
406  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd7.2-i586-pc-freebsd7.2-gcjh%{_exeext}
407
408  # Bug in gcc-3.3.x/gcc-3.4.x: Despite we don't need fixincludes, it installs
409  # the fixinclude-install-tools
[79e55c5]410  rm -rf ${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/install-tools
411  rm -rf ${RPM_BUILD_ROOT}%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/install-tools
[307cbcb5]412
413  # Bug in gcc > 4.1.0: Installs an unused, empty directory
414  if test -d ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd7.2/include/bits; then
415    rmdir ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd7.2/include/bits
416  fi
417
[062927e]418  # gcc >= 4.5.0: installs weird libstdc++ python bindings.
419%if ! %{with pygdb}
420  if test -d ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python; then
421    rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python/libstdcxx
422  fi
423%endif
424
[307cbcb5]425  # Collect multilib subdirectories
[55e45f8d]426  multilibs=`build/gcc/xgcc -Bbuild/gcc/ --print-multi-lib | sed -e 's,;.*$,,'`
[307cbcb5]427
428
429  rm -f dirs ;
430  echo "%defattr(-,root,root,-)" >> dirs
[79e55c5]431  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}"
[55e45f8d]432  for i in $multilibs; do
[307cbcb5]433    case $i in
[7fde8d5]434    \.) ;; # ignore, handled elsewhere
[307cbcb5]435    *)  echo "%dir ${TGTDIR}/$i" >> dirs
436      ;;
437    esac
438  done
439
440  # Collect files to go into different packages
441  cp dirs build/files.gcc
442  cp dirs build/files.gfortran
443  cp dirs build/files.objc
444  cp dirs build/files.gcj
445  cp dirs build/files.g++
446
[79e55c5]447  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}"
[307cbcb5]448  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
449  for i in $f; do
450    case $i in
451    *lib*.la) rm ${RPM_BUILD_ROOT}/$i ;; # ignore: gcc produces bogus libtool libs
452    *f771) ;;
453    *f951) ;;
454    *cc1) ;;
455    *cc1obj) ;;
456    *cc1plus) ;; # ignore: explicitly put into rpm elsewhere
457    *collect2) ;;
458    *libobjc*) echo "$i" >> build/files.objc ;;
459    *include/objc*) ;;
460    *include/g++*);;
461    *include/c++*);;
[55e45f8d]462    *include-fixed/*);;
[79e55c5]463    *finclude/*);;
[307cbcb5]464    *adainclude*);;
465    *adalib*);;
466    *gnat1);;
467    *jc1) ;;
468    *jvgenmain) ;;
469    */libgfortran*.*) echo "$i" >> build/files.gfortran ;;
[062927e]470    %{!?with_pygdb:*/libstdc++*gdb.py*) rm ${RPM_BUILD_ROOT}/$i ;;} # ignore for now
471    %{?with_pygdb:*/libstdc++*gdb.py*) >> build/files.g++ ;;}
[307cbcb5]472    */libstdc++.*) echo "$i" >> build/files.g++ ;;
473    */libsupc++.*) echo "$i" >> build/files.g++ ;;
474    *) echo "$i" >> build/files.gcc ;;
475    esac
476  done
477
478  TGTDIR="%{_exec_prefix}/i586-pc-freebsd7.2/lib"
479  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
480  for i in $f; do
481    case $i in
482    *lib*.la) rm ${RPM_BUILD_ROOT}/$i;; # ignore - gcc produces bogus libtool libs
483    *libiberty.a) rm ${RPM_BUILD_ROOT}/$i ;; # ignore - GPL'ed
484# all other files belong to newlib
485    *) echo "$i" >> build/files.newlib ;;
486    esac
487  done
488# Extract %%__os_install_post into os_install_post~
489cat << \EOF > os_install_post~
490%__os_install_post
491EOF
492
493# Generate customized brp-*scripts
494cat os_install_post~ | while read a x y; do
495case $a in
496# Prevent brp-strip* from trying to handle foreign binaries
497*/brp-strip*)
498  b=$(basename $a)
499  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
500  chmod a+x $b
501  ;;
502esac
503done
504
505sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
506< os_install_post~ > os_install_post
507%define __os_install_post . ./os_install_post
508
509
510cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
511#!/bin/sh
512grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd7.2/(lib|include|sys-root)' \
[79e55c5]513  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd7.2/'} | %__find_provides
[307cbcb5]514EOF
515chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
516%define __find_provides %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
517
518cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
519#!/bin/sh
520grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd7.2/(lib|include|sys-root)' \
[79e55c5]521  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd7.2/'} | %__find_requires
[307cbcb5]522EOF
523chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
524%define __find_requires %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
525
526%ifnarch noarch
527# Extract %%__debug_install_post into debug_install_post~
528cat << \EOF > debug_install_post~
529%__debug_install_post
530EOF
531
532# Generate customized debug_install_post script
533cat debug_install_post~ | while read a x y; do
534case $a in
535# Prevent find-debuginfo.sh* from trying to handle foreign binaries
536*/find-debuginfo.sh)
537  b=$(basename $a)
538  sed -e 's,find "$RPM_BUILD_ROOT" !,find "$RPM_BUILD_ROOT"%_bindir "$RPM_BUILD_ROOT"%_libexecdir !,' $a > $b
539  chmod a+x $b
540  ;;
541esac
542done
543
544sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
545< debug_install_post~ > debug_install_post
546%define __debug_install_post . ./debug_install_post
547
548%endif
549
550%clean
551  rm -rf $RPM_BUILD_ROOT
552
553# ==============================================================
554# i586-pc-freebsd7.2-gcc
555# ==============================================================
556# %package -n i586-pc-freebsd7.2-gcc
557# Summary:        GNU cc compiler for i586-pc-freebsd7.2
558# Group:          Development/Tools
559# Version:        %{gcc_rpmvers}
560# Requires:       i586-pc-freebsd7.2-binutils
561# License:      GPL
562
563# %if %build_infos
564# Requires:      gcc-common
565# %endif
566
567%description -n i586-pc-freebsd7.2-gcc
568GNU cc compiler for i586-pc-freebsd7.2.
569
[55e45f8d]570# ==============================================================
571# i586-pc-freebsd7.2-gcc-libgcc
572# ==============================================================
573%package -n i586-pc-freebsd7.2-gcc-libgcc
574Summary:        libgcc for i586-pc-freebsd7.2-gcc
575Group:          Development/Tools
576Version:        %{gcc_rpmvers}
577%{?_with_noarch_subpackages:BuildArch: noarch}
578License:        GPL
579
580%description -n i586-pc-freebsd7.2-gcc-libgcc
581libgcc i586-pc-freebsd7.2-gcc.
582
583
584%files -n i586-pc-freebsd7.2-gcc
[307cbcb5]585%defattr(-,root,root)
[55e45f8d]586
[307cbcb5]587%{_mandir}/man1/i586-pc-freebsd7.2-gcc.1*
588%{_mandir}/man1/i586-pc-freebsd7.2-cpp.1*
589%{_mandir}/man1/i586-pc-freebsd7.2-gcov.1*
590
591%{_bindir}/i586-pc-freebsd7.2-cpp%{_exeext}
592%{_bindir}/i586-pc-freebsd7.2-gcc%{_exeext}
593%{_bindir}/i586-pc-freebsd7.2-gcc-%{gcc_version}%{_exeext}
594%{_bindir}/i586-pc-freebsd7.2-gcov%{_exeext}
595%{_bindir}/i586-pc-freebsd7.2-gccbug
596
[55e45f8d]597%dir %{_libexecdir}/gcc
598%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2
599%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
600%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/cc1%{_exeext}
601%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/collect2%{_exeext}
[062927e]602%if "%{gcc_version}" >= "4.5.0"
603%{?with_lto:%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/lto%{_exeext}}
604%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/lto-wrapper%{_exeext}
605%endif
[55e45f8d]606
607%files -n i586-pc-freebsd7.2-gcc-libgcc -f build/files.gcc
608%defattr(-,root,root)
609%dir %{_gcclibdir}/gcc
610%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2
611%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
[79e55c5]612%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include
[55e45f8d]613
[307cbcb5]614%if "%{gcc_version}" > "4.0.3"
[79e55c5]615%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include/ssp
[307cbcb5]616%endif
617
618%if "%{gcc_version}" >= "4.3.0"
[55e45f8d]619%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include-fixed
[307cbcb5]620%endif
621
622# ==============================================================
623# i586-pc-freebsd7.2-gcc-c++
624# ==============================================================
625%package -n i586-pc-freebsd7.2-gcc-c++
626Summary:        GCC c++ compiler for i586-pc-freebsd7.2
627Group:          Development/Tools
628Version:        %{gcc_rpmvers}
629License:        GPL
[55e45f8d]630Requires:       i586-pc-freebsd7.2-gcc-libstdc++ = %{gcc_rpmvers}-%{release}
[307cbcb5]631
632%if "%{_build}" != "%{_host}"
633BuildRequires:  i586-pc-freebsd7.2-gcc-c++ = %{gcc_rpmvers}
634%endif
635
636Requires:       i586-pc-freebsd7.2-gcc = %{gcc_rpmvers}-%{release}
637
638%description -n i586-pc-freebsd7.2-gcc-c++
639GCC c++ compiler for i586-pc-freebsd7.2.
640
[55e45f8d]641
642%package -n i586-pc-freebsd7.2-gcc-libstdc++
643Summary:        libstdc++ for i586-pc-freebsd7.2
644Group:          Development/Tools
645Version:        %{gcc_rpmvers}
646%{?_with_noarch_subpackages:BuildArch: noarch}
647License:        GPL
648
649%description -n i586-pc-freebsd7.2-gcc-libstdc++
[e2b68fc1]650%{summary}
[55e45f8d]651
652
653%files -n i586-pc-freebsd7.2-gcc-c++
[307cbcb5]654%defattr(-,root,root)
[55e45f8d]655
[307cbcb5]656%{_mandir}/man1/i586-pc-freebsd7.2-g++.1*
657
658%{_bindir}/i586-pc-freebsd7.2-c++%{_exeext}
659%{_bindir}/i586-pc-freebsd7.2-g++%{_exeext}
660
[79e55c5]661%dir %{_libexecdir}/gcc
662%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2
663%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
664%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/cc1plus%{_exeext}
[307cbcb5]665
[55e45f8d]666
667%files -n i586-pc-freebsd7.2-gcc-libstdc++ -f build/files.g++
668%defattr(-,root,root)
669%dir %{_gcclibdir}/gcc
670%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2
671%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
[79e55c5]672%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include
673%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include/c++
[307cbcb5]674
675# ==============================================================
676# i586-pc-freebsd7.2-gcc-gfortran
677# ==============================================================
678%package -n i586-pc-freebsd7.2-gcc-gfortran
679Summary:        Fortran 95 support for i586-pc-freebsd7.2-gcc
680Group:          Development/Tools
681Version:        %{gcc_rpmvers}
682License:        GPL
683
684Requires:       i586-pc-freebsd7.2-gcc = %{gcc_rpmvers}-%{release}
[55e45f8d]685Requires:       i586-pc-freebsd7.2-gcc-libgfortran = %{gcc_rpmvers}-%{release}
[307cbcb5]686
687%description -n i586-pc-freebsd7.2-gcc-gfortran
688GCC fortran compiler for i586-pc-freebsd7.2.
689
[55e45f8d]690%files -n i586-pc-freebsd7.2-gcc-gfortran
[307cbcb5]691%defattr(-,root,root)
692%{_bindir}/i586-pc-freebsd7.2-gfortran%{_exeext}
693
694%{_mandir}/man1/i586-pc-freebsd7.2-gfortran.1*
695
[79e55c5]696%dir %{_libexecdir}/gcc
697%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2
698%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
699%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/f951%{_exeext}
700
[55e45f8d]701# ==============================================================
702# i586-pc-freebsd7.2-gcc-libgfortran
703# ==============================================================
704%package -n i586-pc-freebsd7.2-gcc-libgfortran
705Summary:        Fortran 95 support libraries for i586-pc-freebsd7.2-gcc
706Group:          Development/Tools
707Version:        %{gcc_rpmvers}
708%{?_with_noarch_subpackages:BuildArch: noarch}
709License:        GPL
710
711%description -n i586-pc-freebsd7.2-gcc-libgfortran
[e2b68fc1]712%{summary}
[55e45f8d]713
714%files -n i586-pc-freebsd7.2-gcc-libgfortran -f build/files.gfortran
715%defattr(-,root,root)
716%dir %{_gcclibdir}/gcc
717%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2
718%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
[79e55c5]719%if "%{gcc_version}" >= "4.2.0"
720%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/finclude
721%endif
[307cbcb5]722
723# ==============================================================
724# i586-pc-freebsd7.2-gcc-objc
725# ==============================================================
726%package -n i586-pc-freebsd7.2-gcc-objc
727Summary:        Objective C support for i586-pc-freebsd7.2-gcc
728Group:          Development/Tools
729Version:        %{gcc_rpmvers}
730License:        GPL
731
732Requires:       i586-pc-freebsd7.2-gcc = %{gcc_rpmvers}-%{release}
[55e45f8d]733Requires:       i586-pc-freebsd7.2-gcc-libobjc = %{gcc_rpmvers}-%{release}
[307cbcb5]734
735%description -n i586-pc-freebsd7.2-gcc-objc
736GCC objc compiler for i586-pc-freebsd7.2.
737
[55e45f8d]738%files -n i586-pc-freebsd7.2-gcc-objc
[307cbcb5]739%defattr(-,root,root)
[79e55c5]740%dir %{_libexecdir}/gcc
741%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2
742%dir %{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
743%{_libexecdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/cc1obj%{_exeext}
[307cbcb5]744
[55e45f8d]745# ==============================================================
746# i586-pc-freebsd7.2-gcc-libobjc
747# ==============================================================
748%package -n i586-pc-freebsd7.2-gcc-libobjc
749Summary:        Objective C support for i586-pc-freebsd7.2-gcc
750Group:          Development/Tools
751Version:        %{gcc_rpmvers}
752%{?_with_noarch_subpackages:BuildArch: noarch}
753License:        GPL
754
755%description -n i586-pc-freebsd7.2-gcc-libobjc
756Support libraries for GCC's objc compiler for i586-pc-freebsd7.2.
757
758%files -n i586-pc-freebsd7.2-gcc-libobjc -f build/files.objc
759%defattr(-,root,root)
760%dir %{_gcclibdir}/gcc
761%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2
762%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}
763%dir %{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include
[79e55c5]764%{_gcclibdir}/gcc/i586-pc-freebsd7.2/%{gcc_version}/include/objc
[307cbcb5]765
Note: See TracBrowser for help on using the repository browser.