source: rtems/contrib/crossrpms/freebsd6.4/i586/i586-pc-freebsd6.4-gcc.spec @ 8a2e9181

4.104.115
Last change on this file since 8a2e9181 was 8a2e9181, checked in by Ralf Corsepius <ralf.corsepius@…>, on 04/24/10 at 14:05:52

Regenerate.

  • Property mode set to 100644
File size: 21.7 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6
7%ifos cygwin cygwin32 mingw mingw32
8%define _exeext .exe
9%define debug_package           %{nil}
10%define _libdir                 %{_exec_prefix}/lib
11%else
12%define _exeext %{nil}
13%endif
14
15%ifos cygwin cygwin32
16%define optflags -O3 -pipe -march=i486 -funroll-loops
17%endif
18
19%ifos mingw mingw32
20%if %{defined _mingw32_cflags}
21%define optflags %{_mingw32_cflags}
22%else
23%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
24%endif
25%endif
26
27%if "%{_build}" != "%{_host}"
28%define _host_rpmprefix %{_host}-
29%else
30%define _host_rpmprefix %{nil}
31%endif
32
33
34%define gcc_pkgvers 4.5.0
35%define gcc_version 4.5.0
36%define gcc_rpmvers %{expand:%(echo "4.5.0" | tr - _ )}
37
38
39Name:           i586-pc-freebsd6.4-gcc
40Summary:        i586-pc-freebsd6.4 gcc
41
42Group:          Development/Tools
43Version:        %{gcc_rpmvers}
44Release:        0.20100424.0%{?dist}
45License:        GPL
46URL:            http://gcc.gnu.org
47BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49%define _use_internal_dependency_generator 0
50
51BuildRequires:  %{_host_rpmprefix}gcc
52
53# FIXME: Disable lto for now, to avoid dependencies on libelf
54%bcond_with lto
55
56# FIXME: Disable python gdb scripts
57# ATM, no idea how to package them
58%bcond_with pygdb
59
60# FIXME: Disable GCC-plugin
61# Bug in gcc-4.5-20100318, doesn't build them on x86_84 hosts.
62%bcond_with plugin
63
64# versions of libraries, we conditionally bundle if necessary
65%global mpc_version     0.8.1
66%global mpfr_version    2.4.1
67%global gmp_version     4.3.2
68%global libelf_version  0.8.13
69
70# versions of libraries these distros are known to ship
71%if 0%{?fc13}
72%global mpc_provided 0.8.1
73%global mpfr_provided 2.4.1
74%global gmp_provided 4.3.1
75%endif
76
77%if 0%{?fc12}
78%global mpc_provided 0.8
79%global mpfr_provided 2.4.1
80%global gmp_provided 4.3.1
81%endif
82
83%if 0%{?fc11}
84%global mpc_provided %{nil}
85%global mpfr_provided 2.4.1
86%global gmp_provided 4.2.4
87%endif
88
89%if 0%{?el6}
90%global mpc_provided %{nil}
91# el6 beta ships mpfr but mpfr-devel is missing
92%global mpfr_provided %{nil}
93%global gmp_provided 4.3.1
94%endif
95
96%if 0%{?el5}
97%global mpc_provided %{nil}
98%global mpfr_provided %{nil}
99%global gmp_provided 4.1.4
100%endif
101
102%if 0%{?suse11_0}
103%global mpc_provided %{nil}
104%global mpfr_provided 2.3.1
105%global gmp_provided 4.2.2
106%endif
107
108%if 0%{?suse11_1}
109%global mpc_provided %{nil}
110%global mpfr_provided 2.3.2
111%global gmp_provided 4.2.3
112%endif
113
114%if 0%{?suse11_2}
115%global mpc_provided 0.7
116%global mpfr_provided 2.4.1
117%global gmp_provided 4.3.1
118%endif
119
120%if 0%{?cygwin}
121%global mpc_provided 0.8
122%global mpfr_provided 2.4.1
123%global gmp_provided 4.3.1
124%endif
125
126%if 0%{?mingw32}
127%global mpc_provided 0.8.1
128%global mpfr_provided 2.4.1
129%global gmp_provided 4.3.2
130%endif
131
132%if "%{gcc_version}" >= "4.2.0"
133%define gmp_required            4.1
134%define mpfr_required           2.2.1
135%endif
136
137%if "%{gcc_version}" >= "4.3.0"
138%define gmp_required            4.1
139%define mpfr_required           2.3.1
140%endif
141
142%if "%{gcc_version}" >= "4.3.3"
143%define cloog_required          0.15
144%endif
145
146%if "%{gcc_version}" >= "4.4.0"
147%define mpfr_required           2.3.2
148%endif
149
150%if "%{gcc_version}" >= "4.5.0"
151%define mpc_required            0.8
152%if %{with lto}
153%define libelf_required         0.8.12
154%endif
155%endif
156
157%if %{defined mpc_required}
158%if "%{mpc_provided}" >= "%{mpc_required}"
159%{?fedora:BuildRequires: libmpc-devel >= %{mpc_required}}
160%{?suse:BuildRequires: mpc-devel >= %{mpc_required}}
161%if "%{_build}" != "%{_host}"
162BuildRequires:  %{_host_rpmprefix}mpc-devel >= %{mpc_required}
163%endif
164%else
165%define _build_mpc 1
166%define gmp_required            4.2
167%endif
168%endif
169
170%if %{defined gmp_required}
171%if "%{gmp_provided}" >= "%{gmp_required}"
172BuildRequires: gmp-devel >= %{gmp_required}
173%if "%{_build}" != "%{_host}"
174BuildRequires:  %{_host_rpmprefix}gmp-devel >= %{gmp_required}
175%endif
176%else
177%define _build_gmp 1
178%endif
179%endif
180
181%if %{defined libelf_required}
182%if "%{libelf_provided}" >= "%{libelf_required}"
183BuildRequires: libelf-devel >= %{libelf_required}
184%if "%{_build}" != "%{_host}"
185BuildRequires:  %{_host_rpmprefix}libelf-devel >= %{libelf_required}
186%endif
187%else
188%define _build_libelf 1
189%endif
190%endif
191
192
193%if %{defined cloog_required}
194%{?fc11:BuildRequires: cloog-ppl-devel >= %cloog_required}
195%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
196%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
197# el6 ships cloog-ppl, but cloog-ppl-devel is missing
198%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
199%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
200%endif
201
202
203%if %{defined mpfr_required}
204%if "%{mpfr_provided}" >= "%{mpfr_required}"
205BuildRequires: mpfr-devel >= %{mpfr_required}
206%if "%{_build}" != "%{_host}"
207BuildRequires:  %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
208%endif
209%else
210%define _build_mpfr 1
211%endif
212%endif
213
214%if "%{_build}" != "%{_host}"
215BuildRequires:  i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}
216%endif
217
218%if "%{gcc_version}" >= "4.2.0"
219BuildRequires:  flex bison
220%endif
221
222
223BuildRequires:  texinfo >= 4.2
224BuildRequires:  i586-pc-freebsd6.4-binutils
225BuildRequires:  i586-pc-freebsd6.4-sys-root
226
227Requires:       i586-pc-freebsd6.4-binutils
228Requires:       i586-pc-freebsd6.4-sys-root
229Requires:       i586-pc-freebsd6.4-gcc-libgcc = %{gcc_rpmvers}-%{release}
230
231%if "%{gcc_version}" >= "4.5.0"
232BuildRequires:  zlib-devel
233%if "%{_build}" != "%{_host}"
234BuildRequires:  %{_host_rpmprefix}zlib-devel
235%endif
236%else
237%endif
238
239%global _gcclibdir %{_prefix}/lib
240
241Source0:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-core-%{gcc_pkgvers}.tar.bz2
242%{?_without_sources:NoSource:   0}
243
244Source1:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-g++-%{gcc_pkgvers}.tar.bz2
245%{?_without_sources:NoSource:   1}
246
247Source2:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-fortran-%{gcc_pkgvers}.tar.bz2
248%{?_without_sources:NoSource:   2}
249
250Source5:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-objc-%{gcc_pkgvers}.tar.bz2
251%{?_without_sources:NoSource:   5}
252
253%if 0%{?_build_mpfr}
254Source60:    http://www.mpfr.org/mpfr-current/mpfr-%{mpfr_version}.tar.bz2
255%endif
256
257%if 0%{?_build_mpc}
258Source61:    http://www.multiprecision.org/mpc/download/mpc-%{mpc_version}.tar.gz
259%endif
260
261%if 0%{?_build_gmp}
262Source62:    ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
263%endif
264
265%if 0%{?_build_libelf}
266Source63:    http://www.mr511.de/software/libelf-%{libelf_version}.tar.gz
267%endif
268
269%description
270Cross gcc for i586-pc-freebsd6.4.
271
272%prep
273%setup -c -T -n %{name}-%{version}
274
275%setup -q -T -D -n %{name}-%{version} -a0
276cd gcc-%{gcc_pkgvers}
277%{?PATCH0:%patch0 -p1}
278cd ..
279
280%setup -q -T -D -n %{name}-%{version} -a1
281cd gcc-%{gcc_pkgvers}
282%{?PATCH1:%patch1 -p1}
283cd ..
284
285%setup -q -T -D -n %{name}-%{version} -a2
286%{?PATCH2:%patch2 -p0}
287
288
289
290%setup -q -T -D -n %{name}-%{version} -a5
291%{?PATCH5:%patch5 -p0}
292
293
294%if 0%{?_build_mpfr}
295%setup -q -T -D -n %{name}-%{version} -a60
296%{?PATCH60:%patch60 -p1}
297  # Build mpfr one-tree style
298  ln -s ../mpfr-%{mpfr_version} gcc-%{gcc_pkgvers}/mpfr
299%endif
300
301%if 0%{?_build_mpc}
302%setup -q -T -D -n %{name}-%{version} -a61
303%{?PATCH61:%patch61 -p1}
304  # Build mpc one-tree style
305  ln -s ../mpc-%{mpc_version} gcc-%{gcc_pkgvers}/mpc
306%endif
307
308%if 0%{?_build_gmp}
309%setup -q -T -D -n %{name}-%{version} -a62
310%{?PATCH62:%patch62 -p1}
311  # Build gmp one-tree style
312  ln -s ../gmp-%{gmp_version} gcc-%{gcc_pkgvers}/gmp
313%endif
314
315%if 0%{?_build_libelf}
316%setup -q -T -D -n %{name}-%{version} -a63
317%{?PATCH63:%patch63 -p1}
318  # Build libelf one-tree style
319  ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
320%endif
321
322
323  # Fix timestamps
324  cd gcc-%{gcc_pkgvers}
325  contrib/gcc_update --touch
326  cd ..
327%build
328  mkdir -p build
329
330  cd build
331
332  languages="c"
333  languages="$languages,c++"
334  languages="$languages,fortran"
335  languages="$languages,objc"
336%if "%{_build}" != "%{_host}"
337  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
338  CC="%{_host}-gcc ${RPM_OPT_FLAGS}" \
339%else
340# gcc is not ready to be compiled with -std=gnu99
341  CC=$(echo "%{__cc} ${RPM_OPT_FLAGS}" | sed -e 's,-std=gnu99 ,,') \
342%endif
343  ../gcc-%{gcc_pkgvers}/configure \
344    --prefix=%{_prefix} \
345    --bindir=%{_bindir} \
346    --exec_prefix=%{_exec_prefix} \
347    --includedir=%{_includedir} \
348    --libdir=%{_gcclibdir} \
349    --libexecdir=%{_libexecdir} \
350    --mandir=%{_mandir} \
351    --infodir=%{_infodir} \
352    --datadir=%{_datadir} \
353    --build=%_build --host=%_host \
354    --target=i586-pc-freebsd6.4 \
355    --disable-libstdcxx-pch \
356    --with-gnu-as --with-gnu-ld --verbose \
357    --with-system-zlib \
358    --disable-nls --without-included-gettext \
359    --disable-win32-registry \
360    --enable-version-specific-runtime-libs \
361    --enable-threads \
362    --with-sysroot=%{_exec_prefix}/i586-pc-freebsd6.4/sys-root \
363    %{?with_lto:--enable-lto}%{!?with_lto:--disable-lto} \
364    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
365    --enable-languages="$languages" $optargs
366
367%if "%_host" != "%_build"
368  # Bug in gcc-3.2.1:
369  # Somehow, gcc doesn't get syslimits.h right for Cdn-Xs
370  mkdir -p gcc/include
371  cp ../gcc-%{gcc_pkgvers}/gcc/gsyslimits.h gcc/include/syslimits.h
372%endif
373
374  make %{?_smp_mflags} all
375  cd ..
376
377%install
378  rm -rf $RPM_BUILD_ROOT
379
380  cd build
381
382  make DESTDIR=$RPM_BUILD_ROOT install
383  cd ..
384
385
386%if "%{gcc_version}" <= "4.1.2"
387# Misplaced header file
388  if test -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h; then
389    mv $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h \
390      $RPM_BUILD_ROOT%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/
391  fi
392%endif
393
394  # host library
395%if "%{gcc_version}" >= "4.2.0"
396  # libiberty doesn't honor --libdir, but always installs to a
397  # magically guessed _libdir
398  rm -f  ${RPM_BUILD_ROOT}%{_libdir}/libiberty.a
399%else
400  # libiberty installs to --libdir=...
401  rm -f ${RPM_BUILD_ROOT}%{_gcclibdir}/libiberty.a
402%endif
403
404  # We use the version from binutils
405  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd6.4-c++filt%{_exeext}
406
407
408# Conflict with a native GCC's infos
409  rm -rf $RPM_BUILD_ROOT%{_infodir}
410
411# Conflict with a native GCC's man pages
412  rm -rf $RPM_BUILD_ROOT%{_mandir}/man7
413
414  # Bug in gcc-3.4.0pre
415  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd6.4-i586-pc-freebsd6.4-gcjh%{_exeext}
416
417  # Bug in gcc-3.3.x/gcc-3.4.x: Despite we don't need fixincludes, it installs
418  # the fixinclude-install-tools
419  rm -rf ${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/install-tools
420  rm -rf ${RPM_BUILD_ROOT}%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/install-tools
421
422  # Bug in gcc > 4.1.0: Installs an unused, empty directory
423  if test -d ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd6.4/include/bits; then
424    rmdir ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd6.4/include/bits
425  fi
426
427  # gcc >= 4.5.0: installs weird libstdc++ python bindings.
428%if ! %{with pygdb}
429  if test -d ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python; then
430    rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python/libstdcxx
431  fi
432%endif
433
434  # Collect multilib subdirectories
435  multilibs=`build/gcc/xgcc -Bbuild/gcc/ --print-multi-lib | sed -e 's,;.*$,,'`
436
437
438  rm -f dirs ;
439  echo "%defattr(-,root,root,-)" >> dirs
440  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}"
441  for i in $multilibs; do
442    case $i in
443    \.) ;; # ignore, handled elsewhere
444    *)  echo "%dir ${TGTDIR}/$i" >> dirs
445      ;;
446    esac
447  done
448
449  # Collect files to go into different packages
450  cp dirs build/files.gcc
451  cp dirs build/files.gfortran
452  cp dirs build/files.objc
453  cp dirs build/files.gcj
454  cp dirs build/files.g++
455
456  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}"
457  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
458  for i in $f; do
459    case $i in
460    *lib*.la) rm ${RPM_BUILD_ROOT}/$i ;; # ignore: gcc produces bogus libtool libs
461    *f771) ;;
462    *f951) ;;
463    *cc1) ;;
464    *cc1obj) ;;
465    *cc1plus) ;; # ignore: explicitly put into rpm elsewhere
466    *collect2) ;;
467    *libobjc*) echo "$i" >> build/files.objc ;;
468    *include/objc*) ;;
469    *include/g++*);;
470    *include/c++*);;
471    *include-fixed/*);;
472    *finclude/*);;
473    *adainclude*);;
474    *adalib*);;
475    *gnat1);;
476    *jc1) ;;
477    *jvgenmain) ;;
478    */libgfortran*.*) echo "$i" >> build/files.gfortran ;;
479    %{!?with_pygdb:*/libstdc++*gdb.py*) rm ${RPM_BUILD_ROOT}/$i ;;} # ignore for now
480    %{?with_pygdb:*/libstdc++*gdb.py*) >> build/files.g++ ;;}
481    */libstdc++.*) echo "$i" >> build/files.g++ ;;
482    */libsupc++.*) echo "$i" >> build/files.g++ ;;
483    *) echo "$i" >> build/files.gcc ;;
484    esac
485  done
486
487  TGTDIR="%{_exec_prefix}/i586-pc-freebsd6.4/lib"
488  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
489  for i in $f; do
490    case $i in
491    *lib*.la) rm ${RPM_BUILD_ROOT}/$i;; # ignore - gcc produces bogus libtool libs
492    *libiberty.a) rm ${RPM_BUILD_ROOT}/$i ;; # ignore - GPL'ed
493# all other files belong to newlib
494    *) echo "$i" >> build/files.newlib ;;
495    esac
496  done
497# Extract %%__os_install_post into os_install_post~
498cat << \EOF > os_install_post~
499%__os_install_post
500EOF
501
502# Generate customized brp-*scripts
503cat os_install_post~ | while read a x y; do
504case $a in
505# Prevent brp-strip* from trying to handle foreign binaries
506*/brp-strip*)
507  b=$(basename $a)
508  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
509  chmod a+x $b
510  ;;
511esac
512done
513
514sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
515< os_install_post~ > os_install_post
516%define __os_install_post . ./os_install_post
517
518
519cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
520#!/bin/sh
521grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd6.4/(lib|include|sys-root)' \
522  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd6.4/'} | %__find_provides
523EOF
524chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
525%define __find_provides %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
526
527cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
528#!/bin/sh
529grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd6.4/(lib|include|sys-root)' \
530  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd6.4/'} | %__find_requires
531EOF
532chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
533%define __find_requires %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
534
535%ifnarch noarch
536# Extract %%__debug_install_post into debug_install_post~
537cat << \EOF > debug_install_post~
538%__debug_install_post
539EOF
540
541# Generate customized debug_install_post script
542cat debug_install_post~ | while read a x y; do
543case $a in
544# Prevent find-debuginfo.sh* from trying to handle foreign binaries
545*/find-debuginfo.sh)
546  b=$(basename $a)
547  sed -e 's,find "$RPM_BUILD_ROOT" !,find "$RPM_BUILD_ROOT"%_bindir "$RPM_BUILD_ROOT"%_libexecdir !,' $a > $b
548  chmod a+x $b
549  ;;
550esac
551done
552
553sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
554< debug_install_post~ > debug_install_post
555%define __debug_install_post . ./debug_install_post
556
557%endif
558
559%clean
560  rm -rf $RPM_BUILD_ROOT
561
562# ==============================================================
563# i586-pc-freebsd6.4-gcc
564# ==============================================================
565# %package -n i586-pc-freebsd6.4-gcc
566# Summary:        GNU cc compiler for i586-pc-freebsd6.4
567# Group:          Development/Tools
568# Version:        %{gcc_rpmvers}
569# Requires:       i586-pc-freebsd6.4-binutils
570# License:      GPL
571
572# %if %build_infos
573# Requires:      gcc-common
574# %endif
575
576%description -n i586-pc-freebsd6.4-gcc
577GNU cc compiler for i586-pc-freebsd6.4.
578
579# ==============================================================
580# i586-pc-freebsd6.4-gcc-libgcc
581# ==============================================================
582%package -n i586-pc-freebsd6.4-gcc-libgcc
583Summary:        libgcc for i586-pc-freebsd6.4-gcc
584Group:          Development/Tools
585Version:        %{gcc_rpmvers}
586%{?_with_noarch_subpackages:BuildArch: noarch}
587License:        GPL
588
589%description -n i586-pc-freebsd6.4-gcc-libgcc
590libgcc i586-pc-freebsd6.4-gcc.
591
592
593%files -n i586-pc-freebsd6.4-gcc
594%defattr(-,root,root)
595
596%{_mandir}/man1/i586-pc-freebsd6.4-gcc.1*
597%{_mandir}/man1/i586-pc-freebsd6.4-cpp.1*
598%{_mandir}/man1/i586-pc-freebsd6.4-gcov.1*
599
600%{_bindir}/i586-pc-freebsd6.4-cpp%{_exeext}
601%{_bindir}/i586-pc-freebsd6.4-gcc%{_exeext}
602%{_bindir}/i586-pc-freebsd6.4-gcc-%{gcc_version}%{_exeext}
603%{_bindir}/i586-pc-freebsd6.4-gcov%{_exeext}
604%{_bindir}/i586-pc-freebsd6.4-gccbug
605
606%dir %{_libexecdir}/gcc
607%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
608%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
609%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/cc1%{_exeext}
610%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/collect2%{_exeext}
611%if "%{gcc_version}" >= "4.5.0"
612%{?with_lto:%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/lto%{_exeext}}
613%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/lto-wrapper%{_exeext}
614%endif
615
616%files -n i586-pc-freebsd6.4-gcc-libgcc -f build/files.gcc
617%defattr(-,root,root)
618%dir %{_gcclibdir}/gcc
619%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
620%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
621%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include
622
623%if "%{gcc_version}" > "4.0.3"
624%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/ssp
625%endif
626
627%if "%{gcc_version}" >= "4.3.0"
628%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include-fixed
629%endif
630
631# ==============================================================
632# i586-pc-freebsd6.4-gcc-c++
633# ==============================================================
634%package -n i586-pc-freebsd6.4-gcc-c++
635Summary:        GCC c++ compiler for i586-pc-freebsd6.4
636Group:          Development/Tools
637Version:        %{gcc_rpmvers}
638License:        GPL
639Requires:       i586-pc-freebsd6.4-gcc-libstdc++ = %{gcc_rpmvers}-%{release}
640
641%if "%{_build}" != "%{_host}"
642BuildRequires:  i586-pc-freebsd6.4-gcc-c++ = %{gcc_rpmvers}
643%endif
644
645Requires:       i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}-%{release}
646
647%description -n i586-pc-freebsd6.4-gcc-c++
648GCC c++ compiler for i586-pc-freebsd6.4.
649
650
651%package -n i586-pc-freebsd6.4-gcc-libstdc++
652Summary:        libstdc++ for i586-pc-freebsd6.4
653Group:          Development/Tools
654Version:        %{gcc_rpmvers}
655%{?_with_noarch_subpackages:BuildArch: noarch}
656License:        GPL
657
658%description -n i586-pc-freebsd6.4-gcc-libstdc++
659%{summary}
660
661
662%files -n i586-pc-freebsd6.4-gcc-c++
663%defattr(-,root,root)
664
665%{_mandir}/man1/i586-pc-freebsd6.4-g++.1*
666
667%{_bindir}/i586-pc-freebsd6.4-c++%{_exeext}
668%{_bindir}/i586-pc-freebsd6.4-g++%{_exeext}
669
670%dir %{_libexecdir}/gcc
671%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
672%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
673%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/cc1plus%{_exeext}
674
675
676%files -n i586-pc-freebsd6.4-gcc-libstdc++ -f build/files.g++
677%defattr(-,root,root)
678%dir %{_gcclibdir}/gcc
679%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
680%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
681%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include
682%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/c++
683
684# ==============================================================
685# i586-pc-freebsd6.4-gcc-gfortran
686# ==============================================================
687%package -n i586-pc-freebsd6.4-gcc-gfortran
688Summary:        Fortran 95 support for i586-pc-freebsd6.4-gcc
689Group:          Development/Tools
690Version:        %{gcc_rpmvers}
691License:        GPL
692
693Requires:       i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}-%{release}
694Requires:       i586-pc-freebsd6.4-gcc-libgfortran = %{gcc_rpmvers}-%{release}
695
696%description -n i586-pc-freebsd6.4-gcc-gfortran
697GCC fortran compiler for i586-pc-freebsd6.4.
698
699%files -n i586-pc-freebsd6.4-gcc-gfortran
700%defattr(-,root,root)
701%{_bindir}/i586-pc-freebsd6.4-gfortran%{_exeext}
702
703%{_mandir}/man1/i586-pc-freebsd6.4-gfortran.1*
704
705%dir %{_libexecdir}/gcc
706%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
707%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
708%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/f951%{_exeext}
709
710# ==============================================================
711# i586-pc-freebsd6.4-gcc-libgfortran
712# ==============================================================
713%package -n i586-pc-freebsd6.4-gcc-libgfortran
714Summary:        Fortran 95 support libraries for i586-pc-freebsd6.4-gcc
715Group:          Development/Tools
716Version:        %{gcc_rpmvers}
717%{?_with_noarch_subpackages:BuildArch: noarch}
718License:        GPL
719
720%description -n i586-pc-freebsd6.4-gcc-libgfortran
721%{summary}
722
723%files -n i586-pc-freebsd6.4-gcc-libgfortran -f build/files.gfortran
724%defattr(-,root,root)
725%dir %{_gcclibdir}/gcc
726%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
727%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
728%if "%{gcc_version}" >= "4.2.0"
729%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/finclude
730%endif
731
732# ==============================================================
733# i586-pc-freebsd6.4-gcc-objc
734# ==============================================================
735%package -n i586-pc-freebsd6.4-gcc-objc
736Summary:        Objective C support for i586-pc-freebsd6.4-gcc
737Group:          Development/Tools
738Version:        %{gcc_rpmvers}
739License:        GPL
740
741Requires:       i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}-%{release}
742Requires:       i586-pc-freebsd6.4-gcc-libobjc = %{gcc_rpmvers}-%{release}
743
744%description -n i586-pc-freebsd6.4-gcc-objc
745GCC objc compiler for i586-pc-freebsd6.4.
746
747%files -n i586-pc-freebsd6.4-gcc-objc
748%defattr(-,root,root)
749%dir %{_libexecdir}/gcc
750%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
751%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
752%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/cc1obj%{_exeext}
753
754# ==============================================================
755# i586-pc-freebsd6.4-gcc-libobjc
756# ==============================================================
757%package -n i586-pc-freebsd6.4-gcc-libobjc
758Summary:        Objective C support for i586-pc-freebsd6.4-gcc
759Group:          Development/Tools
760Version:        %{gcc_rpmvers}
761%{?_with_noarch_subpackages:BuildArch: noarch}
762License:        GPL
763
764%description -n i586-pc-freebsd6.4-gcc-libobjc
765Support libraries for GCC's objc compiler for i586-pc-freebsd6.4.
766
767%files -n i586-pc-freebsd6.4-gcc-libobjc -f build/files.objc
768%defattr(-,root,root)
769%dir %{_gcclibdir}/gcc
770%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
771%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
772%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include
773%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/objc
774
Note: See TracBrowser for help on using the repository browser.