source: rtems/contrib/crossrpms/freebsd6.4/i586/i586-pc-freebsd6.4-gcc.spec @ 814dd292

4.115
Last change on this file since 814dd292 was 814dd292, checked in by Ralf Corsepius <ralf.corsepius@…>, on 12/11/10 at 09:14:09

Regenerate.

  • Property mode set to 100644
File size: 22.2 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6
7%ifos cygwin cygwin32 mingw mingw32
8%define _exeext .exe
9%define debug_package           %{nil}
10%define _libdir                 %{_exec_prefix}/lib
11%else
12%define _exeext %{nil}
13%endif
14
15%ifos cygwin cygwin32
16%define optflags -O3 -pipe -march=i486 -funroll-loops
17%endif
18
19%ifos mingw mingw32
20%if %{defined _mingw32_cflags}
21%define optflags %{_mingw32_cflags}
22%else
23%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
24%endif
25%endif
26
27%if "%{_build}" != "%{_host}"
28%define _host_rpmprefix %{_host}-
29%else
30%define _host_rpmprefix %{nil}
31%endif
32
33
34%define gcc_pkgvers 4.5.0
35%define gcc_version 4.5.0
36%define gcc_rpmvers %{expand:%(echo "4.5.0" | tr - _ )}
37
38
39Name:           i586-pc-freebsd6.4-gcc
40Summary:        i586-pc-freebsd6.4 gcc
41
42Group:          Development/Tools
43Version:        %{gcc_rpmvers}
44Release:        0.20101211.0%{?dist}
45License:        GPL
46URL:            http://gcc.gnu.org
47BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49%define _use_internal_dependency_generator 0
50
51BuildRequires:  %{_host_rpmprefix}gcc
52
53# FIXME: Disable lto for now, to avoid dependencies on libelf
54%bcond_with lto
55
56# FIXME: Disable python gdb scripts
57# ATM, no idea how to package them
58%bcond_with pygdb
59
60# FIXME: Disable GCC-plugin
61# Bug in gcc-4.5-20100318, doesn't build them on x86_84 hosts.
62%bcond_with plugin
63
64# EXPERIMENTAL: Use gcc's stdint.h instead of newlib's
65# Should be applicable to gcc >= 4.5.0
66%bcond_with gcc_stdint
67
68# versions of libraries, we conditionally bundle if necessary
69%global mpc_version     0.8.1
70%global mpfr_version    2.4.2
71%global gmp_version     4.3.2
72%global libelf_version  0.8.13
73
74# versions of libraries these distros are known to ship
75%if 0%{?fc15}
76%global mpc_provided 0.8.3
77%global mpfr_provided 3.0.0
78%global gmp_provided 4.3.2
79%endif
80
81%if 0%{?fc14}
82%global mpc_provided 0.8.1
83%global mpfr_provided 2.4.2
84%global gmp_provided 4.3.1
85%endif
86
87%if 0%{?fc13}
88%global mpc_provided 0.8.1
89%global mpfr_provided 2.4.2
90%global gmp_provided 4.3.1
91%endif
92
93%if 0%{?el6}
94%global mpc_provided %{nil}
95%global mpfr_provided 2.4.1
96%global gmp_provided 4.3.1
97%endif
98
99%if 0%{?el5}
100%global mpc_provided %{nil}
101%global mpfr_provided %{nil}
102%global gmp_provided 4.1.4
103%endif
104
105%if 0%{?suse11_0}
106%global mpc_provided %{nil}
107%global mpfr_provided 2.3.1
108%global gmp_provided 4.2.2
109%endif
110
111%if 0%{?suse11_1}
112%global mpc_provided %{nil}
113%global mpfr_provided 2.3.2
114%global gmp_provided 4.2.3
115%endif
116
117%if 0%{?suse11_2}
118%global mpc_provided 0.7
119%global mpfr_provided 2.4.1
120%global gmp_provided 4.3.1
121%endif
122
123%if 0%{?suse11_3}
124%global mpc_provided 0.8.1
125%global mpfr_provided 2.4.2
126%global gmp_provided 4.3.2
127%endif
128
129%if 0%{?cygwin}
130%global mpc_provided 0.8
131%global mpfr_provided 2.4.1
132%global gmp_provided 4.3.1
133%endif
134
135%if 0%{?mingw32}
136%global mpc_provided 0.8.1
137%global mpfr_provided 2.4.1
138%global gmp_provided 4.3.2
139%endif
140
141%if "%{gcc_version}" >= "4.2.0"
142%define gmp_required            4.1
143%define mpfr_required           2.2.1
144%endif
145
146%if "%{gcc_version}" >= "4.3.0"
147%define gmp_required            4.1
148%define mpfr_required           2.3.1
149%endif
150
151%if "%{gcc_version}" >= "4.3.3"
152%define cloog_required          0.15
153%endif
154
155%if "%{gcc_version}" >= "4.4.0"
156%define mpfr_required           2.3.2
157%endif
158
159%if "%{gcc_version}" >= "4.5.0"
160%define mpc_required            0.8
161%if %{with lto}
162%define libelf_required         0.8.12
163%endif
164%endif
165
166%if %{defined mpc_required}
167%if "%{mpc_provided}" >= "%{mpc_required}"
168%{?fedora:BuildRequires: libmpc-devel >= %{mpc_required}}
169%{?suse:BuildRequires: mpc-devel >= %{mpc_required}}
170%if "%{_build}" != "%{_host}"
171BuildRequires:  %{_host_rpmprefix}mpc-devel >= %{mpc_required}
172%endif
173%else
174%define _build_mpc 1
175%define gmp_required            4.2
176%endif
177%endif
178
179%if %{defined gmp_required}
180%if "%{gmp_provided}" >= "%{gmp_required}"
181BuildRequires: gmp-devel >= %{gmp_required}
182%if "%{_build}" != "%{_host}"
183BuildRequires:  %{_host_rpmprefix}gmp-devel >= %{gmp_required}
184%endif
185%else
186%define _build_gmp 1
187%endif
188%endif
189
190%if %{defined libelf_required}
191%if "%{libelf_provided}" >= "%{libelf_required}"
192BuildRequires: libelf-devel >= %{libelf_required}
193%if "%{_build}" != "%{_host}"
194BuildRequires:  %{_host_rpmprefix}libelf-devel >= %{libelf_required}
195%endif
196%else
197%define _build_libelf 1
198%endif
199%endif
200
201
202%if %{defined cloog_required}
203%{?fc11:BuildRequires: cloog-ppl-devel >= %cloog_required}
204%{?fc12:BuildRequires: cloog-ppl-devel >= %cloog_required}
205%{?fc13:BuildRequires: cloog-ppl-devel >= %cloog_required}
206%{?fc14:BuildRequires: cloog-ppl-devel >= %cloog_required}
207%{?el6:BuildRequires: cloog-ppl-devel >= %cloog_required}
208%{?suse11_3:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
209%{?suse11_2:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
210%{?suse11_1:BuildRequires: cloog-devel >= %cloog_required, ppl-devel}
211%endif
212
213
214%if %{defined mpfr_required}
215%if "%{mpfr_provided}" >= "%{mpfr_required}"
216BuildRequires: mpfr-devel >= %{mpfr_required}
217%if "%{_build}" != "%{_host}"
218BuildRequires:  %{_host_rpmprefix}mpfr-devel >= %{mpfr_required}
219%endif
220%else
221%define _build_mpfr 1
222%endif
223%endif
224
225%if "%{_build}" != "%{_host}"
226BuildRequires:  i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}
227%endif
228
229%if "%{gcc_version}" >= "4.2.0"
230BuildRequires:  flex bison
231%endif
232
233
234BuildRequires:  texinfo >= 4.2
235BuildRequires:  i586-pc-freebsd6.4-binutils
236BuildRequires:  i586-pc-freebsd6.4-sys-root
237
238Requires:       i586-pc-freebsd6.4-binutils
239Requires:       i586-pc-freebsd6.4-sys-root
240Requires:       i586-pc-freebsd6.4-gcc-libgcc = %{gcc_rpmvers}-%{release}
241
242%if "%{gcc_version}" >= "4.5.0"
243BuildRequires:  zlib-devel
244%if "%{_build}" != "%{_host}"
245BuildRequires:  %{_host_rpmprefix}zlib-devel
246%endif
247%else
248%endif
249
250%global _gcclibdir %{_prefix}/lib
251
252Source0:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-core-%{gcc_pkgvers}.tar.bz2
253%{?_without_sources:NoSource:   0}
254
255Source1:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-g++-%{gcc_pkgvers}.tar.bz2
256%{?_without_sources:NoSource:   1}
257
258Source2:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-fortran-%{gcc_pkgvers}.tar.bz2
259%{?_without_sources:NoSource:   2}
260
261Source5:        ftp://ftp.gnu.org/gnu/gcc/gcc-%{gcc_version}/gcc-objc-%{gcc_pkgvers}.tar.bz2
262%{?_without_sources:NoSource:   5}
263
264%if 0%{?_build_mpfr}
265Source60:    http://www.mpfr.org/mpfr-%{mpfr_version}/mpfr-%{mpfr_version}.tar.bz2
266%endif
267
268%if 0%{?_build_mpc}
269Source61:    http://www.multiprecision.org/mpc/download/mpc-%{mpc_version}.tar.gz
270%endif
271
272%if 0%{?_build_gmp}
273Source62:    ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
274%endif
275
276%if 0%{?_build_libelf}
277Source63:    http://www.mr511.de/software/libelf-%{libelf_version}.tar.gz
278%endif
279
280%description
281Cross gcc for i586-pc-freebsd6.4.
282
283%prep
284%setup -c -T -n %{name}-%{version}
285
286%setup -q -T -D -n %{name}-%{version} -a0
287cd gcc-%{gcc_pkgvers}
288%{?PATCH0:%patch0 -p1}
289cd ..
290
291%setup -q -T -D -n %{name}-%{version} -a1
292cd gcc-%{gcc_pkgvers}
293%{?PATCH1:%patch1 -p1}
294cd ..
295
296%setup -q -T -D -n %{name}-%{version} -a2
297%{?PATCH2:%patch2 -p0}
298
299
300
301%setup -q -T -D -n %{name}-%{version} -a5
302%{?PATCH5:%patch5 -p0}
303
304%if %{with gcc_stdint}
305sed -i -e '/thread_file=.*rtems/,/use_gcc_stdint=wrap/ { s/use_gcc_stdint=wrap/use_gcc_stdint=provide/}' gcc-%{gcc_pkgvers}/gcc/config.gcc
306%endif
307
308
309%if 0%{?_build_mpfr}
310%setup -q -T -D -n %{name}-%{version} -a60
311%{?PATCH60:%patch60 -p1}
312  # Build mpfr one-tree style
313  ln -s ../mpfr-%{mpfr_version} gcc-%{gcc_pkgvers}/mpfr
314%endif
315
316%if 0%{?_build_mpc}
317%setup -q -T -D -n %{name}-%{version} -a61
318%{?PATCH61:%patch61 -p1}
319  # Build mpc one-tree style
320  ln -s ../mpc-%{mpc_version} gcc-%{gcc_pkgvers}/mpc
321%endif
322
323%if 0%{?_build_gmp}
324%setup -q -T -D -n %{name}-%{version} -a62
325%{?PATCH62:%patch62 -p1}
326  # Build gmp one-tree style
327  ln -s ../gmp-%{gmp_version} gcc-%{gcc_pkgvers}/gmp
328%endif
329
330%if 0%{?_build_libelf}
331%setup -q -T -D -n %{name}-%{version} -a63
332%{?PATCH63:%patch63 -p1}
333  # Build libelf one-tree style
334  ln -s ../libelf-%{libelf_version} gcc-%{gcc_pkgvers}/libelf
335%endif
336
337
338  # Fix timestamps
339  cd gcc-%{gcc_pkgvers}
340  contrib/gcc_update --touch
341  cd ..
342%build
343  mkdir -p build
344
345  cd build
346
347  languages="c"
348  languages="$languages,c++"
349  languages="$languages,fortran"
350  languages="$languages,objc"
351%if "%{_build}" != "%{_host}"
352  CFLAGS_FOR_BUILD="-g -O2 -Wall" \
353  CC="%{_host}-gcc ${RPM_OPT_FLAGS}" \
354%else
355# gcc is not ready to be compiled with -std=gnu99
356  CC=$(echo "%{__cc} ${RPM_OPT_FLAGS}" | sed -e 's,-std=gnu99 ,,') \
357%endif
358  ../gcc-%{gcc_pkgvers}/configure \
359    --prefix=%{_prefix} \
360    --bindir=%{_bindir} \
361    --exec_prefix=%{_exec_prefix} \
362    --includedir=%{_includedir} \
363    --libdir=%{_gcclibdir} \
364    --libexecdir=%{_libexecdir} \
365    --mandir=%{_mandir} \
366    --infodir=%{_infodir} \
367    --datadir=%{_datadir} \
368    --build=%_build --host=%_host \
369    --target=i586-pc-freebsd6.4 \
370    --disable-libstdcxx-pch \
371    --with-gnu-as --with-gnu-ld --verbose \
372    --with-system-zlib \
373    --disable-nls --without-included-gettext \
374    --disable-win32-registry \
375    --enable-version-specific-runtime-libs \
376    --enable-threads \
377    --with-sysroot=%{_exec_prefix}/i586-pc-freebsd6.4/sys-root \
378    %{?with_lto:--enable-lto}%{!?with_lto:--disable-lto} \
379    %{?with_plugin:--enable-plugin}%{!?with_plugin:--disable-plugin} \
380    --enable-languages="$languages" $optargs
381
382%if "%_host" != "%_build"
383  # Bug in gcc-3.2.1:
384  # Somehow, gcc doesn't get syslimits.h right for Cdn-Xs
385  mkdir -p gcc/include
386  cp ../gcc-%{gcc_pkgvers}/gcc/gsyslimits.h gcc/include/syslimits.h
387%endif
388
389  make %{?_smp_mflags} all
390  cd ..
391
392%install
393  rm -rf $RPM_BUILD_ROOT
394
395  cd build
396
397  make DESTDIR=$RPM_BUILD_ROOT install
398  cd ..
399
400
401%if "%{gcc_version}" <= "4.1.2"
402# Misplaced header file
403  if test -f $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h; then
404    mv $RPM_BUILD_ROOT%{_includedir}/mf-runtime.h \
405      $RPM_BUILD_ROOT%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/
406  fi
407%endif
408
409  # host library
410%if "%{gcc_version}" >= "4.2.0"
411  # libiberty doesn't honor --libdir, but always installs to a
412  # magically guessed _libdir
413  rm -f  ${RPM_BUILD_ROOT}%{_libdir}/libiberty.a
414%else
415  # libiberty installs to --libdir=...
416  rm -f ${RPM_BUILD_ROOT}%{_gcclibdir}/libiberty.a
417%endif
418
419  # We use the version from binutils
420  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd6.4-c++filt%{_exeext}
421
422
423# Conflict with a native GCC's infos
424  rm -rf $RPM_BUILD_ROOT%{_infodir}
425
426# Conflict with a native GCC's man pages
427  rm -rf $RPM_BUILD_ROOT%{_mandir}/man7
428
429  # Bug in gcc-3.4.0pre
430  rm -f $RPM_BUILD_ROOT%{_bindir}/i586-pc-freebsd6.4-i586-pc-freebsd6.4-gcjh%{_exeext}
431
432  # Bug in gcc-3.3.x/gcc-3.4.x: Despite we don't need fixincludes, it installs
433  # the fixinclude-install-tools
434  rm -rf ${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/install-tools
435  rm -rf ${RPM_BUILD_ROOT}%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/install-tools
436
437  # Bug in gcc > 4.1.0: Installs an unused, empty directory
438  if test -d ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd6.4/include/bits; then
439    rmdir ${RPM_BUILD_ROOT}%{_prefix}/i586-pc-freebsd6.4/include/bits
440  fi
441
442  # gcc >= 4.5.0: installs weird libstdc++ python bindings.
443%if ! %{with pygdb}
444  if test -d ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python; then
445    rm -rf ${RPM_BUILD_ROOT}%{_datadir}/gcc-%{gcc_version}/python/libstdcxx
446  fi
447%endif
448
449  # Collect multilib subdirectories
450  multilibs=`build/gcc/xgcc -Bbuild/gcc/ --print-multi-lib | sed -e 's,;.*$,,'`
451
452
453  rm -f dirs ;
454  echo "%defattr(-,root,root,-)" >> dirs
455  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}"
456  for i in $multilibs; do
457    case $i in
458    \.) ;; # ignore, handled elsewhere
459    *)  echo "%dir ${TGTDIR}/$i" >> dirs
460      ;;
461    esac
462  done
463
464  # Collect files to go into different packages
465  cp dirs build/files.gcc
466  cp dirs build/files.gfortran
467  cp dirs build/files.objc
468  cp dirs build/files.gcj
469  cp dirs build/files.g++
470
471  TGTDIR="%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}"
472  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
473  for i in $f; do
474    case $i in
475    *lib*.la) rm ${RPM_BUILD_ROOT}/$i ;; # ignore: gcc produces bogus libtool libs
476    *f771) ;;
477    *f951) ;;
478    *cc1) ;;
479    *cc1obj) ;;
480    *cc1plus) ;; # ignore: explicitly put into rpm elsewhere
481    *collect2) ;;
482    *libobjc*) echo "$i" >> build/files.objc ;;
483    *include/objc*) ;;
484    *include/g++*);;
485    *include/c++*);;
486    *include-fixed/*);;
487    *finclude/*);;
488    *adainclude*);;
489    *adalib*);;
490    *gnat1);;
491    *jc1) ;;
492    *jvgenmain) ;;
493    */libgfortran*.*) echo "$i" >> build/files.gfortran ;;
494    %{!?with_pygdb:*/libstdc++*gdb.py*) rm ${RPM_BUILD_ROOT}/$i ;;} # ignore for now
495    %{?with_pygdb:*/libstdc++*gdb.py*) >> build/files.g++ ;;}
496    */libstdc++.*) echo "$i" >> build/files.g++ ;;
497    */libsupc++.*) echo "$i" >> build/files.g++ ;;
498    *) echo "$i" >> build/files.gcc ;;
499    esac
500  done
501
502  TGTDIR="%{_exec_prefix}/i586-pc-freebsd6.4/lib"
503  f=`find ${RPM_BUILD_ROOT}${TGTDIR} ! -type d -print | sed -e "s,^$RPM_BUILD_ROOT,,g"`;
504  for i in $f; do
505    case $i in
506    *lib*.la) rm ${RPM_BUILD_ROOT}/$i;; # ignore - gcc produces bogus libtool libs
507    *libiberty.a) rm ${RPM_BUILD_ROOT}/$i ;; # ignore - GPL'ed
508# all other files belong to newlib
509    *) echo "$i" >> build/files.newlib ;;
510    esac
511  done
512# Extract %%__os_install_post into os_install_post~
513cat << \EOF > os_install_post~
514%__os_install_post
515EOF
516
517# Generate customized brp-*scripts
518cat os_install_post~ | while read a x y; do
519case $a in
520# Prevent brp-strip* from trying to handle foreign binaries
521*/brp-strip*)
522  b=$(basename $a)
523  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
524  chmod a+x $b
525  ;;
526esac
527done
528
529sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
530< os_install_post~ > os_install_post
531%define __os_install_post . ./os_install_post
532
533
534cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
535#!/bin/sh
536grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd6.4/(lib|include|sys-root)' \
537  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd6.4/'} | %__find_provides
538EOF
539chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
540%define __find_provides %{_builddir}/%{name}-%{gcc_rpmvers}/find-provides
541
542cat << EOF > %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
543#!/bin/sh
544grep -E -v '^${RPM_BUILD_ROOT}%{_exec_prefix}/i586-pc-freebsd6.4/(lib|include|sys-root)' \
545  %{?_gcclibdir:| grep -v '^${RPM_BUILD_ROOT}%{_gcclibdir}/gcc/i586-pc-freebsd6.4/'} | %__find_requires
546EOF
547chmod +x %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
548%define __find_requires %{_builddir}/%{name}-%{gcc_rpmvers}/find-requires
549
550%ifnarch noarch
551# Extract %%__debug_install_post into debug_install_post~
552cat << \EOF > debug_install_post~
553%__debug_install_post
554EOF
555
556# Generate customized debug_install_post script
557cat debug_install_post~ | while read a x y; do
558case $a in
559# Prevent find-debuginfo.sh* from trying to handle foreign binaries
560*/find-debuginfo.sh)
561  b=$(basename $a)
562  sed -e 's,find "$RPM_BUILD_ROOT" !,find "$RPM_BUILD_ROOT"%_bindir "$RPM_BUILD_ROOT"%_libexecdir !,' $a > $b
563  chmod a+x $b
564  ;;
565esac
566done
567
568sed -e 's,^[ ]*/usr/lib/rpm/find-debuginfo.sh,./find-debuginfo.sh,' \
569< debug_install_post~ > debug_install_post
570%define __debug_install_post . ./debug_install_post
571
572%endif
573
574%clean
575  rm -rf $RPM_BUILD_ROOT
576
577# ==============================================================
578# i586-pc-freebsd6.4-gcc
579# ==============================================================
580# %package -n i586-pc-freebsd6.4-gcc
581# Summary:        GNU cc compiler for i586-pc-freebsd6.4
582# Group:          Development/Tools
583# Version:        %{gcc_rpmvers}
584# Requires:       i586-pc-freebsd6.4-binutils
585# License:      GPL
586
587# %if %build_infos
588# Requires:      gcc-common
589# %endif
590
591%description -n i586-pc-freebsd6.4-gcc
592GNU cc compiler for i586-pc-freebsd6.4.
593
594# ==============================================================
595# i586-pc-freebsd6.4-gcc-libgcc
596# ==============================================================
597%package -n i586-pc-freebsd6.4-gcc-libgcc
598Summary:        libgcc for i586-pc-freebsd6.4-gcc
599Group:          Development/Tools
600Version:        %{gcc_rpmvers}
601%{?_with_noarch_subpackages:BuildArch: noarch}
602License:        GPL
603
604%description -n i586-pc-freebsd6.4-gcc-libgcc
605libgcc i586-pc-freebsd6.4-gcc.
606
607
608%files -n i586-pc-freebsd6.4-gcc
609%defattr(-,root,root)
610
611%{_mandir}/man1/i586-pc-freebsd6.4-gcc.1*
612%{_mandir}/man1/i586-pc-freebsd6.4-cpp.1*
613%{_mandir}/man1/i586-pc-freebsd6.4-gcov.1*
614
615%{_bindir}/i586-pc-freebsd6.4-cpp%{_exeext}
616%{_bindir}/i586-pc-freebsd6.4-gcc%{_exeext}
617%{_bindir}/i586-pc-freebsd6.4-gcc-%{gcc_version}%{_exeext}
618%{_bindir}/i586-pc-freebsd6.4-gcov%{_exeext}
619%{_bindir}/i586-pc-freebsd6.4-gccbug
620
621%dir %{_libexecdir}/gcc
622%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
623%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
624%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/cc1%{_exeext}
625%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/collect2%{_exeext}
626%if "%{gcc_version}" >= "4.5.0"
627%{?with_lto:%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/lto%{_exeext}}
628%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/lto-wrapper%{_exeext}
629%endif
630
631%files -n i586-pc-freebsd6.4-gcc-libgcc -f build/files.gcc
632%defattr(-,root,root)
633%dir %{_gcclibdir}/gcc
634%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
635%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
636%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include
637
638%if "%{gcc_version}" > "4.0.3"
639%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/ssp
640%endif
641
642%if "%{gcc_version}" >= "4.3.0"
643%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include-fixed
644%endif
645
646# ==============================================================
647# i586-pc-freebsd6.4-gcc-c++
648# ==============================================================
649%package -n i586-pc-freebsd6.4-gcc-c++
650Summary:        GCC c++ compiler for i586-pc-freebsd6.4
651Group:          Development/Tools
652Version:        %{gcc_rpmvers}
653License:        GPL
654Requires:       i586-pc-freebsd6.4-gcc-libstdc++ = %{gcc_rpmvers}-%{release}
655
656%if "%{_build}" != "%{_host}"
657BuildRequires:  i586-pc-freebsd6.4-gcc-c++ = %{gcc_rpmvers}
658%endif
659
660Requires:       i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}-%{release}
661
662%description -n i586-pc-freebsd6.4-gcc-c++
663GCC c++ compiler for i586-pc-freebsd6.4.
664
665
666%package -n i586-pc-freebsd6.4-gcc-libstdc++
667Summary:        libstdc++ for i586-pc-freebsd6.4
668Group:          Development/Tools
669Version:        %{gcc_rpmvers}
670%{?_with_noarch_subpackages:BuildArch: noarch}
671License:        GPL
672
673%description -n i586-pc-freebsd6.4-gcc-libstdc++
674%{summary}
675
676
677%files -n i586-pc-freebsd6.4-gcc-c++
678%defattr(-,root,root)
679
680%{_mandir}/man1/i586-pc-freebsd6.4-g++.1*
681
682%{_bindir}/i586-pc-freebsd6.4-c++%{_exeext}
683%{_bindir}/i586-pc-freebsd6.4-g++%{_exeext}
684
685%dir %{_libexecdir}/gcc
686%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
687%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
688%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/cc1plus%{_exeext}
689
690
691%files -n i586-pc-freebsd6.4-gcc-libstdc++ -f build/files.g++
692%defattr(-,root,root)
693%dir %{_gcclibdir}/gcc
694%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
695%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
696%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include
697%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/c++
698
699# ==============================================================
700# i586-pc-freebsd6.4-gcc-gfortran
701# ==============================================================
702%package -n i586-pc-freebsd6.4-gcc-gfortran
703Summary:        Fortran 95 support for i586-pc-freebsd6.4-gcc
704Group:          Development/Tools
705Version:        %{gcc_rpmvers}
706License:        GPL
707
708Requires:       i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}-%{release}
709Requires:       i586-pc-freebsd6.4-gcc-libgfortran = %{gcc_rpmvers}-%{release}
710
711%description -n i586-pc-freebsd6.4-gcc-gfortran
712GCC fortran compiler for i586-pc-freebsd6.4.
713
714%files -n i586-pc-freebsd6.4-gcc-gfortran
715%defattr(-,root,root)
716%{_bindir}/i586-pc-freebsd6.4-gfortran%{_exeext}
717
718%{_mandir}/man1/i586-pc-freebsd6.4-gfortran.1*
719
720%dir %{_libexecdir}/gcc
721%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
722%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
723%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/f951%{_exeext}
724
725# ==============================================================
726# i586-pc-freebsd6.4-gcc-libgfortran
727# ==============================================================
728%package -n i586-pc-freebsd6.4-gcc-libgfortran
729Summary:        Fortran 95 support libraries for i586-pc-freebsd6.4-gcc
730Group:          Development/Tools
731Version:        %{gcc_rpmvers}
732%{?_with_noarch_subpackages:BuildArch: noarch}
733License:        GPL
734
735%description -n i586-pc-freebsd6.4-gcc-libgfortran
736%{summary}
737
738%files -n i586-pc-freebsd6.4-gcc-libgfortran -f build/files.gfortran
739%defattr(-,root,root)
740%dir %{_gcclibdir}/gcc
741%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
742%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
743%if "%{gcc_version}" >= "4.2.0"
744%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/finclude
745%endif
746
747# ==============================================================
748# i586-pc-freebsd6.4-gcc-objc
749# ==============================================================
750%package -n i586-pc-freebsd6.4-gcc-objc
751Summary:        Objective C support for i586-pc-freebsd6.4-gcc
752Group:          Development/Tools
753Version:        %{gcc_rpmvers}
754License:        GPL
755
756Requires:       i586-pc-freebsd6.4-gcc = %{gcc_rpmvers}-%{release}
757Requires:       i586-pc-freebsd6.4-gcc-libobjc = %{gcc_rpmvers}-%{release}
758
759%description -n i586-pc-freebsd6.4-gcc-objc
760GCC objc compiler for i586-pc-freebsd6.4.
761
762%files -n i586-pc-freebsd6.4-gcc-objc
763%defattr(-,root,root)
764%dir %{_libexecdir}/gcc
765%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4
766%dir %{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
767%{_libexecdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/cc1obj%{_exeext}
768
769# ==============================================================
770# i586-pc-freebsd6.4-gcc-libobjc
771# ==============================================================
772%package -n i586-pc-freebsd6.4-gcc-libobjc
773Summary:        Objective C support for i586-pc-freebsd6.4-gcc
774Group:          Development/Tools
775Version:        %{gcc_rpmvers}
776%{?_with_noarch_subpackages:BuildArch: noarch}
777License:        GPL
778
779%description -n i586-pc-freebsd6.4-gcc-libobjc
780Support libraries for GCC's objc compiler for i586-pc-freebsd6.4.
781
782%files -n i586-pc-freebsd6.4-gcc-libobjc -f build/files.objc
783%defattr(-,root,root)
784%dir %{_gcclibdir}/gcc
785%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4
786%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}
787%dir %{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include
788%{_gcclibdir}/gcc/i586-pc-freebsd6.4/%{gcc_version}/include/objc
789
Note: See TracBrowser for help on using the repository browser.