source: rtems/contrib/crossrpms/autotools/rtems-4.11-autoconf.spec @ 9d323a9

4.115
Last change on this file since 9d323a9 was 9d323a9, checked in by Ralf Corsepius <ralf.corsepius@…>, on 07/08/10 at 13:01:04

autoconf-2.66

  • Property mode set to 100644
File size: 5.3 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.11
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define srcvers 2.66
49%define rpmvers %{expand:%(echo "2.66" | tr - _ )}
50
51%define name                    rtems-4.11-autoconf
52
53
54Name:           %{name}
55License:        GPL
56URL:            http://www.gnu.org/software/autoconf
57Group:          Development/Tools
58Version:        %{rpmvers}
59Release:        1%{?dist}
60Summary:        Tool for automatically generating GNU style Makefile.in's
61
62BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
63BuildArch:      noarch
64BuildRequires:  perl m4 gawk emacs
65%if "%{version}" >= "2.62"
66BuildRequires:  m4 >= 1.4.5
67%endif
68Requires:       m4 gawk
69Requires(post):         /sbin/install-info
70Requires(preun):        /sbin/install-info
71
72Source0: ftp://ftp.gnu.org/gnu/autoconf/autoconf-%{srcvers}.tar.bz2
73# Fedora's patch to fix
74# http://lists.gnu.org/archive/html/autoconf/2010-07/msg00004.html
75# http://lists.gnu.org/archive/html/bug-autoconf/2010-07/msg00012.html
76Patch0: autoconf-2.66-611661.patch
77
78
79
80%description
81GNU's Autoconf is a tool for configuring source code and Makefiles.
82Using Autoconf, programmers can create portable and configurable
83packages, since the person building the package is allowed to
84specify various configuration options.
85You should install Autoconf if you are developing software and you'd
86like to use it to create shell scripts which will configure your
87source code packages.
88Note that the Autoconf package is not required for the end user who
89may be configuring software with an Autoconf-generated script;
90Autoconf is only required for the generation of the scripts, not
91their use.
92
93%prep
94%setup -q -n autoconf-%{srcvers}
95%{?PATCH0:%patch0 -p1}
96
97# Work around rpm inserting bogus perl-module deps
98cat << \EOF > %{name}-prov
99#!/bin/sh
100%{__perl_provides} $* |\
101    sed -e '/^perl(Autom4te/d'
102EOF
103%define __perl_provides %{_builddir}/autoconf-%{srcvers}/%{name}-prov
104chmod +x %{__perl_provides}
105
106cat << \EOF > %{name}-requ
107#!/bin/sh
108%{__perl_requires} $* |\
109    sed -e '/^perl(Autom4te/d'
110EOF
111%define __perl_requires %{_builddir}/autoconf-%{srcvers}/%{name}-requ
112chmod +x %{__perl_requires}
113
114%build
115./configure --prefix=%{_prefix} --infodir=%{_infodir} --mandir=%{_mandir} \
116  --bindir=%{_bindir} --datadir=%{_datadir}
117make
118
119%check
120%if "%{_build}" == "%{_host}"
121# test 193 fails sporadically
122# test 199 fails deterministically
123make check TESTSUITEFLAGS='-192 194-198 200-'
124%endif
125
126%install
127rm -rf "${RPM_BUILD_ROOT}"
128make DESTDIR=${RPM_BUILD_ROOT} install
129
130# Create this directory to prevent the corresponding line
131# in %%files below to fail
132mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp
133
134# RTEMS's standards.info comes from binutils
135rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
136
137rm -f $RPM_BUILD_ROOT%{_infodir}/dir
138touch $RPM_BUILD_ROOT%{_infodir}/dir
139
140# Extract %%__os_install_post into os_install_post~
141cat << \EOF > os_install_post~
142%__os_install_post
143EOF
144
145# Generate customized brp-*scripts
146cat os_install_post~ | while read a x y; do
147case $a in
148# Prevent brp-strip* from trying to handle foreign binaries
149*/brp-strip*)
150  b=$(basename $a)
151  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
152  chmod a+x $b
153  ;;
154# Fix up brp-compress to handle %%_prefix != /usr
155*/brp-compress*)
156  b=$(basename $a)
157  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
158  chmod a+x $b
159  ;;
160esac
161done
162
163sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
164  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
165< os_install_post~ > os_install_post
166%define __os_install_post . ./os_install_post
167
168%clean
169  rm -rf $RPM_BUILD_ROOT
170
171%post
172/sbin/install-info  --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz ||:
173
174%preun
175if [ $1 -eq 0 ]; then
176  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz ||:
177fi   
178
179%files
180%defattr(-,root,root)
181# %doc AUTHORS COPYING ChangeLog NEWS README THANKS
182%dir %{_bindir}
183%{_bindir}/*
184%dir %{_infodir}
185%ghost %{_infodir}/dir
186
187%{_infodir}/autoconf.info*
188%dir %{_mandir}
189%dir %{_mandir}/man1
190%{_mandir}/man1/*
191%dir %{_datadir}
192%{_datadir}/autoconf
193%exclude %{_datadir}/emacs/site-lisp
Note: See TracBrowser for help on using the repository browser.