source: rtems/contrib/crossrpms/autotools/rtems-4.10-autoconf.spec @ 64101ef

4.104.115
Last change on this file since 64101ef was 64101ef, checked in by Ralf Corsepius <ralf.corsepius@…>, on 11/23/09 at 03:33:52

autoconf-2.65.

  • Property mode set to 100644
File size: 4.9 KB
Line 
1#
2# Please send bugfixes or comments to
3#       http://www.rtems.org/bugzilla
4#
5
6%define _prefix                 /opt/rtems-4.10
7%define _exec_prefix            %{_prefix}
8%define _bindir                 %{_exec_prefix}/bin
9%define _sbindir                %{_exec_prefix}/sbin
10%define _libexecdir             %{_exec_prefix}/libexec
11%define _datarootdir            %{_prefix}/share
12%define _datadir                %{_datarootdir}
13%define _sysconfdir             %{_prefix}/etc
14%define _sharedstatedir         %{_prefix}/com
15%define _localstatedir          %{_prefix}/var
16%define _includedir             %{_prefix}/include
17%define _libdir                 %{_exec_prefix}/%{_lib}
18%define _mandir                 %{_datarootdir}/man
19%define _infodir                %{_datarootdir}/info
20%define _localedir              %{_datarootdir}/locale
21
22%ifos cygwin cygwin32 mingw mingw32
23%define _exeext .exe
24%define debug_package           %{nil}
25%define _libdir                 %{_exec_prefix}/lib
26%else
27%define _exeext %{nil}
28%endif
29
30%ifos cygwin cygwin32
31%define optflags -O3 -pipe -march=i486 -funroll-loops
32%endif
33
34%ifos mingw mingw32
35%if %{defined _mingw32_cflags}
36%define optflags %{_mingw32_cflags}
37%else
38%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
39%endif
40%endif
41
42%if "%{_build}" != "%{_host}"
43%define _host_rpmprefix %{_host}-
44%else
45%define _host_rpmprefix %{nil}
46%endif
47
48%define srcvers 2.65
49%define rpmvers %{expand:%(echo "2.65" | tr - _ )}
50
51%define name                    rtems-4.10-autoconf
52
53
54Name:           %{name}
55License:        GPL
56URL:            http://www.gnu.org/software/autoconf
57Group:          Development/Tools
58Version:        %{rpmvers}
59Release:        1%{?dist}
60Summary:        Tool for automatically generating GNU style Makefile.in's
61
62BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
63BuildArch:      noarch
64BuildRequires:  perl m4 gawk emacs
65%if "%{version}" >= "2.62"
66BuildRequires:  m4 >= 1.4.5
67%endif
68Requires:       m4 gawk
69Requires(post):         /sbin/install-info
70Requires(preun):        /sbin/install-info
71
72Source0: ftp://ftp.gnu.org/gnu/autoconf/autoconf-%{srcvers}.tar.bz2
73
74
75%description
76GNU's Autoconf is a tool for configuring source code and Makefiles.
77Using Autoconf, programmers can create portable and configurable
78packages, since the person building the package is allowed to
79specify various configuration options.
80You should install Autoconf if you are developing software and you'd
81like to use it to create shell scripts which will configure your
82source code packages.
83Note that the Autoconf package is not required for the end user who
84may be configuring software with an Autoconf-generated script;
85Autoconf is only required for the generation of the scripts, not
86their use.
87
88%prep
89%setup -q -n autoconf-%{srcvers}
90%{?PATCH0:%patch0 -p1}
91
92# Work around rpm inserting bogus perl-module deps
93cat << \EOF > %{name}-prov
94#!/bin/sh
95%{__perl_provides} $* |\
96    sed -e '/^perl(Autom4te/d'
97EOF
98%define __perl_provides %{_builddir}/autoconf-%{srcvers}/%{name}-prov
99chmod +x %{__perl_provides}
100
101cat << \EOF > %{name}-requ
102#!/bin/sh
103%{__perl_requires} $* |\
104    sed -e '/^perl(Autom4te/d'
105EOF
106%define __perl_requires %{_builddir}/autoconf-%{srcvers}/%{name}-requ
107chmod +x %{__perl_requires}
108
109%build
110./configure --prefix=%{_prefix} --infodir=%{_infodir} --mandir=%{_mandir} \
111  --bindir=%{_bindir} --datadir=%{_datadir}
112make
113
114%install
115rm -rf "${RPM_BUILD_ROOT}"
116make DESTDIR=${RPM_BUILD_ROOT} install
117
118# Create this directory to prevent the corresponding line
119# in %%files below to fail
120mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp
121
122# RTEMS's standards.info comes from binutils
123rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
124
125rm -f $RPM_BUILD_ROOT%{_infodir}/dir
126touch $RPM_BUILD_ROOT%{_infodir}/dir
127
128# Extract %%__os_install_post into os_install_post~
129cat << \EOF > os_install_post~
130%__os_install_post
131EOF
132
133# Generate customized brp-*scripts
134cat os_install_post~ | while read a x y; do
135case $a in
136# Prevent brp-strip* from trying to handle foreign binaries
137*/brp-strip*)
138  b=$(basename $a)
139  sed -e 's,find $RPM_BUILD_ROOT,find $RPM_BUILD_ROOT%_bindir $RPM_BUILD_ROOT%_libexecdir,' $a > $b
140  chmod a+x $b
141  ;;
142# Fix up brp-compress to handle %%_prefix != /usr
143*/brp-compress*)
144  b=$(basename $a)
145  sed -e 's,\./usr/,.%{_prefix}/,g' < $a > $b
146  chmod a+x $b
147  ;;
148esac
149done
150
151sed -e 's,^[ ]*/usr/lib/rpm.*/brp-strip,./brp-strip,' \
152  -e 's,^[ ]*/usr/lib/rpm.*/brp-compress,./brp-compress,' \
153< os_install_post~ > os_install_post
154%define __os_install_post . ./os_install_post
155
156%clean
157  rm -rf $RPM_BUILD_ROOT
158
159%post
160/sbin/install-info  --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz ||:
161
162%preun
163if [ $1 -eq 0 ]; then
164  /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/autoconf.info.gz ||:
165fi   
166
167%files
168%defattr(-,root,root)
169# %doc AUTHORS COPYING ChangeLog NEWS README THANKS
170%dir %{_bindir}
171%{_bindir}/*
172%dir %{_infodir}
173%ghost %{_infodir}/dir
174
175%{_infodir}/autoconf.info*
176%dir %{_mandir}
177%dir %{_mandir}/man1
178%{_mandir}/man1/*
179%dir %{_datadir}
180%{_datadir}/autoconf
181%exclude %{_datadir}/emacs/site-lisp
Note: See TracBrowser for help on using the repository browser.