source: rtems-tools/tools/gdb/python/wscript @ 01a4192

4.104.11
Last change on this file since 01a4192 was 01a4192, checked in by Adit Sahasrabudhe <asahasra@…>, on Feb 22, 2015 at 6:07:10 AM

Modified waf scripts to have a minimum python version requirement of 2.6.6, instead of 2.7.3

  • Property mode set to 100644
File size: 779 bytes
Line 
1#
2# Install the RTEMS gdb python
3#
4
5def options(opt):
6    opt.load('python')
7
8def configure(conf):
9    conf.load('python')
10    conf.check_python_version((2,6,6))
11
12def build(bld):
13    source = ['__init__.py',
14              'chains.py',
15              'classic.py',
16              'classic_printer.py',
17              'configuration.py',
18              'heaps.py',
19              'helper.py',
20              'main.py',
21              'objects.py',
22              'percpu.py',
23              'pretty.py',
24              'rtems.py',
25              'sparc.py',
26              'supercore.py',
27              'supercore_printer.py',
28              'threads.py',
29              'watchdog.py']
30    bld(features = 'py',
31        source = source,
32        install_path = '${PREFIX}/share/gdb/python/rtems')
Note: See TracBrowser for help on using the repository browser.